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About This Manual

Thank you for purchasing a Teledyne LeCroy oscilloscope. We're certain you'll be pleased with the detailed features
unigue to our instruments.

This manual shows the HDO6000B, although much of it could be applied to earlier instruments in the series. With the
introduction of later versions of the 64-bit MAUI® software, particularly version 8.3 and later, the graphical user
interface on some instruments looked very different from what was offered on earlier instruments and included
different touch screen capabilities. Despite the difference in appearance, however, the functionality is the same
unless otherwise stated. Where there are differences or limitations in capabilities, these are explained in the text.

Documentation for implementing COM Automation and remote control, and for using optional software packages
sold for Teledyne LeCroy instruments such as decoders and Serial Data Analysis software, can be downloaded from
our free technical library at: teledynelecroy.com/support/techlib

Our website maintains the most current product specifications and should be checked for updates. Detailed
specifications are listed on the product datasheet.

Note: Specifications are subject to change without notice.



http://teledynelecroy.com/support/techlib
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Safety

Safety
Symbols

These symbols appear on the instrument or in documentation to alert you to important safety concerns:

Caution of potential damage to instrument or Warning of potential bodily injury. Refer to manual. Do not
proceed until the information is fully understood and conditions are met.

Warning, risk of electric shock or burn.

Caution, contains parts/assemblies susceptible to damage by Electrostatic Discharge (ESD).

Frame or chassis terminal (ground connection).

Alternating current.

Standby power (front of instrument).

C B>

Precautions

Observe generally accepted safety procedures in addition to the precautions listed here. The overall safety of any
system incorporating this product is the responsibility of the assembler of the system.

Use proper power cord. Use only the power cord shipped with the instrument and certified for the country of use.
Maintain ground. The AC inlet ground is connected directly to the chassis of the instrument. To avoid electric shock,

connect only to a mating outlet with a safety ground contact.

Caution: Interrupting the protective conductor inside or outside the oscilloscope, or disconnecting the safety
ground terminal, creates a hazardous situation. Intentional interruption is prohibited.

Connect and disconnect properly. Do not connect/disconnect probes, test leads, or cables while they are connected
to a live voltage source.

Observe all terminal ratings. Do not apply a voltage to any input that exceeds the maximum rating of that input. Refer
to the marking next to the terminals for maximum allowed values.

Use indoors only within the operational environment listed. Do not use in wet or explosive atmospheres.
Keep product surfaces clean and dry. See Cleaning.

Do not block the cooling vents. Leave a minimum six-inch (15 cm) gap between the instrument and the nearest
object. Keep the underside clear of papers and other objects.

Exercise care when lifting and carrying. Unplug the instrument to move it. Use the built-in carrying handle.
Do not remove the covers or inside parts. Refer all maintenance to qualified service personnel.

Do not operate with suspected failures. Check body and cables regularly. If any part is damaged, cease operation
immediately and secure the instrumentfrom inadvertent use.
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Operating Environment

Temperature; 5°Cto40°C

Humidity: Maximum relative humidity (RH) 90% up to 31 °C,
decreasing linearly to 50% relative humidity at 40 °C

Altitude: Up to 10,000 ft (3,048 m) at or below 30 °C

Measuring Terminal Ratings (C1-C4 and Ext)

Maximum Input Voltage: 50 Q coupling = 5Vrms

1T MQ coupling < 400 Vpk max. (Peak AC < 10 kHz + DC)
derating at 15 dB/decade from 10 kHz to 1.6 MHz, 10 Vpk max.above 1.6 MHz

A Caution: Measuring terminals have no rated measurement category per IEC/EN 61010-1:2010. Measuring
terminals are not intended to be connected directly to supply mains.

Clearance and Ventilation

The instrument relies on forced air cooling with internal fans and vents. The internal fan control circuitry regulates
the fan speed based on the ambient temperature. This is performed automatically after start-up.

A Caution: Do not block the cooling vents.

Take care to avoid restricting the airflow to any part. In a benchtop configuration, leave a minimum of 15 cm (6
inches) around the sides between the instrument and the nearest object. The feet provide adequate bottom
clearance. Follow rackmount instructions for proper rack spacing.

Power

The instrument automatically adapts to the line voltage; manual voltage selection is not required.
AC Power Source: 100-240 VAC (+ 10%) at 50/60/400 Hz (+ 5%)

Automatic AC voltage selection

Maximum Consumption:* 320 W (320 VA)
Nominal Consumption: 220 W (220 VA)
Standby Consumption: 4W

* All PC peripherals and active probes installed on four channels.

The provided power cords mate to a compatible power inlet on the instrument for making line voltage and safety
ground connections. The AC inlet ground is connected directly to the chassis of the instrument. For adequate
protection again electric shock, connect to a mating outlet with a safety ground contact.
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Oscilloscope Overview and Set Up

Front of Oscilloscope
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Touch Screen display F. Mixed Signal interface

Front Panel controls Ground and Cal Out terminals

r o
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ProBus analog inputs (4) Tilting feet

E. External trigger input
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Side of Oscilloscope

A. HDMI and DisplayPort C. Ethernet Ports (2)

to external monitors )
D. Mic Inand Speaker Out

B. USB 3.1 Gen1 Ports (4)
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Back of Oscilloscope
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Front Panel
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Front panel controls duplicate functionality available through the touch screen
and are described here only briefly.

Knobs on the front panel function one way if turned and another if pushed like a
button. The first label describes the knob’s “turn” action, the second label its
“push” action. Actions performed from the front panel always apply to the active

trace.

Many buttons light to show the active traces and functions.

Trigger Controls

The front panel Level knob changes the trigger threshold level (V). The current
value is shown on the Trigger descriptor box. Pushing the knob sets the trigger
level to the 50% point of the input signal.

The READY indicator is lit when the trigger is armed. TRIG'D is lit momentarily
when a trigger occurs.

Setup opens the Trigger Setup dialog. Press it again to close the dialog.

Auto sets Auto mode, which triggers the oscilloscope after a set time, even if the
trigger conditions are not met.

Normal sets Normal mode, which triggers the oscilloscope each time a signal is
present that meets the trigger conditions.

Single sets Single trigger mode. The first press readies the oscilloscope to
trigger. The second press arms and triggers the oscilloscope once (single-shot
acquisition) when the input signal meets the trigger conditions.

Stop prevents the oscilloscope from triggering. If you boot up the instrument
with the trigger in Stop mode, a "No trace available" message is shown. Press
the Auto button to display a trace.

Horizontal Controls

Turn the Delay knob to change the Trigger Delay value (S). Push the knob to
reset Delay to zero.

If the trace source is an input channel, turn the Horizontal Adjust knob to set the
Time/division (S) of the oscilloscope acquisition system. The value is shown on
the Timebase descriptor box. When using this control, the oscilloscope allocates
memory as needed to maintain the highest sample rate possible for the
timebase setting. If the active trace is a math, zoom or memory, use this knob to
change the Horizontal Scale, effectively 'zooming" in or out. The value is shown
on the corresponding descriptor box. Push the knob to adjust scale in fine
increments; push it again to return to stepped increments.
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Vertical Controls

The Offset knob adjusts the zero level of the trace (this makes it appear to move up or down relative to the center
axis of the grid). The value appears on the trace descriptor box. Push it to reset Offset to zero.

The Vertical Adjust knob sets Vertical Gain (V/div) for channel traces or Vertical Scale for math, zoom and memory
traces. The value appears on the trace descriptor box. Push the knob to toggle between fine and stepped
increments.

The Channel buttons (1-4) turn on a channel that is off, or activate a channel that is already on. When the channel is
active, pushing its channel button turns it off. A lit button shows the active channel.

The Zoom (Z) button creates a Quick Zoom of each open trace.The resulting zoom traces are 1/10 of the source
channel scale and centered on the display. Use the Horizontal knobs to adjust this, or touch the zoom descriptor box
twice to display the zoom dialog controls. Touch the Zoom button again to turn off the zooms.

The Digital (D) button enables digital input on -MS models.

Math, Zoom, and Mem Indicators

These LEDs light to indicate when a type of trace other than an input channel is currently active and controllable
using the Front Panel. Touch the trace descriptor box to make a trace active and controllable.

Cursor Controls

Cursors identify specific voltage and time values on the waveform. The white cursor markers help make these points
more visible, as well as provide a simple way to reposition them. A readout of the Vertical values appears on the
trace descriptor box, while the Horizontal values appear below the Timebase descriptor box.

There are five preset cursor types, each with a unique appearance on the display. These are described in more detail
in the Cursors section.

Press the Cursor Type button to apply or remove cursors. Continue pressing to cycle through all cursor types until
the desired type is found ("Off" occurs when no cursors are visible).

Turn the Coarse knob to adjust the position of absolute cursors (dashed-dotted lines). Push it to return the cursor to
the default 2.5 division setting. If you're using the Both Rel cursor type, each push will toggle between the Horizontal
and Vertical absolute cursors. With the correct cursor selected (highlighted), turn the knob to adjust the position.

Turn the Fine knob to adjust the position of relative cursors (dashed lines). Push it to return the cursor to the default
7.5 division setting, or to select the other relative cursor when using the Both Rel cursor type.

When a numeric value field is selected, these knobs serve as the Adjust knobs. Turn the Coarse knob to make large-
increment adjustments; turn the Fine knob to make small-increment adjustments. Push either knob to return to the
default setting.

When a waveform trace is selected (by touching the descriptor box or the trace itself), these knobs
increase/decrease trace intensity.
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Miscellaneous Controls
These miscellaneous controls also appear along the top and bottom rows of the front panel.

Auto Setup performs an Auto Setup. After the first press, you will be prompted for a confirmation. Press the button
again or use the touch screen to confirm.

Default Setup resets the oscilloscope to the factory default configuration. After the first press, you will be prompted
for a confirmation. Press the button again or use the touch screen to confirm.

Clear Sweeps resets the acquisition counter and any cumulative measurements.
Touch Screen toggles on/off touch screen functionality.

Save performs whatever action was last selected on the Save dialog: save a LabNotebook, screen image, setup or
waveform file.

User can be configured as you choose, for example:

e To save a screen capture using your current Screen Image Preferences.

» To save other file types: LabNotebooks, setup or waveforms.

See Configuring the User Button for instructions on making the selection.

Signal Interfaces

Teledyne LeCroy instruments offer a variety of interfaces to input analog or digital signals. See the oscilloscope
product page at teledynelecroy.com for a list of compatible input devices.

ProBus Interface
C1-C4 utilize the ProBus interface.

The ProBus interface contains a 6-pin power and communication connection and a BNC signal connection to the
probe, with sense rings for detecting passive probes. It offers both 50 Q and 1 MQ input impedance, enabling it to
provide power and control for a wide range of probes such as high impedance passive probes, high impedance
active probes, current probes, high voltage probes, and differential probes.

The ProBus interface completely integrates the probe with the channel. Upon connecting a Teledyne LeCroy probe,
the probe type is recognized and some setup information, such as input coupling and attenuation, is performed
automatically. This information is displayed on the Probe Dialog, behind the Channel (Cn) dialog. System (probe plus
instrument) gain settings are automatically calculated and displayed based on the probe attenuation.

The ProBus interface may have a BNC-terminated cable connected directly to it. Depending on the BNC connector
used on the cable, the interface is rated for up to 2 GHz with 50 Q coupling or T GHz with 1 MQ coupling.

Note: Operational bandwidth is equal to the maximum input frequency of your oscilloscope model. See the
product datasheet.
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Other Analog Inputs

EXT In can be used to input an external trigger pulse or sample clock signal.
REF In can be used to input an external reference clock signal.
These inputs have a simple BNC interface with no power supply. See your product datasheet for voltage and

frequency ratings.

Mixed Signal Inputs

Digital Leadset

The digital leadset shipped with the -MS model oscilloscopes connects to the Mixed Signal Input on the front of the
oscilloscope to input of up-to-16 lines of digital data. Physical lines can be preconfigured into different logical
groups, Digitaln, corresponding to a bus and renamed appropriately depending on the group. The transitions for each
line may be viewed through different displays.

See Connecting the Digital Leadset for instructions.

Probes

The oscilloscope is compatible with the included passive probes and most Teledyne LeCroy active probes that are
rated for the instrument’s bandwidth. Probe specifications and documentation are available at
teledynelecroy.com/probes.

Passive Probes

The passive probes supplied are matched to the input impedance of the instrument but may need further
compensation. Follow the directions in the probe instruction manual to compensate the frequency response of the
probes.

If using other passive probes than those supplied, be sure to perform a low frequency calibration before using them
to measure signal. You can use the signal from the Cal Out hook on the front of the oscilloscope.

Active Probes

Teledyne LeCroy offers a variety of active probes for use with your oscilloscope. Most active probes match probe to
oscilloscope response automatically using probe response data stored in an on-board EEPROM. This ensures the
best possible combined probe plus oscilloscope channel frequency response without the need to perform any de-
embedding procedure.

Be aware that many active probes require a minimum oscilloscope firmware version to be fully operational. See the
probe documentation.
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Powering the Oscilloscope

Power On

I
Press the Power /Standby button (_) on the front to turn on the instrument. The button will light to show the
oscilloscope is operational.

A Caution: Do not power on or calibrate with a signal attached.

If the button is not easily accessible (e.g., in a rackmount), you can go to Utilities > Preferences and enable Power on
AC. Then, the instrument will start whenever the AC power supply is turned on.

Powering on will automatically start all services and load the oscilloscope application software. Aftera 20 min.
warm up and calibration period, the oscilloscope will be fully operational.

Power Off/Standby

Briefly press the Power button again or use the File > Shutdown menu option to execute a proper shut down and
preserve settings. Holding the Power button will execute a "hard” shut down (as on a computer), but we do not
recommend doing this because it does not allow the operating system to close properly, and setup data may be lost.

Caution; Except for emergencies, never power off by pulling the power cord or turning off the AC supply
without first shutting down the oscilloscope application properly.

The Power button does not disconnect the instrument from the AC power supply but puts it into "Standby" mode.
Some housekeeping circuitry continues to draw power. Only unplugging the power cord fully disconnects the
instrument from the power source. We recommend unplugging the instrument if it will remain unused for a long
period of time.

A Caution: Do not change the instrument’s Windows® Power Options setting from the default Never to
System Standby or System Hibernate. Doing so can cause the system to fail.

Connecting to Other Devices/Systems

LAN

The instrument is preset to accept a DHCP network address over a TCP/IP connection. Connect a cable from an
Ethernet (LAN) port to a network access device. Go to Utilities > Utilities Setup > Remote to find the IP address.

To assign a static IP address, choose Net Connections from the Remote dialog. Use the standard Windows
networking dialogs to configure the device address.

Choose File > File Sharing and open the Email & Report Settings dialog to configure email settings.

Audio/USB Peripherals

Connect the device to the appropriate port on the instrument. These connections are "plug-and-play" and do not
require any additional configuration.

10
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Printer

MAUI oscilloscopes support USB printers compatible with the instrument's Windows OS. Go to File > Print Setup to
configure printer settings. Select Properties to open the Windows Print dialog.

External Monitor

You may operate the instrument using the built-in touch screen or attach an external monitor for extended desktop
operation. See your product datasheet for the supported monitor resolution.

Connect the monitor cable to a video output on the instrument. You can use an adaptor if the monitor cable has a
different interface. Go to Display > Display Setup > Open Monitor Control Panel to configure the display. Be sure to
select the instrument as the primary display.

To use the Extend Grids feature, configure the second monitor to extend, not duplicate, the oscilloscope display. If
the external monitor is touch screen enabled, the MAUI user interface can be controlled through touch on the
external monitor as well as the oscilloscope. See Windows 10 External Display Setup for additional instructions on
setting up external monitors with Windows 10 oscilloscopes.

Remote Control

Go to Utilities > Utilities Setup > Remote to configure remote control. Connect the oscilloscope to the
network/controller using the cable type required by your selection.

« VICP(TCP/IP) and VXI-11(LXI) over Ethernet are supported standard, as is USBTMC.

» GPIBis supported with the use of the optional USB-GPIB adapter.

Note: Choose TCP/IP for remote control using MAUI Studio Pro. You can make the Ethernet connection
over a LAN or connect directly to the MAUI Studio host PC.

Sample Clock

To input an external sample clock signal, connect a BNC cable from the EXT input to the other instrument. Go to
Timebase > Horizontal Setup > Clock Source to configure the clock.

Reference Clock

To input/output a reference clock signal, connect a BNC cable from the Ref In/Out connector to the other
instrument. Go to Timebase > Horizontal Setup > Clock Source to configure the clock.

Auxiliary Output

To output signal to another instrument, connect a BNC cable from Aux Out to the other device. Go to Utilities >
Utilities Setup > Aux Output to configure the output.

11
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Using MAUI

MAUI (Most Advanced User Interface) is Teledyne LeCroy's unique oscilloscope user interface. MAUI provides an
extensible front-end to the MAUI oscilloscope application, integrating software options into a single application that
can be controlled using the latest Windows touch screen features.

MAUI Application

MAUI forms the front-end of Teledyne LeCroy oscilloscopes, providing a single interface for all standard and optional
oscilloscope applications. MAUI runs on the Microsoft Windows platform.

The oscilloscope firmware and standard applications are active upon delivery. At power-up, the instrument loads the
software automatically. Free updates are available periodically from the software download page of our website at
teledynelecroy.com. Go to Oscilloscope Downloads > Firmware Upgrade. Follow the instructions in Firmware Update
to download and install the software.

When you purchase an option, you will receive a license key via email that activates the optional features. See
Options for instructions on activating optional software packages.

Automation

The MAUI application is a COM Automation server. All the configurable application objects that are presented
through MAUI can be controlled using COM Automation strings embedded in remote control scripts. See the MAUI
Oscilloscopes Remote Control and Automation Manual for instructions.

Besides reading waveform and measurement data from the oscilloscope, a common use of Automation is the
creation of remote setup files. In fact, MAUI provides a simple way to save any oscilloscope configuration to a
LeCroy System Setup (.LSS) file, which is nothing more than a COM Automation program written in VB Script, ready
to restore the entire saved configuration when executed.

Further customization, such as the introduction of custom math or measurement processors into MAUI, can be
performed on oscilloscopes equipped with the CustomDSO (XDEV) option. See our website for examples.

Volatile vs. Non-Volatile Settings

Most of the oscilloscope settings are volatile, meaning they will automatically revert to the factory default whenever
the oscilloscope is rebooted, or when you choose to recall the default setup using the front panel Default Setup
button or the Recall dialog.

Those settings that are exceptions to this rule are called non-volatile. These settings will be retained session to
session until you manually change them. Non-volatile settings include:

« All preferences settings (including acquisition, calibration, color and miscellaneous)
 All networking, remote control and email settings

« All printer settings and screen image (file) preferences

 All report settings, including logo selections

 All file paths and names, including auto-naming selections

12


http://teledynelecroy.com/doc/docview.aspx?id=9905
http://teledynelecroy.com/doc/docview.aspx?id=9905

Using MAUI

Touch Screen

With MAUI, the touch screen is the principal control center of the oscilloscope. The entire display is active: use your
finger or a stylus to touch, drag, swipe, and draw selection boxes. With the addition of OneTouch, gestures such as
pinch and flick can be used to control the screen.

Many controls that display information also work as “buttons” to access other functions, and even the waveform
traces can be manipulated. If you have a mouse installed, you can click anywhere you can touch to activate a control;
in fact, you can alternate between clicking and touching, whichever is convenient for you.

The touch screen is divided into the following major control groups:

Bl File | ¥ Vertical |+ Timebase = | Trigger | & Display | # e | @ Math | 2 Analysis | X Utliies | @ Support Menu bar

Grid
| |_HD | Trigger LI )
o | : "5 S oime Descriptor boxes
Dialogs
1000000
= I = = =
Sioe | FindScale | NextGrid Label
4/11/2018 9:19.02 AM MeSSEﬂE le_bar

Menu Bar

The top of the window contains a complete menu of functions. Making a selection here changes the dialogs
displayed at the bottom of the screen. While many operations can also be launched from the front panel or
descriptor boxes, the menu bar is the best way to access dialogs for Save/Recall, Display, Status, LabNotebook,
Pass/Fail, optional Analysis packages and Utilities/Preferences.

Undo
If an action can be “undone”, the Undo button at the right of the menu bar restores the oscilloscope display to
the state prior to the action.

You will see a Q-Scape E=== control added to the menu bar when the Q-Scape Multi-tabbed Display
features are available. Q-Scape allows you to choose different tabbed display configurations.

13
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Grid
The grid displays the waveform traces. Every grid is 8 Vertical divisions representing the full number of 4096 Vertical

levels and 10 Horizontal divisions representing the total acquisition time. The value of each division depends on the
Vertical and Horizontal scale of the traces that appear on that grid.

Multi-Grid Display

The screen can be divided into multiple grids, each showing different types and numbers of traces (in Auto Grid
mode, it will divide automatically as needed). Regardless of the number and orientation of grids, every grid always
represents the same number of Vertical levels so that absolute measurement precision is maintained. See Display.

[ File | § Vertical = Timebase [ Trigger @ Display =~ # Cursors | E] Measure @& Math | | Analysis | ¢ Utilities | @ Support

c1 OCTH ' | HD [Tbase 412 ms|Trigger (1) L)
1.00 Vidiv 1.00 ps/div. X; | 12 Bits 1.00 ms/div Stop 600 mV
-3.0800 V 10.0 #idiv .0 ps © 1MS 100 MS/s Width Neg

1028 |

Different types of traces opening in a multi-grid display.

Q-Scape Tabs

On instruments with the Q-Scape multi-tabbed display features, Tabs 1-4 appear above the grids. Each tabis a
distinct multi-grid display. See Display for more information about using Q-Scape.

Grid Indicators

These indicators appear around or on the grid to mark important points on the display. They are matched to the
color of the trace to which they apply. When multiple traces appear on the same grid, indicators refer to the
foreground trace—the one that appears on top of the others.

- Axis labels mark the times/units represented by a grid division. They update dynamically as you pan the

trace or change the Vertical/Horizontal scale. Originally shown in absolute values, the labels change to
show delta from 0 (center) when the number of significant digits grows too large. To remove axis labels,
go to Display > Display Setup and deselect Axis Labels.

Trigger Time, a small triangle along the bottom (horizontal) edge of the grid, shows the time of the trigger.
Unless Horizontal Delay is set, this indicator is at the zero (center) point of the grid. Delay time is shown on
the Timebase descriptor box.

14



Using MAUI

Pre/Post-trigger Delay, a small arrow to the bottom left or right of the grid, indicates that a pre- or post-trig-
ger Delay has shifted the Trigger Position indicator to a point in time not displayed on the grid. All Delay
values are shown on the Timebase descriptor box.

Trigger Level at the right edge of the grid tracks the trigger voltage level. A solid triangle indicates the last
triggered level. If you change the trigger level prior to acquisition (e.g., in Stop mode), a hollow triangle of
the same color appears at the new trigger level. The trigger level indicator is not shown if the triggering
channel is not displayed.

the number and color of the trace.

Cursor markers appear over the grid to indicate the voltage and time being measured on the waveform.
Drag-and-drop cursor markers to quickly reposition the measurement.

Zero Volts Level is located at the left edge of the grid. One appears for each open trace on the grid, sharing
|
4

Grid Intensity
You can adjust the brightness of the grid lines by going to Display > Display Setup and entering a new Grid Intensity
percentage. The higher the number, the brighter and bolder the grid lines.

Descriptor Boxes

Trace descriptor boxes appear just beneath the grid whenever any type of waveform trace or graph is turned on.
They function to:

» Inform—descriptors summarize the current trace settings and its activity status.

» Navigate—touch the descriptor box once to activate the trace, again to open the setup dialog.
» Arrange—drag-and-drop descriptor boxes to move traces among grids.
 Configure—drag-and-drop descriptor boxes to change source or copy setups.

The following descriptors appear within standard MAUI. Graph/trace descriptor boxes that are unique to software
options (e.g., eye diagrams) are described with the option.

Channel Descriptor

Channel trace descriptor boxes correspond to analog signal inputs. They show (clockwise from
top left): channel number, pre-processing list (if any), coupling, vertical scale (gain) setting,
WVRIEL  yertical offset setting, sweeps count (when averaging), vertical cursor positions, and number of

L Uj.n"};}famkff segments acquired (when in Sequence mode).

t -10533mV

Ay 245 M\ If you are interleaving channels, channel descriptor boxes will show the channel's overall

acquisition status: trigger only, active or not active. Codes in the header indicate coupling and
pre-processing affecting the channel.

Symbols on Channel Descriptor Boxes

Processing Type Code

Coupling D50, DCT, ACT or GND
Bandwidth Limiting BWL

Averaging AVG

(Sinx)/x Interpolation / SINX / ESR

Enhanced Sample Rate

Deskew DSQ

15



HD06000B High Definition Oscilloscopes Operator's Manual

Processing Type Code

Noise Filter (ERes) FLT
Inversion INV

Note: When (Sinx)/x interpolation is applied automatically by the Enhanced Sample Rate feature, the Cn
descriptor box will show ESR. When applied manually, descriptors will show SINX.

Math, Zoom and Memory Descriptors

F1 FFT(C1)] Similar descriptor boxes appear for math (Fn), zoom (Zn) and memory (Mn) traces. These
=Y descriptors show any scaling that differs from the channel timebase. Units are automatically
eI adjusted for the trace type. They function the same as channel descriptor boxes.

Timebase and Trigger Descriptors

Timebase 0 nslTrigger [MBIEM| The Timebase descriptor box shows: (clockwise from top right) Horizontal
0.0 ns/div Auto i Delay, Time/div, Sample Rate, Number of Samples and Sampling Mode
ORET NG EGEN T (blank when in real-time mode).
1250ns AX= 2500 ns
P Vel " The Trigger descriptor box shows: (clockwise from top right) Source and
Coupling, trigger Level (V), Slope/Polarity, Type and Mode.

Horizontal (time) cursor readout, including the time between cursors and the frequency, is shown beneath the
TimeBase and Trigger descriptor boxes. See the Cursors section for more information.

Trace Context Menu

The trace context menu is a pop-up menu of actions to apply to a trace, such as turn off, add

Setup...
measurement, label or rename.

Off

To open the trace context menu, either right-click on the descriptor box, or touch and hold on the
Next Grid descriptor box until a white box appears, then lift your finger.

Math...

Measure. .

Set label...

Add/Edit Name...

Remove Name
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Using MAUI

Dialogs

Dialogs appear at the bottom of the display for entering setup data. The top dialog will be the main entry point for the
selected functionality. For convenience, related dialogs appear as a series of tabs behind the main dialog. Touch the
tab to open the dialog.

Main Dialog

Related Dialog Tabs Right-hand Subdialogs

f(x; q(f(x)) . FFT(C1)

Add / Edit Help Markers
Name Simple

Right-hand Subdialogs

At times, your selections will require more settings than can fit on one dialog, or the task invites further action, such
as zooming a new trace. In that case, subdialogs will appear to the right of the dialog. These subdialog settings
always apply to the object that is being configured on the tab to the left.

Action Toolbar

Several setup dialogs contain a toolbar at the bottom of the dialog. These buttons enable you to perform
commonplace tasks—such as turning on a measurement—without having to leave the underlying dialog. Toolbar
actions always apply to the active trace.

+ ‘;‘: Add / Edit L. |

Zoom Math Decode Find SE:ElE! MName

Measure opens the Measure pop-up to set measurement parameters on the active trace.
Zoom creates a zoom trace of the active trace.
Math opens the Math pop-up to apply math functions to the active trace and create a new math trace.

Decode opens the main Serial Decode dialog where you configure and apply serial data decoders and triggers. This
button is only active if you have serial data software options installed.

Store loads the active trace into the corresponding memory location (C1, F1 and Z1 to M1; C2, F2 and Z2 to M2, etc.).
Find Scale performs a vertical scaling that fits the waveform into the grid.

Add/Edit Name opens the virtual keypad for you to alias the trace.

Label opens the Label pop-up to annotate the active trace.

Histogram, Trend, and Track buttons appear on the Action toolbar at the bottom of the Parameter (Pn) set up
dialogs. They allow you to quickly create a Math function to plot the parameter results.

Actions for P1

b | — || M

Histogram Trend
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Message Bar

At the bottom of the oscilloscope display is a narrow message bar. The current date and time are shown at the far
right. Status, error, or other messages are shown at the far left, where "Teledyne LeCroy" normally appears.

A Input has invalid points

You will see the word "Processing..." highlighted with red at the right of the message bar when the oscilloscope is
processing your last acquisition or calculating.

Processing ...

This will be especially evident when you change an acquisition setting that affects the ADC configuration while in
Normal or Auto trigger mode, such as changing the Vertical Scale, Offset, or Bandwidth. Traces may briefly
disappear from the display while the oscilloscope is processing.

Language Selection
To change the language of the oscilloscope application:

1. Go to Utilities > Preference Setup > Preferences and make a Language selection.

2. Follow the prompt to restart the application.

You can also select by touching the Language icon when it appears to the far right of the menu bar

upon start up.

Windows 10 Gestures
Windows 10 oscilloscopes support new touch screen gestures for accessing applications and settings:

» Swipe from the left of the screen to switch applications or show the desktop. Continue swiping to return to
MAUL.

» Swipe from the right of the screen to open the Action Center, from where you can access system settings.

18
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Controlling Traces

Traces are the visible representations of waveforms that appear on the display grid. They may show live inputs (Cn,
Digitaln), a math function applied to a waveform (Fn), a stored memory of a waveform (Mn), a zoom of a waveform
(Zn), or the processing results of special analysis software.

Traces are a touch screen object like any other and can be manipulated. They can be panned, moved, labeled,
zoomed and captured in different visual formats for printing and reporting.

Each visible trace will have a descriptor box summarizing its principal configuration settings. See OneTouch Help for

more information about how you can use traces and trace descriptor boxes to modify your configurations.

Turning On/Off Traces

Turn On/Off Analog Trace
To turn on a channel trace, do any of the following:

e From the front panel, press the Channel button.
» From the touch screen, choose Vertical > Channel n Setup.
e Touch the Add New box and select Channel, or drag another Cn descriptor box to Add New.
To turn off a trace, press the front panel Channel button a second time, or from the touch screen, either:
» Right-click on the descriptor box and choose Off.

» Touch the descriptor box and clear the Trace On checkbox on the setup dialog.

Turn On/Off Digital Trace
To turn on digital traces, from the touch screen, choose Vertical > Digitaln Setup, then check Group on the Digitaln
dialog.

To turn off the traces, clear the Group checkbox.

Turn On/Off Other Trace
To turn on/off math or memory traces, check or clear the Trace On box on the respective setup dialogs.

You can also touch the Add New box and select the trace type, or drag another descriptor box of that same type to
the Add New box (e.g., drag M1 to Add New to turn on a the next available memory trace).

19
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Activating Traces

Although several traces may be open, only one trace is active and can be adjusted using front panel controls and
touch screen gestures. A highlighted descriptor box indicates which trace is active. All actions apply to that trace
until you activate another. Touch the trace descriptor box to make it active (and the foreground trace in that grid).

ESE D58 C1
2 50.0 m\/f 0.0 m\/Y 200 V/div 20.0 A/div
0.00 mV 0.00 mVy -33240V

Active trace descriptor (left), inactive trace descriptor (right).

1 ESR 058

%
GHz

Whenever you activate a trace, the dialog at the bottom of the screen automatically switches to the appropriate
setup dialog.

Since multiple traces can be opened on the same grid, the trace shown on top of the others is the foreground trace.
Grid indicators (matched to the input channel color) represent the foreground trace.

Touch a trace or its descriptor box to bring it to the foreground. This also makes it the active trace.

Note that a foreground trace may not be the same as the active trace. A trace in a separate grid may subsequently
become the active trace, but the indicators on a given grid will still represent the foreground trace in that group.

Adjusting Traces

To adjust Vertical Scale and Offset, or Horizontal Scale and Delay, just activate the trace and use the front panel
knobs. To make other adjustments—such as units—touch the trace descriptor box twice to open the appropriate
setup dialog.

Many settings are adjusted by selecting from the pop-up that appears when you touch a control.

e When an entry field appears highlighted in blue after touching, it is active and can be adjusted by
50.0 mV

turning the front panel knobs. Fields that don't have a dedicated knob (as do Vertical Level and
Horizontal Delay) can be modified using the Adjust knob.

If you have a keyboard installed, you can type entries
in an active (highlighted) data entry field. Or, you can touch it again, then
"type" the entry by touching keys on the virtual keypad or keyboard.

Scale

50.0 mV

To use the virtual keypad, touch the soft keys exactly as you would a Setto
calculator. When you touch OK, the calculated value is entered in the Max.
field.

Set to
Default

Set to

Min.

Clear | Back

Cancel
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Moving Traces

You can move a trace from one grid to another by dragging its descriptor box to the desired grid. This is a convenient
way to quickly re-arrange traces on the display.

If you are in Q-Scape display mode, you can drag the descriptor box to a grid on another tab, provided the grid is
visible while you are moving the trace. For example, you cannot drag descriptors across tabs in Q-Scape Single
mode, because the target grids aren't visible, but you can in Q-Scape Dual or Q-Scape Mosaic modes. This is true
even in extended display. For more information, see Display.

See OneTouch Help for ways to pan traces within the same grid.

Naming Traces (Aliases)

A custom name can be added to the mnemonic associated with a trace on its descriptor box, making the
oscilloscope user interface more intuitive. This custom name will appear in reports and wherever this trace is
referenced on the user interface. On trace descriptor boxes, the original trace label will appear above the alias.

C1 T C1 LEEEEI
Voltage&

2 50.0mV/ 16 50.0 mV/ 200 V/div
5 0.00mV 5" 0.00 mV -332.40 V

A custom name (alias) can be added to trace descriptor boxes.

Note: Although there is a 250 character logical limit, we recommend keeping names to 10 characters or
less, as characters over this number will be truncated on the display. Custom aliases apply only to the
oscilloscope display; use the original trace mnemonic (C1-Cn, F1-Fn, etc.) to refer to traces in remote
control programs.

Adding Name

1. Select Add/Edit Name from the Action toolbar on the trace setup dialog.

2. On the virtual keyboard, enter the new name (alias) and click OK.

Removing Name
To remove an alias from the trace, click Add/Edit Name again and choose Remove Name.
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Labeling Traces

The Label function gives you the ability to add custom annotations to the trace display. Once
placed, labels can be moved to new positions or hidden while remaining associated with the
trace.

Create Label

1. Select Label from the context menu, or touch the Label Action toolbar button on the trace setup dialog.
Cl: Trace Annotatio 1 J
Text of label

Add
Label

Remove
Label

Text of label

Label position may either
or by dragging the label

Close

2. Onthe Trace Annotation pop-up, touch Add Label.
3. Enterthe Label Text.

4. Optionally, enter the Horizontal/Vertical Pos. (in same units as the trace) at which to place the label. The
default position is 0 ns. Use Trace Vertical Position places the label immediately above the trace.

Reposition Label
Drag-and-drop labels to reposition them, or change the position settings on the Trace Annotation pop-up.

Edit/Remove Label

On the Trace Annotation pop-up, select the Label from the list. Change the settings as desired, or touch Remove
Label to delete it.

Clear View labels to hide all labels. They will remain in the list.
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Finding Trace Status

If a small letter "i" inside a bubble appears on the trace descriptor box, this indicates there is additional information
regarding a waveform processing error that resulted in the oscilloscope being unable to display a trace, or producing

a trace that could lead to unreliable measurements.

To find out the additional information behind this indicator, use the MAUI Browser installed on the oscilloscope to
view the Automation result interface: app.Subsystem.Wfmn.Out.Result.Samples

For example, if the F1 descriptor shows the

indicator, look at: app.Math.F1.0ut.Result.Samples

See the MAUI Oscilloscopes Remote Control and Automation Manual for instructions on using MAUI Browser to view

Automation results.

The Status property of the Out. Result.Samples interface will show the value of the error status bit that was
generated (there is no value if there is no error). The table below shows the status bit meaning.

O T = S

0 0x0000000000001 Invalid

1 0x0000000000002 Overflow

2 0x0000000000004 Underflow

3 0x0000000000008 Contains Undefined Values
4 0x0000000000010 Less Than

5 0x0000000000020 Greater Than

6 0x0000000000040 Not A Pulse

7 0x0000000000080 Not Cyclic

8 0x0000000000100 Averaged

9 0x0000000000200 Unlocked PLL

10 0x0000000000400 Other Error

11 0x0000000000800 Other Warning

12 0x0000000001000 Other Info

32 0x0000100000000 Inputs Incompatible

33 0x0000200000000 Algorithm Limits Reached
34 0x0000400000000 Bad Definition

35 0x0000800000000 Too Few Data

36 0x0007000000000 Too Many Data

37 0x0002000000000 Uniform Horizlnterval Required
38 0x0004000000000 Bad Units

39 0x0008000000000 Data Range Too Low

40 0x0010000000000 Data Undersampled

41 0x0020000000000 Poor Statistics

42 0x0040000000000 Slow Transition Time

43 0x0080000000000 Data Resampled

44 0x0100000000000 Data Interpolated

45 0x0200000000000 Measurement Scale Imprecise
46 0x0400000000000 No Data Available

47 0x0800000000000 Some Cummulated Results Invalid
48 0x1000000000000 Insufficient Memory

49 0x2000000000000 Channel Not Active

50 0x4000000000000 Use Status Description

23


http://teledynelecroy.com/doc/docview.aspx?id=9905

HD06000B High Definition Oscilloscopes Operator's Manual

MAUI with OneTouch

Gestures like touch, drag, swipe, pinch and flick can be used to create and change setups with one touch. Just as
you change the display by using the setup dialogs, you can change the setups by moving different display objects.
Use the setup dialogs to refine OneTouch actions to precise values.

As you drag & drop objects, valid targets are outlined with a white box. When you're moving over invalid targets, you'll
see the "Null" symbol (@) under your finger tip or cursor.

Turn On

To turn on a new channel, math, memory, or zoom trace, drag any descriptor box of the same type to the Add New
("+") box. The next trace in the series will be added to the display at the default settings. It is now the active trace.

500 my

0.0 mV ofst

If there is no descriptor box of the desired type on the screen to drag, touch the Add New box and choose the trace
type from the pop-up menu.

To turn on the Measure table when it is closed, touch the Add New box and choose Measurement.

Activate

Touch a trace or its descriptor box to activate it and bring it to the foreground. When the descriptor box appears
highlighted in blue, front panel controls and touch screen gestures apply to that trace.

U.Ij mYy ofst
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Copy Setups

To copy the setup of one trace to another of the same type (e.g., channel to channel, math to math), drag-and-drop
the source descriptor box onto the target descriptor box.

200 e\ iclew

5 [

To copy the setup of a measurement (Pn), drag-and-drop the source column onto the target column of the Measure
table. You can do the same for a query (Qn) on the Pass/Fail readout table.

Change Source

To change the source of a trace, drag-and-drop the descriptor box of the desired source onto the target descriptor
box. You can also drop it on the Source field of the target setup dialog.

50.0 mf 0.0 oV ey 50,0 ml
00 mv 53 MHz'dev 0,00 my 53 MHz'dev!

To change the source of a measurement, drag-and-drop the descriptor box of the desired source onto the parameter
(Pn) column of the Measure table. You can do the same to a query (Qn) on the Pass/Fail readout table.

1.0 Wi
0.00Y oid
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Position Cursors

To change cursor measurement time/level, drag cursor markers to new positions on the grid.
The cursor readout will update immediately.

To place horizontal cursors on zooms or other calculated traces where the source Horizontal Scale has forced
cursors off the grid, drag the cursor readout from below the Timebase descriptor to the grid where you wish to place
the cursors. The cursors are set at either the 5 (center) or the 2.5 and 7.5 divisions of the grid. Cursors on the source
traces adjust position accordingly.

Change Trigger

To change the trigger level, drag the Trigger Level indicator to a new position on the Y axis.
The Trigger descriptor box will show the new voltage Level.

To change the trigger source channel, drag-and-drop the desired channel (Cn) descriptor box onto the Trigger
descriptor box. The trigger will revert to the coupling and slope/polarity last set on that channel.
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Store to Memory
To store a trace to internal memory, drag-and-drop its descriptor onto the target memory (Mn) descriptor.

C1 ACTH | T

100 i idie 100 iy fdy

TR o idine 14 o chala
g5 0 my|  available.

25.0 mV 200 ns/div

Move Trace

To move a trace to a different grid, drag-and-drop the trace descriptor box onto the target grid. If you are in a multi-
tabbed Q-Scape display mode, you can move traces between tabs this way.

To scroll long lists of values or readout tables, swipe the selection dialog or
table in an up or down direction.
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Pan/Swipe Trace

To pan atrace, activate it to bring it to the forefront, then drag the waveform
trace right/left or up/down. If it is the source of any other trace, that trace will
move, as well.

For channel traces, the Timebase descriptor box will show the new
Horizontal Delay value. For other traces, the zoom factor controls show the
new Horizontal Center.

0 Tip: When using multi-zoom, all time-locked traces will pan together.

Swipe from the far left of the screen to switch "tabs" and show the Windows desktop. Swipe from left again to return
to the oscilloscope application.

Rectangle Zoom

To create a new channel zoom trace, touch then drag diagonally to draw a rectangle
around the portion of the trace you want to zoom. Touch the Zn descriptor box to open
T M,i I the zoom factor controls and adjust the zoom exactly.

| 1% Ty | 1
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Using MAUI

Pinch Zoom
To "zoom in" on any trace, unpinch two fingers over the trace horizontally.

LR

HY .J||.||||.||||||I.1|

Note: Pinch gestures do not create a separate zoom (Zn) trace, they only adjust the Horizontal Scale. When
you pinch a channel (Cn) trace, the Timebase for all channels changes. If the trace is the source of any
other, all its dependent traces change, as well.

Turn Off

To turn off a trace, flick the trace descriptor box toward the bottom of the screen.

To turn off a measure parameter or Pass/Fail query, flick the Pn or Qn cell toward the bottom of the screen. If it's the
last active cell of the table, the table will close.

29



HD06000B High Definition Oscilloscopes Operator's Manual

Waveform Acquisition

Topics in this section explain how to configure the instrument to acquire new waveforms.

Auto Setup

Auto Setup configures the essential acquisition settings based on the first input signal it finds, starting with C1. If
nothing is connected to C1, it searches C2 and so forth until it finds a signal. Vertical Scale (Volts/div), Offset,
Timebase (Time/div), and Trigger are set to a 50% Edge trigger on the first, non-zero-level amplitude, with the entire
waveform visible for at least 10 cycles over 10 horizontal divisions.

To run Auto Setup:

1. Press the front panel Auto Setup button, or choose Auto Setup from the Vertical, Timebase, or Trigger menus
(these all perform the same function).

2. To confirm, press the Auto Setup button again, or use the touch screen display.

After running Auto Setup, you'll see the words "Auto Setup" next to an Undo button at the far right of the menu bar.
This allows you to undo the Auto Setup and restore the settings in place prior to Auto Setup.

Caution; You will undo all new measurements or math function definitions entered since the Auto Setup
when you Undo the Auto Setup.

Vertical

Vertical, also called Channel, settings usually relate to voltage level and control traces along the Y axis.

Note: While Digital settings can be accessed through the Vertical menu on oscilloscopes with mixed-signal
capabilities, they are handled quite differently. See Digital.

The amount of voltage displayed by one vertical division of the grid, or Vertical Scale (V/div), is most quickly adjusted
by using the front panel Vertical knob. The Cn descriptor box always shows the current Vertical Scale setting.

Channel Setup Dialog

To access the main Channel Setup dialog, choose Vertical > Channel Setup from the menu bar.

Channel Setup

)

Copy Channel T 50.0 mv 0.0 mv_ DCIMQ
Setup

c3 - W 500mv, 0.0my, DCIMOQ

cs | W 500my, 0.0myv, DCTMO

Use this dialog to quickly make/change basic Vertical settings for all analog input channels.
e Toturn on/off the channel trace, select/deselect the checkbox.

» To change the trace color, touch the color block, then choose the new color from the pop-up.
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» To change any basic Vertical settings (Scale, Offset, etc.), touch the input field and enter the new value.
» To quickly propagate the changes made, touch Copy Channel Setup and select the channels to Copy From and
Copy To.

Tip: On instruments with OneTouch, you can copy settings from one channel to another just by dragging the
source channel descriptor box onto the target channel descriptor box.

Cn (Channel) Dialog

Full vertical setup is done on the individual Cn dialogs. To access them, choose Vertical > Channeln Setup from the
menu bar, or touch the Channel descriptor box.

Channel Setup

o

Add / Edit

L

Measure Zoom Decode Store Find Scale Name

If aTeledyne LeCroy probe is connected, its Probe dialog appears to the right of the Cn dialog.

Note: In case of a waveform processing error (e.g., overflow), a small letter "i" inside a bubble will appear on
the Cn descriptor box to indicate there is information regarding the waveform status. See Finding Waveform
Status for instructions on finding the error.

Vertical Settings
The Trace On checkbox turns on/off the channel trace.

Vertical Scale sets the gain (sensitivity) in the selected Vertical units, Volts by default. Select Variable Gain for fine
adjustment or leave the checkbox clear for fixed 1, 2, 5, 10-step adjustments.

Offset adds a defined value of DC offset to the signal as acquired by the input channel. This may be helpful in order
to display a signal on the grid while maximizing the vertical height (gain) of the signal. A negative value of offset will
"subtract” a DC voltage value from the acquired signal (and move the trace down on the grid) whereas a positive
value will do the opposite. Touch Zero Offset to return to zero.

A variety of Bandwidth filters are available. To limit bandwidth, select a filter from this field.
Set Coupling appropriate to the input used:

e ProBus: DC 50 Q, DCTM, ACTM or GND (Ground)

Maximum input voltage depends on the input used. Limits are displayed on the body of the instrument. Whenever
the voltage exceeds this limit, the coupling mode automatically switches to GND. You must then manually reset the
coupling to its previous state. While the unit provides this protection, damage can still occur if extreme voltages are
applied.

Probe Attenuation
Probe Attenuation values for third-party probes may be entered manually on the Cn dialog. The instrument will
detect it is a third-party probe and display these fields.
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When a Teledyne LeCroy probe is connected to a channel input, the Attenuation field becomes a button to access
the Probe dialog, a tab added to the right of the Cn tab. Enter Attenuation on the Probe dialog.

Rescale Settings
The rescale settings provide the same capability as the oscilloscope Rescale math function
(y=ax + b, where the original value is x, Units/V is a, and Add is b), with two key differences:

 |tis applied directly to the channel input trace rather than to a separate math function trace.
» Rescaling is done according to the offset grain for the particular V/div.
To rescale, enter the number of units equal to 1 Volt in Units/V and any additive constant in Add.

The Vertical Units setting may be changed from Volts (V) to Amperes (A) or Others. This is useful when using a third-
party current probe (which is not auto-detected) or when probing across a current sensor/resistor. Units assigned
directly to an input will carry to other traces calculated using that input, such as math or spectrum traces. When
using a unit other than volts or amperes, first choose a unit subcategory from the pop-up dialog that appears, then
the unit.

Pre-Processing Settings
Pre-processing functions modify the acquired signal prior to display, math and measurement processing.

Average performs continuous averaging—the repeated addition, with unequal weight, of successive source
waveforms. It is particularly useful for reducing noise on signals drifting very slowly in time or amplitude. The most
recently acquired waveform has more weight than all the previously acquired ones: the continuous average is
dominated by the statistical fluctuations of the most recently acquired waveform. The weight of old waveforms in
the continuous average gradually tends to zero (following an exponential rule) at a rate that decreases as the weight
increases.

Interpolate applies (Sinx)/x interpolation to the waveform. The selection of None or Linear applies Linear
interpolation, which inserts a straight line between sample points and is best used to reconstruct straight-edged
signals such as square waves. (Sinx)/x interpolation, on the other hand, is suitable for reconstructing curved or
irregular wave shapes. Choose an upsample factor of 2 or more points. The Interpolation setting is disabled .

On some HDO models, this setting is called Enhanced Sample Rate and appears disabled when using a sample rate
greater than 2.5 GS/s, as the system automatically sets the upsample factor according to your sample rate. Only
when the sample rate is below this can you choose an upsample factor or use Linear interpolation (None). See
Enhanced Sample Rate.

Deskew adjusts the horizontal time offset by the amount entered in order to compensate for propagation delays
caused by different probes or cable lengths. The valid range is dependent on the current timebase setting. The
Deskew pre-processing setting and the Deskew math function perform the same action.

Noise Filter applies Enhanced Resolution (ERes) filtering to increase vertical resolution, allowing you to distinguish
closely spaced voltage levels. The tradeoff is reduced bandwidth. ERes functions similarly to smoothing the signal
with a simple, moving-average filter. It is best used on single-shot acquisitions, acqusitions where the data record is
slowly repetitive (and you cannot use averaging), or to reduce noise when your signal is noticeably noisy but you do
not need to perform noise measurements. It also may be used when performing high-precision voltage
measurements and zooming with high vertical gain, for example. ERes is disabled.

Invert changes the apparent polarity of the signal, substituting an equivalent negative value for a positive one, and
vice versa, so that the waveform appears to be "flipped" on screen.
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De-Embedding allows you to remove the effects of cables used to input signals. On oscilloscopes with the Cable De-
embedding option installed, select the checkbox, then enter the attenuation constants or cable characteristics
(provided by the cable manufacturer) on the Cable De-Embedding dialog that appears.

Cable De-Embedding Option

Losses in the cables used in the test setup can reduce the accuracy of your signal (e.g., signal amplitude and rise
time), as well as introduce Inter-Symbol Interference. These cable effects can dramatically alter measurements and
potentially create mask test violations.

Cable De-Embedding (standard on LabMaster and some WaveMaster 8 Zi oscilloscopes, and available as an option
on many other models) allows you to quickly specify the loss characteristics of the cables, typically found on the
cable's data sheet, and analyze your signal with the effects removed. The compensated signal is a more accurate
representation of what was actually transmitted.

When Cable De-Embedded is installed and De-embedding is selected from the channel pre-processing settings, the
Cable De-Embedding dialog will appear for you to describe the cable being used on the channel.

1. Touch Vertical > Channel # Setup... from the menu bar, then on the Cn dialog, check Cable De-Embedding to
display the Cable De-Embedding tab.

2. Onthe Cable De-Embedding dialog, touch Cable Specified by and choose either:
» Attenuation Constants. Enter the cable loss model constants in Cable A1 and Cable A2.

 Attenuation Table. Enter the first set of Frequency and Attenuation values. Touch Add to continue
adding rows to the table as needed.

Tip: To edit a row in the table, select it, change values, then touch Change. To delete a row,
select the row and touch Delete.
3. Enter the Cable Length in inches.

4. Touch Delay Specified by and choose from Propagation Velocity, Nominal Delay, or Dielectric Constant. Enter
the value in the field of the same name.

o

Click Apply to initiate the cable de-embedding for the signal on this channel.

6. To save this cable configuration for future use, touch File Name [DefaultCable] and enter a name.
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Probe Dialog

The Probe Dialog immediately to the right of the Cn dialog displays the attributes of the probe connected to that
channel and (depending on the probe type) allows you to control the probe from the touch screen.

A Caution: Remove probes from the circuit under test before initializing Auto Zero or DeGauss.

C1HVD3102

itial Probe

Attributes
AD01
A
25 MHz
=100
DC 10MQ

Depending on the type of probe you have connected to the channel, you may see any of the following controls:
Power On initiates power to active probes via the oscilloscope interface.

LED Active turns on AutoColor ID if the probe has this feature. The LED on the probe body will light in the color of the
channel to which the probe is connected.

Auto Zero corrects for DC offset drifts that naturally occur from thermal effects in the amplifier of active probes.
Teledyne LeCroy probes incorporate Auto Zero capability to remove the DC offset from the probe's amplifier output
to improve the measurement accuracy.

The Degauss control is activated for current probes. Degaussing eliminates residual magnetization from the probe
core caused by external magnetic fields or by excessive input. It is recommended to always Degauss probes prior to
taking a measurement.

If using a WaveLink probe, touch Tip Select and select the type of tip/lead you are using.

Note: Making the tip selection here results in the amplifier and tip combination having the response
calibrated for at the factory. Failure to do so may result in inaccurate measurements.

On oscilloscopes running MAUI version 8.5.1.1 or later, HYD3000 probes set attenuation relative to the
oscilloscope’s V/div setting and the Voltage Range selection:

» Auto automatically raises attenuation when V/div is >7.9 or lowers attenuation when V/div is <7.9, allowing you
to properly view the input waveform.

» Lock to High locks attenuation to the highest setting, regardless of the V/div setting. Maintaining a high
attenuation will allow small signals on larger voltage waveforms to be accurately measured.

Use the Refresh button to update the attributes display.
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Digital (Mixed-Signal)

When a mixed-signal device is connected to the oscilloscope, digital input setup options are added to the Vertical
menu. There are set up dialogs for digital groups Digital1 to Digital4, which correspond to possible digital buses. You:

» Choose which lines make up each digital group, what they are named and how they appear on the display

» Set the logic determination thresholds

A pattern trigger can be set on digital logic, or a combination of digital logic and analog states.

Connecting the Digital Leadset

The digital leadset enables input of up-to-16 lines of
digital data. Physical lines can be configured into
different logical groups, Digitaln, corresponding to a
bus. The transitions for each line may be viewed
through different display modes.

The digital leadset features two digital banks with
separate Threshold and Hysteresis controls, making it
possible to simultaneously view data from different
logic families. Initially, logical lines are named and
numbered the same as the physical lead, although any
line can be renamed appropriately or re-assigned to any
lead.

Each flying lead has a signal and a ground connection.
A variety of ground extenders and flying ground leads
are available for different probing needs.

Note: To achieve optimal signal integrity, connect the ground at the tip of the flying lead for each input used
in measurements. Use the provided ground extenders or ground flying leads to ground the connection.

To connect the leadset to the instrument, push the connector
into the Mixed Signal interface below the front panel until you
hear a click. After connecting the device, go on to set up your

digital groups.

To remove the leadset, press and hold the buttons on each side
of the connector head, then pull out to release.

35



HD06000B High Definition Oscilloscopes Operator's Manual

Digital Group Set Up
Logic Setup

DA5-D8
Display D7 D6 D5 D4 2 D1 Do

|
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Display DATAT DATA 6 DATA5 DATA 4 DATA.3 DATA.2 DATA.1 DATA0 Reset Names
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Line Activity
D8 D7 Do
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Digital Group dialog when using Digital Leadset (MSO).

A group defines the lines that comprise a bus or that you wish to view together. To set up a digital group:
1. From the menu bar, choose Vertical > Digitaln Setup.

2. Onthe Digitaln set up dialog, check the boxes for all the lines that comprise the group. Touch the Right and
Left Arrow buttons to switch between lead banks as you make line selections.

3. Choose a Display Mode (see below). Use the controls at the right of the dialog to define the Group Height and
Vertical Position.

4. When you're finished defining the groups and display on the Digitaln dialog, open the Logic Setup dialog to
define logic thresholds.

5. Check the Group box to start the display.

Digital Display Set Up
When a digital group is enabled, the Display Mode setting determines how the data appears on the display.

Lines (default) shows a time-correlated trace indicating high, low, and transitioning points (relative to the Threshold)
for every digital line in the group.

Bus collapses the lines in a group into their Hex values.

Line & Bus displays both types of digital trace. The Bus trace appears immediately below the Line traces.

8 File & Vertical = Timebase | [ Trigger & Display & Cursors [l Measure @ Math | = Analysis X Utilties @ Support

150 0

Digital1 (magenta) shows four lines at Vertical Position +4.0 (top of grid) and Group Height 4.0 divisions (half of grid).
Digital4 (green) shows five digital lines and bus trace with the same Vertical Position and Group Height.

The size and placement of the traces depend on the Vertical Position and Group Height settings.
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In Vertical Position, enter the number of divisions (positive or negative) relative to the zero line of the grid where the
display begins.The top of the first trace appears at this position.

In Group Height, enter the total number of grid divisions the entire display should occupy. All the selected traces
(Line and Bus) will appear in this space. Individual traces are resized to fit the total number of divisions available.

To close the display of digital traces, uncheck the Group box on the Digitaln dialog.

Tip: You may wish to enable groups with many lines one or two at a time to maximize the screen space
available for each. Closing the set up dialogs will also increase available screen space.

Renaming Digital Lines
The labels used to name each line can be changed to make the user interface more intuitive.

Touch Label and select the type:
+ Data (default) appends "D." to the front of each line number.
» Address appends "A." to the front of each line number.
» Custom lets you create your own labels line by line.

To use Custom labels:

» Touch the Line number field below the corresponding checkbox. If necessary, use the Left/Right Arrow buttons
to switch between banks.

¢ Use the virtual keyboard to enter the name, then press OK.

Renumbering Digital Lines

Labels can also be "swapped" between lines. This procedure helps in cases where the physical lead number is
different from the logical line number you would like to assign to that input. It can save time having to reattach leads
or reconfigure groups.

Example: A group is set up for lines 0-4, but lead 5 was accidentally attached to the probing point. By
"swapping" line 5 with line 4, you do not need to change either the physical or the logical setup.

1. Select a Label of Data or Address.

2. Touch the Line number field below the corresponding checkbox. If necessary, use the Left/Right Arrow
buttons to switch between banks.

3. From the pop-up, choose the line with which you want to swap labels.

Activity Indicators

Activity indicators appear at the bottom of the Digitaln dialogs. They show which lines are High (up arrow), Low
(down arrow), or Transitioning (up an down arrows) relative to the Logic Threshold value.

High Low Transitioning
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Shortcut Buttons
At the right side of the Digitaln dialogs are buttons to:

» Create a new Zoom of a Digital group display. Each press of the button zooms each group displayed in order,
creating Z1 for Digital1, then Z4 for Digital4, etc. The zoom's horizontal and vertical scale can be changed from
that of the original digital group display to show transitions in more detail.

» Open the Serial Decode dialogs to configure decoders. Digital lines can be selected for Data and/or Clock
sources when configuring decoders. Be sure the digital logic levels you set on Logic Setup are compatible with
the decoding levels.

 Store the active digital group data to internal memory. As with Zoom, Digital1 will be stored to M1, Digital4 to
M4, etc., but the group must first be activated by selecting the setup tab or the descriptor box.

» Move the active digital group to the Next Grid.

Digital Logic Set Up

Digital logic determination is made according to the settings made on the Logic Setup tab when defining groups.

Note: If you are using digital inputs as decoder sources, be sure the logic setup you make here matches the
levels you set on the decoder dialogs.

Digital Leadset (MSO)

Digital4 Logic Setup

D15:D8 D7:D0
Logic Family Logic Family
CMOS 5V TTL

For the low-speed digital leadset, logic determination level can be set per digital lead bank. You can use standard
Logic Family TTL, ETL, CMOS 5V, CMOS 3.3V, CMOS 2.5V, PECL 5V or LVDS.

Alternatively, by selecting Logic Family User Defined, you can define a custom logic Threshold voltage and
Hysteresis. Pulses that fail to cross the Hysteresis band will not be determined to be logical 1 or 0.
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Timebase

Timebase (Horizontal) settings control traces along the X axis. The timebase is shared by all channels.

The time represented by each horizontal division of the grid, or Time/Division, is most easily adjusted using the front
panel Horizontal knob. Full Timebase set up is done on the Timebase dialog, accessed either by choosing Timebase
> Horizontal Setup from the menu bar or by touching the Timebase descriptor box.

Controls specifically used for interleaving are located at the far right of the main Timebase dialog. They allow you to
increase the sampling rate, memory, and bandwidth of a single input through channel interleaving.

Timebase Set Up

TimeBase

Set Fixed
Maximum Sample

Set To Zero Memory Rate

Sampling Mode

The Sampling Mode determines how the instrument samples the input signal and renders it for display.

Real Time Sampling Mode

Real Time sampling mode is a series of digitized voltage values sampled on the input signal at a uniform rate. These
samples are displayed as a series of measured data values associated with a single trigger event. By default (with no
Delay), the waveform is positioned so that the trigger event is time 0 on the grid. The relationship between sample
rate, memory, and time can be expressed as:

Capture Interval = 1/(Sample Rate X Memory)
Capture Interval/10 = Time Per Division

Usually, on fast timebase settings, the maximum sample rate is used when in Real Time mode. For slower timebase
settings, the sample rate is decreased so that the maximum number of data samples is maintained over time.

RIS Sampling Mode
RIS (Random Interleaved Sampling) allows effective sampling rates higher than the maximum single-shot sampling
rate. It is available on timebases <10 ns/div.

The maximum effective RIS sampling rate is achieved by making multiple single-shot acquisitions at maximum real-
time sample rate. The bins thus acquired are positioned approximately 8 ps (125 GS/s) apart. The process of
acquiring these bins and satisfying the time constraint is a random one. The relative time between ADC sampling
instants and the event trigger provides the necessary variation. The system then interleaves these acquisitions to
provide a waveform covering a time interval that is a multiple of the maximum single-shot sampling rate. However,
the real-time interval over which the instrument collects the waveform data is much longer, and depends on the
trigger rate and the amount of interleaving required.

Because the instrument requires multiple triggers to complete an acquisition, RIS is best used on repetitive
waveforms with a stable trigger. The number depends on the sample rate: the higher the sample rate, the more
triggers are required.
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Note: RIS is not available when the oscilloscope is operating at fixed sample rate or using another form of
channel interleaving.

Roll Sampling Mode

Parameters or math functions are updated only after each acquisition is complete, as new data becomes available.
Therefore, Roll mode should not be used with Auto trigger mode, because as the acquisition is never "complete,”
parameters are not updated correctly.

Timebase must be set sufficiently slow to enable Roll mode selection; increase Time/div to 100 ms/div or more and
decrease sample rate to 5 MS/s or less to activate the Roll mode option on the Timebase dialog. Only Edge trigger is
supported for Roll mode acquisitions.

Roll mode displays incoming points of slow timebase acquisitions so that the trace appears to "roll" continuously
across the screen from right to left. The acquisition is complete when a trigger event is detected, at which point the
next acquisition begins immediately.

Note: Roll mode sampling is not available when using any form of digital interleaving. If processing time is
greater than acquisition time, the roll mode buffer is overwritten. The instrument warns, "Channel data is not
continuous in ROLL mode!!'" and rolling starts again.

Sequence Sampling Mode

In Sequence Mode sampling, the completed acquisition consists of a number of fixed-size segments each
containing the trigger event. The instrument calculates the capture duration and number of sample points in each
segment from the user-defined number of segments and total available memory. Acquired segments can be
arranged adjacent to one another, forming the waveform display of a typical acquisition, or in other types of
sequence displays to facilitate comparison of the segments.

Sequence Mode is ideal for capturing specific events that may be separated by long time intervals. The instrument
can acquire over long periods waiting for the trigger event, recording only the desired segments while ignoring the
uninteresting periods between events. Measurements can be made on selected segments or on the entire
acquisition sequence.

See Sequence Mode Set Up.

Note: You cannot operate some Serial Decoders on Sequence Mode acquisitions.

Timebase Mode

Time/Division is the time represented by one horizontal division of the grid. Touch the Up/Down Arrow buttons on
the Timebase dialog or turn the front panel Horizontal knob to adjust this value. The overall length of the acquisition
record is equal to 10 times the Time/Division setting.

Delay is the amount of time relative to the trigger event to display on the grid. Raising/lowering the Delay value has
the effect of shifting the trace to the right/left. This allows you to isolate and display a time/event of interest that
occurs before or after the trigger event.

» Pre-trigger Delay, entered as a positive value, displays the acquisition time prior to the trigger event, which
occurs at time 0 when in Real Time sampling mode. Pre-trigger Delay can be set up to the instrument's
maximum sample record length; how much actual time this represents depends on the timebase. At maximum
pre-trigger Delay, the trigger point is off the grid (indicated by the arrow at the lower right corner), and
everything you see represents 10 divisions of pre-trigger time.
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 Post-trigger Delay, entered as a negative value, displays time following the trigger event. Post-trigger Delay can
cover a much greater lapse of acquisition time than pre-trigger Delay, up to the equivalent of 10,000 divisions
after the trigger event (it is limited at slower time/div settings and in Roll mode). At maximum post-trigger
Delay, the trigger point is off the grid far left of the time displayed.

Set to Zero returns Delay to zero.

Sampling Rate
These controls specify how the instrument samples when in Real Time mode.

Set Maximum Memory sets the oscilloscope to take the maximum number of samples possible given the amount of
pre- or post-trigger Delay and the Time/div, up to the maximum record length. This optimizes the sample rate for fast
timebases when in Real Time mode.

Maximum Sample Points shows the maximum number of samples taken per acquisition. The actual number of
samples acquired can be lower due to the other timebase settings.

Fixed Sampling Rate allows you to set a fixed rate of sampling, in which case the length of acquisition depends on
the Time/div. The oscilloscope will use whatever memory is required for the acquisition time, until none remains.
Lowering the rate can extend the acquisition to accommodate slower timebases or longer delays.

In this mode, Maximum Sample Points changes to Sampling Rate for you to enter the desired rate.

Note: To avoid aliasing and other waveform distortions, it is advisable (per Nyquist) to acquire at a sample
rate at least twice the bandwidth of the input signal. Those with higher speed acquisition systems may need
to manually adjust Bandwidth, Time/div, Sample Rate, and the number of Active Channels to achieve the
optimal result.

Enhanced Sample Rate

On instruments with Enhanced Sample Rate (ESR), Sinx/x interpolation is applied globally to all channels in order to
improve measurement accuracy over a wide range of timebases.

On HDO6000B and HDO4000A oscilloscopes, the maximum ESR upsampling factor is 4x.

In "Set Maximum Memory" mode, ESR will be enabled whenever the timebase settings dictate that the required
acquisition length is less than or equal to the maximum memory value selected. The ESR factor is automatically
adjusted to yield the best possible sample rate. In "Fixed Sample Rate" mode, the ESR rate will correspond to the
maximum selectable sample rate.

Enhanced Sample Rate per channel can be added or set to Linear (None) on the Channel (Cn) setup dialog.

When ESR is in use, the code E/ESR will appear on the descriptor boxes of the active channels.
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Sequence Mode Set Up

The Sequence dialog appears behind the Timebase dialog only when Sequence Mode sampling is selected. Use it to
define the number of fixed-size segments to be acquired.

Adjacent

Show Sequence

Trigger Times...
Use Zoom i o

viewed and

1. From the menu bar, choose Timebase > Horizontal Setup..., then Sequence Sampling Mode.
2. Onthe Sequence tab under Acquisition Settings, enter the Number of Segments to acquire.

3. To stop acquisition in case no valid trigger event occurs within a certain timeframe, check the Enable Timeout
box and provide a Timeout value.

Note: While optional, Timeout ensures that the acquisition completes in a reasonable amount of time
and control is returned to the operator/controller without having to manually stop the acquisition,
making it especially useful for remote control applications.

4. Touch Display mode and select a sequence display mode from the pop-up menu:

Overlay

Adjacent

Waterfall (cascaded) Perspective

Mosaic (tiled)

5. To see the trigger times of those segments acquired, stop acquisition and touch Show Sequence Trigger
Times. This will launch the Trigger Time tab of the Acquisition Status dialogs.

When in Sequence sampling mode, you can view individual segments easily using the front panel Zoom button. A
new zoom of the channel trace defaults to Segment 1. ou can view other segments by changing the First and total
Num(ber) of segments to be shown on the Zn dialog. Touch the Zn descriptor to display the dialog.

0 Tip: When Num is 1, you can use the front panel Adjust knob to scroll to each segment.
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Channel descriptor boxes indicate the total number of segments acquired in sequence mode. Zoom descriptor
boxes show the first segment displayed ([#]) and total number of segments displayed (#). As with all other zoom
traces, the zoomed segments are highlighted on the source trace.

C1 D58
16 500mV/ s 50.0 mv/ 50.0 mv/ 50.0 mv/

G2 goomv Mz 000mV 500 ps/ 500 ps/
10 Seg 10 Seg [1]11 Seg [111 Segq

Example: You have acquired 10 segments of two channels. You choose to display only segment 1. The Cn
descriptor box reads 10 Seg(ments). The Zn descriptor box reads [1]1 Seg, meaning you are displaying a total
of one segment starting with segment 1.

Clock Source Settings
In some cases, an external clock signal can replace the instrument's internal 10 MHz clock.

Oscilloscope External Clock Frequencies Impedance Use Input
HDO6000 Reference Clock T0MHz +25 ppm @ 0- 10 dBm 50Q Rear REF In
HDOG000A Sample Clock DC to 100 MHz 50Q/ Front EXT In
HDO6000B 1MQ

Note: External clocks can only be used in real-time sampling mode. An external trigger cannot be used when
an external sampling clock is in use.

Internal Cl Internal

v 2 £ oo External

Reference Clock
An external 10 MHz reference clock can be used to synchronize the instrument's internal timebase with an external
frequency source so that multiple instruments can lock timebases to a common source.

1. Connect a clock source to the reference clock input using a BNC cable.
2. Go to Timebase > Horizontal Setup and choose Real-Time Sampling Mode.

3. Onthe Clock Source tab under Reference Clock choose External.

Sample Clock
An external sampling clock replaces the internal timebase as the sampling clock, controlling when the digitizers
sample the input waveforms.

1. Connect a clock source to the sample clock input (see table below) using a BNC cable.
2. Go to Timebase > Horizontal Setup and choose Real-time Sampling Mode.

3. Onthe Clock Source tab, under Sample Clock choose the clock threshold:
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e 0V samples a symmetrical square wave with a minimum amplitude of 150 mVpp at the zero level
» ECL samples a square wave with a minimum amplitude of 150 mVpp at the -1.3 V level
e TTL samples a square wave with a minimum amplitude of 1.8 Vpp atthe +1.6 V level

4. Choose the External Coupling that matches the clock source input impedance.
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History Mode

History Mode allows you to review any acquisition saved in the history buffer. Not only can individual acquisitions be
restored to the grid, you can "scroll" backward and forward through the history at varying speeds to capture changes
in the waveforms over time. To access this feature, choose Timebase > History Mode or press the front panel
History Mode button, then select View History to enable the display.

Each record is indexed and time-stamped, and you can choose to view the absolute time of acquisition or the time
relative to when you entered History Mode. In the latter case, the last acquisition is time zero, and all others are
stamped with a negative time. The maximum number of records stored depends on your acquisition settings and
the total available memory.

Entering History Mode automatically stops new acquisitions. To leave History Mode, press the History Mode button
again, or restart acquisition by pressing one of the front panel Trigger Mode buttons.

@ Note: History Mode does not work with RIS or Sequence Mode acquisitions, or ERes on the input.

[ File | § Vertical | ++ Timebase | I Trigger @ Display = # Cursors | ] Measure @ Math | = Analysis | X Utilities = @ Support

Acq. Time " TV
13:30:36.017 [
61V

51V

41V

11V

10002 A A S

-900mV

176 ps 226 s 276 s 326 s

[ HD [Timebase 76 us|Trigger (8 141§
12 Bits 50.0ps/div Stop 246V
62.5kS 125 MSis Edge Positive

Clear History

1 of 60
waveforms available (| Using 9 MB

Oscilloscope in History mode.

Replay Acquisition History
Watching a "movie" of the history allows you to see waveform changes that are invisible during real-time acquisition.
Use the buttons or the slider bar at the bottom of the dialog to navigate the history.

e Top row buttons scroll: Fast Backward, Slow Backward, Slow Forward, Fast Forward.
» Bottom row buttons step: Back to Start, Back One, Go to Index (row #), Forward One, Forward to End.

Press Pause when you see something of interest, then use the History table to find the exact Index.

View Single Acquisition
Select View Table to show the index of records. Select the row from the table or enter its Index number.
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Trigger

Triggers define the event around which digitized information is displayed on the grid.

Different Trigger Types are used to select different events in the trigger source waveforms: edge voltages, pulse
widths, high/low states, etc. These may be a single-channel event or a complex pattern of events across several
channels. On instruments with Mixed Signal capabilities, pattern triggers can be set on analog channels (including
the External Trigger input), digital lines or a mix of both.

In addition to the type, the Trigger Mode determines how the instrument behaves as it encounters trigger events:
take a single acquisition and stop, holding on to the display of the last acquisition, or continuously take and display
acquisitions.

In both cases, when the previous acquisition has completed processing, the oscilloscope is again ready to acquire
and the READY indicator is lit. If, while READY, the trigger circuit detects a signal that matches the trigger conditions,
the oscilloscope triggers on the next matching event, and the TRIG'D indicator is lit.

Unless modified by a pre- or post-trigger Delay, the trigger event appears at time 0 at the horizontal center of the grid,
and a period of time equal to five divisions of the timebase is shown to the left and right of it. Delay shifts the
acquisition "window" on screen, displaying a different portion of the waveform.

An additional condition of Holdoff by time or events is available for Edge and Pattern triggers, including those that
appear within Qualified triggers. Holdoff arms the trigger on the first matching event, inserts the holdoff count, then
triggers on a subsequent event. Often, especially with repetitive signals, the initial arming event appears to the left of
the trigger in "negative" acquisition time.

Trigger Modes

The Trigger Mode determines how often the instrument acquires. It is equivalent to how analog oscilloscopes
"sweep," or refresh, the display. Trigger Mode can be set from the Trigger menu or from the front panel Trigger
control group.

In Single mode, when you choose Trigger > Single or press the front panel Single button, the oscilloscope readies,
arms, and triggers provided all trigger conditions (including Holdoff) are met. It then stops and continues to display
the last acquisition until a new one is taken. The oscilloscope remains armed unless manually stopped or triggered,
and if a valid trigger does not occur, invoking Single a second time will force a trigger and display the acquisition.

In Normal mode, operation is the same as in Single, except that the trigger automatically re-arms after the previous
acquisition is complete, and data is continuously refreshed on the touch screen.

Auto operates the same as Normal mode, except that a trigger is forced if the trigger event has not occurred within a
preset timeout period.

Stop ceases acquisition processing until you select one of the other three modes. The arming and Holdoff counters
are cleared, even if there has not yet been a trigger since the previous acquisition.
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Trigger Types
The Trigger Type sets the triggering conditions.

Edge triggers upon a achieving a certain voltage level in the positive or negative slope of the waveform.
Width triggers upon finding a positive- or negative-going pulse width when measured at the specified voltage level.

Pattern triggers upon a user-defined pattern of high and low voltage levels on selected inputs. On oscilloscopes with
mixed-signal capability, it may be a digital logic pattern or a combined digital-analog pattern. If your oscilloscope
does not have mixed-signal capability, the pattern can be set using analog channels alone.

Measurement is not technically a trigger, per se, but permits the instrument to stop and display acquisition based on
a post-processing measurement result, similar to a trigger.

TV triggers on a specified line and field in standard (PAL, SECAM, NTSC, HDTV) or custom composite video signals.

Serial triggers on the occurrence of user-defined serial data events. This type will only appear if you have installed
protocol-specific serial trigger and decode options. Go to teledynelecroy.com/serialdata to download manuals.

MultiStage Types

MultiStage triggers define an event on one signal that "qualifies” or arms the triger, and another event on a second
signal that fires the trigger. They are useful for capturing time violations that occur between the state different
signals. First choose MultiStage to show all the triggers in the group.

Cascaded establishes a succession of criteria in Stages A-D. The trigger occurs when stage D—or whatever is the
last defined event—is achieved. In Normal trigger mode, it automatically resets after finding the last defined event.
You may apply additional Holdoff by time or number of events between each stage in the cascade.

Qualified arms when the 'A" event occurs on one signal, then fires when the 'B' event occurs on another. In Normal
trigger mode, it automatically resets after the 'B' event and re-arms upon the next matching 'A' event.

QualFirst is only enabled when in Sequence sampling mode. It operates and is set up exactly like a Qualified trigger,
except that the qualifying 'A' event need only occur once, and all the segments are captured in succession when the
‘B' event occurs on the trigger source.

Smart Triggers
Smart triggers allow you to apply Boolean logic conditions to the basic signal characteristics of level, slope, and
polarity to determine when to trigger. First select Smart to show all the triggers in the group.

Glitch triggers upon finding a pulse-width that is less than a specified time or within a specified time range.
Window triggers when a signal exits a window defined by voltage thresholds.

Interval triggers upon finding a specific time between two consecutive edges of the same polarity. Use it to capture
intervals that fall short of, or exceed, a specified range.

Dropout triggers when a signal loss is detected. The trigger is generated at the end of the timeout period following
the last trigger source transition. It is used primarily in Single acquisitions with pre-trigger Delay.

Runt triggers when a pulse crosses a first threshold, but fails to cross a second threshold before re-crossing the first.
Other defining conditions for this trigger are the edge (triggers on the slope opposite to that selected) and runt width.

Slew Rate triggers when the rising or falling edge of a pulse crosses an upper and a lower level. The pulse edge must
cross the thresholds faster or slower than a selected period of time.
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Other Triggers

What are commonly known as External and Line triggers are not trigger types, per se, but alternative sources that
may be used with several types of triggers, most usually Edge triggers that fire upon the occurrence of a particular
edge and level of the trigger input.

External triggers (Ext source) look for the selected slope and level in an externally generated pulse that is input to the
oscilloscope's Ext. In port. In Pattern triggers, the Ext. In port may be examined for a High/Low state as part of the
overall triggering pattern. Select the Coupling to use for the Ext. In port when defining the pattern.

Line triggers (Line source) are Edge triggers that fire at the occurrence of the 50% level of the selected slope on the
AC power line connected to the oscilloscope.

A Zone trigger allows you to visually define the waveform states that will trigger an acquisition, adding a second set
of trigger conditions to the primary hardware trigger. Similar to a mask test, shapes drawn on the grid represent
Areas that a waveform must be "In" or "Out" to qualify each trigger condition. An acquisition occurs only when all the
primary and secondary trigger conditions are met. Custom Boolean logic can be added to define Areas relative to
each other.

Trigger Set Up

To open the Trigger dialog, press the front panel Trigger Setup button or touch the Trigger descriptor box. Different
controls will appear depending on the Trigger Type selected (e.g., Slope for Edge triggers). Complete the settings
shown after making your selection.

The trigger condition is summarized in a preview window at the far right of the Trigger dialog. Refer to this to confirm
your selections are producing the trigger you want.

Trigger Holdoff Software Assisted Trigger Zone Trigger TriggerScan

Primary Trigger Secondary Trigger Setup
Edge Width Pattern None

[ Source
va i=s > 0 ci

Smart Measurement v Zone

SO —_— Coupling
A4 5 T B oc _
Trigger on

MultiStage Serial i
: ’ = Slope Optimize for HF positive edge

- | Positive

Source
For most triggers, the Source is the analog channel or digital line to inspect for the trigger conditions. Depending on
the type of trigger, in addition to input channels C1-Cn or digital lines D0-Dn, the trigger source may be:

» Apulse from an external instrument connected to the Ext In. input (i.e., external trigger)
» The Line frequency of the oscilloscope power input (i.e., line trigger)

Pattern triggers may utilize multiple sources (such as a mix of analog and digital signals), and likewise Multi-Stage
triggers use different sources for the arming and triggering events.

Tip: On instruments with OneTouch, the trigger source can be easily set by dragging the desired channel
descriptor box onto the Trigger descriptor box. Note that the trigger coupling and slope/polarity will revert to
whatever was last set on that channel.
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Coupling
For analog triggers, specify the type of signal Coupling at the input:

» DC - Frequency components are coupled to the trigger circuit for high frequency bursts, or where the use of AC
coupling would shift the effective trigger level.

e AC - Capacitively coupled. DC levels are rejected, and frequencies below 50 Hz are attenuated.

» LFREJ - Coupled through a capacitive high-pass filter network, DC is rejected and signal frequencies below 50
kHz are attenuated. For stable triggering on medium to high frequency signals.

» HFREJ - DC coupled to the trigger circuit, and a low-pass filter network attenuates frequencies above 50 kHz
(used for triggering on low frequencies).

Slope/Polarity
For some triggers, such as Edge, you will be asked to select the waveform Slope (i.e., rising vs. falling) on which the
triggering event occurs. For others, such as Width, the equivalent selection will be Polarity (i.e., positive vs. negative).

Level
For analog triggers, enter the Level at which the triggering condition must occur. Use the Find Level button to set the
level to the signal mean.

Trigger types that require multiple crossings to define the triggering condition—such as Window, SlewRate and
Runt— will have Upper Level and Lower Level fields.

For digital pattern triggers, the level is determined by the Logic Family that is set on the digital group. This can also
be specified by entering a custom (User-Defined) crossing Threshold and Hysteresis. Usually, there will be a
separate Logic tab for these settings.

Hysteresis

For Edge triggers, you may select to Optimize for HF. When this box is left unchecked, the trigger circuit's hysteresis
is set quite high to eliminate any potential trigger instability from high-frequency noise riding on a low-frequency
input signal. Because HF signal amplitudes tend to be smaller, the Optimize for HF setting reduces the hysteresis
value to make the trigger more sensitive. The effect this will have on trigger behavior depends on the signal's
spectral and noise content rather than just fundamental frequency, so it's overall effect is difficult to quantify.

Conditions (Smart Triggers)

Smart triggers all allow you to apply Boolean logic to extend the possible triggering conditions beyond an absolute
Level and Slope/Polarity.

Absolute

Relative

Triggering events can be Less Than, Less Than or Equal To, Greater Than, etc. an Upper Value and/or Lower Value.

In some cases, it is possible to set a discrete range of values that satisfy the condition. Depending on the trigger, the
triggering values may be any that are In Range bounded by the upper/lower values, or any that are Out Range of the
upper/lower bounds.
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The extent of the range can often also be specified by using a Nominal and Delta value, rather than an absolute
upper and lower value. In this case, the Nominal value sets the center of the range, and the Delta determines how
many units plus/minus the Nominal value are included in the range.

For Dropout triggers, the default is to Ignore Opposite Edge, setting the trigger to fire on a dropout of the Positive or
Negative edge within the given timeframe. Deselecting it has the effect of setting the trigger on Both edges, which
will fire when dropout occurs on either edge.

Patterns
A triggering logic pattern may be set on digital lines, analog channels or a combination of both. See Digital Pattern:
Trigger for digital/mixed-signal trigger setup instructions.

Purely analog patterns may be set on a combination of High/Low states across the channels and the External input.
Disconnect any digital input device to enable the analog pattern trigger controls.

Note: When the assertion of an ongoing external signal is used to arm the trigger, the presence of it can be
made part of the triggering pattern by including the State of the External input. Note, however, that in
Normal trigger mode, the full pattern will need to be detected twice for the trigger to fire: the first occurrence
arms the trigger, the second fires it. Another method is to use a Qualified trigger with the State of the
External input as the arming A event, and the Pattern on the channels as the triggering B event. To use an
externally generated pulse (rather than a persistent High/Low state) to arm the trigger, configure a Qualified
trigger with an Edge on the External input as the A event.

To trigger on a pattern of analog channel High/Low states:

CHANNEL 2

State

1. Onthe Trigger dialog, select the Pattern trigger type.
2. Select the Boolean Operator that describes the relationship among input states:
» AND asserts the simultaneous presence of all the states (e.g., C1 is High AND C2 is Low).
» OR asserts the presence of any state.
» NAND asserts the simultaneous absence of all the states.
» NOR asserts the absence of any state.

3. Foreach inputin the trigger pattern, select what State it must be in compared to the threshold Level. Leave
"Don't Care" for any input you wish to exclude from the pattern.

4. For each input included in the trigger, enter the voltage threshold Level.

5. If you've included the EXT(ernal) input in the pattern, open the Ext tab and enter the input Attenuation.
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Measurement Trigger

Measurement is not technically a trigger, but permits the instrument to stop and display acquisition based on a post-
processing measurement result, similar to a trigger. The available measurements will each offer a different method
for specifying the "trigger" conditions, based on the type of measurement. Generally, you will be able to specify a
triggering value or range of values, and for @level parameters, the voltage level at which the measurement is taken.

Fall at level Condition 0 CLOSE

Transition time Is of all falling edges.

00m

Set Levels to Set Levels to ov
10% and 90% 20% and 80% 00my

TV Trigger
TV triggers on a specified line and field in standard or custom composite video signals.

Trigger (] TriggerScan

Trigger On

264

1. Choose the Source signal input.

2. Choose the signal TV Standard. To use a custom signal, also enter the Frame Rate , # of Fields per line, # of
Lines, and Interlace ratio.

3. Choose the Line and Field upon which to trigger.

Serial Trigger

The Serial trigger type will appear if you have installed serial data trigger and decode options. Select the Serial type
then the desired Protocol to open the serial trigger setup dialogs. For setup instructions, download the software
instruction manual from teledynelecroy.com/serialdata.

Note: Certain software serial triggers can only be input on certain channels; the set up dialog will instruct
you which channel to use. Information on the operation of hardware serial pattern triggers can be obtained
from the High Speed Serial Triggers Instruction Manual.
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Digital Pattern Trigger

Pattern is the default trigger type selection when a digital input device is connected to the instrument. A Pattern
trigger can be set on a digital logic pattern, or a combination of digital logic and analog states.

Logic Bus Method
The Logic Bus method simplifies pattern set up by utilizing digital groups and logic you have already defined on the
Digital setup dialogs. Lines not included in the digital pattern are disabled (X = "Don't Care").

Trigger Digital Pattern Levels Ext TriggerScan

Digital1 e
D6 D5

1. Select the Trigger descriptor and choose Trigger Type Pattern.
2. Onthe Digital Pattern dialog, select the Logic Bus button.

3. Enter the Source Digitaln group to use for the pattern. The dialog will show the high/low logic pattern already
set on that digital group and the hexadecimal Value it represents. The bottom of the dialog shows the entire
pattern across both lead banks.

§=|| Note: Digital lines inherit the Logic Setup made when defining the digital group. However, you can change
the logic threshold on the Levels dialog. The two settings are linked; they will always reflect whatever was
last selected on either dialog. MSO logic thresholds can only be set per lead bank, not individual line.

Logic Method
If you have not yet set up digital groups, you can set a logic pattern line by line using the Logic method. All available
lines remain active for selection.

Trigger Digital Pattern Levels Ext TriggerScan

Setallto ...

1. Select the Trigger descriptor and choose Trigger Type Pattern.
2. Onthe Digital Pattern dialog, select the Logic button.

3. Toapply a digital logic pattern, either:

» Enter the hexadecimal value of the pattern in Hex. Lines will take a logical 1, 0 or X ("Don't Care")
according to the pattern. Inactive lines will remain X.

» Touch the Dn button for each active line and select whether it must be High or Low compared to the
logic threshold. Depending on your selection, a logical 1 (High) or 0 (Low) now appears on the dialog.
Leave X selected for any line you wish to exclude from the pattern. Use the Left and Right Arrow buttons
to display lines in other digital banks.
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Note: As an alternative, you may set edge conditions on any line. Touch the Dn button and choose
the edge. Edge conditions always assume a logical OR in the overall trigger criteria.

4. Open the Levels dialog and either:
 Select a Logic Family for each digital bank (if using Digital Leadset) or digital line (if using HDA125)

» Choose Logic Family User Defined, then enter a custom Threshold voltage and Hysteresis

Adding an Analog Pattern
A pattern of high/low states on analog channels, including the EXT input, can be added to a digital pattern trigger.
The analog pattern forms an additional trigger condition that must be met coincident with the digital pattern.

Note: Only the AND operator is available when combining analog and digital patterns. All the states in the
analog pattern must occur simultaneously.

Trigger Digital Pattern Levels Ext TriggerScan

Setallto ..

uuur

D17-D0 L
nnAnns

nns

1. Touch the Left Arrow button until the C1-EXT group of inputs is displayed in the main section of the dialog.

2. Touch the Cn button for each input to be included in the pattern, and select whether it must be High or Low
compared to the threshold Level you will set. Depending on your selection, a logical 1 (High) or O (Low) now
appears on the dialog. Leave Don't Care ("X") selected for any input you wish to exclude.

3. Open the Levels dialog and enter the voltage threshold for each analog channel included in the trigger.

Trigger Digital Pattern Levels Ext TriggerScan

Analog Levels
Channelt

0.0 mV
Channel2 Go To Digital Logic

0.0 mv o

All inouts set to DC couplina

4. If you've included an EXT input in the analog pattern, open the Ext dialog and enter the Attenuation to use on
the EXT input.

5. The Go to Digital Logic Setup button will return you to the Logic Setup dialog for setting digital thresholds.

Glitch Filter

Filter Out Unstable Conditions ignores short glitches that last less than 3.5 ns in logic state triggers . It is selected by
default, you can optionally deselect it to turn off the filter.
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Qualified Trigger

A Qualified trigger arms when the qualifying A event occurs on one signal, then fires when the B event occurs on
another signal. In Normal trigger mode, it automatically resets after the B event and re-arms upon the next qualifying
Aevent. It is useful for capturing time violations that occur between the state of two signals.

On the Trigger dialog, select MultiStage trigger type and choose Qualified.

igger defined by the simul

Event 'A'
The A signals' transition above or below a given level serves as the enabling, or qualifying, condition for the second,
triggering signal (or pattern of signals). It may be:

» Edge-qualified once the validating Edge condition occurs on the A signal, with no further requirements. This is
set up the same as any Edge trigger by defining the level and slope upon which the A signal is considered to be
qualified. Select this method when using an externally generated pulse to arm the trigger.

» State-qualified, where the A signal amplitude must remain in a High/Low state until the B event occurs. Select
this method when using an externally generated High/Low signal to arm the trigger.

» Pattern-qualified, where a logical pattern must occur across several digital lines/analog channels. The
qualifying Pattern is set up the same as a Pattern trigger.

» PatState-qualified, where a pattern of High/Low states must persist across several analog channels until the B
event occurs. The qualifying pattern is set up the same as a Pattern trigger using only the analog channels (C1-
Cn and Ext inputs).

Note: Qualifying patterns should not include the B trigger source(s) as any input.

On the Qualified dialog, choose the A event. After choosing the qualifying method, open the Event 'A' tab and set the
qualifying conditions.

Event 'A’ Edge Event ‘B’ Pattemn ne Trigger TriggerScan

Acquisition Start

Last Trigger time

Event 'B'

Once you've selected the B trigger event on the Qualified dialog, set up the triggering conditions on the Event 'B'
dialog exactly as you would a single-stage trigger. The B events available depend on the A event selected; for
example, if the A event is a Pattern, the B event can only be an Edge or other single-source trigger such as Width,
Glitch or Interval, not another Pattern.

Note: The B trigger event should not involve any source signal that was used in the qualifying A event.
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Time Window
When the B event is the occurrence of an Edge or Pattern, a window can be set to constrain the time in which B must
occur following A in order for the trigger to fire. Use the When B Occurs buttons to trigger:

« Any Time that B occurs after being qualified by A. This selection is best when you don't care about the time
between A and B events, just that A has already occurred.

* When B occurs in Less Than/Before the time set after being qualified by A.

» When B occurs in Greater Than/After the time set after being qualified by A.

o After N (trigger) Events have occurred on the B signal after being qualified by A. This is similar to Holdoff by
Events, with the added condition that A must have occurred before the first B.

When using a time window, the time between A and B can be counted from either:

» Acquisition Start, in which case only an A event that occurs within the acquisition window of the B trigger event
is used. A events that may have occurred during the "dead time" between acquisitions are ignored.

Tip: If you use this selection, be sure that you have set a long enough timebase that an A event will
occur within the time needed to qualify the trigger.

 Last Trigger, in which case any A events that occurred since the last trigger will start the count, including those
that may have occurred within the "dead time."

QualFirst Trigger

The QualFirst trigger, which is only used in Sequence sampling mode, operates and is set up exactly like the Qualified
trigger, except that the qualifying A event need only occur once, and all the segments are captured in succession
when the B trigger conditions occur on the trigger source (you need "qualify" only the "first" segment).

Note: The Qualified trigger can also be used with Sequence mode acquisitions, but the behavior is different.
Both the A and the B events must occur in order to fire the trigger for each segment.
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Trigger Holdoff

Holdoff is either a period of time or an event count that may be set as an additional condition for Edge and Pattern
triggers. Holdoff disables the trigger temporarily, even if the other conditions are met. Use Holdoff to obtain a stable
trigger for repetitive, composite waveforms. For example, if the number or duration of sub-signals is known, you can
disable them by setting an appropriate Holdoff value.

Hold Off by Time

This is a period of time to wait after the arming event before triggering on the next event. The maximum allowed
time is 20 seconds; Holdoff time is otherwise limited only by the input signal frequency, coupling, and the
instrument's bandwidth.

When a Holdoff by time is counted from the start of the acquisition, the oscilloscope readies, arms on the first event,
holds for the specified time, then triggers on the next event. After one full acquisition has completed, the
oscilloscope again readies, arms, holds, and triggers for the following acquisition.

|Huldnff 5 | |Huldnff 5 |

Arm Trigger Arm Trigger
| I ]
| | |
| | |
| | |
[ | |
[ | |
| | |

+ S S
Ready Complete One Acquisition Process  Ready Complete One Acquisition

Positive Edge trigger with Holdoff by time counted from the start of acquisition.

When a Holdoff by time is counted from the last trigger time, the oscilloscope immediately re-arms on the first event
following the trigger and begins counting the Holdoff, rather than wait to complete the full acquisition. The Holdoff
count continues even during the very brief time between acquisitions while the oscilloscope is processing. As soon
as the Holdoff is satisfied and the oscilloscope is again ready, it triggers on the next event. The re-arming and
Holdoff may occur in one acquisition, and the trigger in the next.

lHuIdnff 5 l IHuIduffS IHoIl:Iu:rlfS I
Arm Trigger Arm Trigger Arm Trigger
iT T
: I ! : |
| | | | |
| [ | | |
| | | | |
| | | | |
| | | | |
F Y T o F Y T
Ready Complete One Acquisition Process  Ready Complete One Acquisition Process  Ready

Positive Edge trigger with Holdoff by time counted from the last trigger time.

Note: Because there is only one trigger per acquisition, the trigger event will always belongs to the new
acquisition. The processing time shown here is for purposes of illustration only.

Regardless of where in the acquisition record the trigger event was found (first edge or last), the display will show
time pre- and post-trigger based on your Time/Div and Delay settings.
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Hold Off by Events

Events refers to the number of times the trigger conditions have been met following the arming event.

For example, if the Holdoff is two edges counted from the start of the acquisition, the oscilloscope readies, arms on
the first edge, holds off for the next two, triggers on the fourth edge, then completes the acquisition. Because there
must always be a first arming edge, it appears to be "Holdoff plus one."

l Holdoff 2 Edges | l Holdoff 2 Edges
Arm 1 2 Trigger Arm 1 2 Trigger

| 1~ 7 ]
1 1 |
I 1 |
| | !
I | |
1 1 |
| 1 |

- S .

Ready Complete One Acquisition Process  Ready Complete One Acquisition

Positive Edge trigger with Holdoff by events counted from start of acquisition.

As with Holdoff by time, when a Holdoff by events is counted from the last trigger time, the oscilloscope re-arms
immediately following the trigger and begins the Holdoff count. If the count is satisfied by the time the oscilloscope
is again ready, the trigger occurs on the next event at the start of the new acquisition.

l Holdoff 2 Edges | l Holdoff 2 Edges I Holdoff 2 Edges l
Arm 1 2 Trigger Arm 1 2 Trigger Arm 1 2 Trigger
177 T
: I | : I
| 1 | 1 |
| 1 | 1 |
| | | i |
| | | i |
| 1 | 1 |
Y o o FY - F Y
Ready Complete One Acquisition Process  Ready Complete One Acquisition Process  Ready

Positive Edge trigger with Holdoff by events counted from last trigger time.

Holdoff Set Up
To add Holdoff to an Edge or Pattern trigger, touch the Trigger descriptor box or press the front panel Trigger Setup
button, then open the Holdoff tab.

Acquisition Start

Trigger on
positive edge
with Holdoff by Time

Last Trigger time

Choose to Holdoff by Time (clock) or Events, then enter the Time (S) or number of Events to wait before triggering.

Choose to Start Holdoff Counter On either the current Acquisition Start time or the Last Trigger Time (time of trigger
from previous acquisition).
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Zone Trigger

A Zone trigger allows you to visually define the waveform states that will trigger an acquisition, adding a second set
of trigger conditions to the primary trigger. Similar to a mask test, shapes drawn on the grid represent Areas that a
waveform must be "In" or "Out" to qualify each trigger condition. An acquisition occurs only when all the primary and
secondary trigger conditions are met.

Areas can be drawn on any analog input signal, not just the primary trigger signal, and the state of different Areas in
relation to each other can be defined using Boolean logic. As a result, you can easily define complex trigger
conditions simply by arranging a set of shapes on the screen and writing a one-line equation.

At this time, Zone triggers can only be used with Edge, Width, Smart or MultiStage primary triggers. All the primary
trigger conditions, including any Holdoff or other qualifiers, must be met before the Zone conditions are applied.

Drawing Areas

An Area is a visual representation of a condition that must be met by its source signal. Each Area has a number
beginning with "A" by which it is identified in the Configuration List and on the screen. A green Area number indicates
that condition (In or Out) is currently being met by the signal on screen, whereas a red number indicates it is failing.

To begin, on the Trigger dialog, choose Zone as the Secondary Trigger. This will add the Zone descriptor to the right
of the Trigger descriptor at the bottom right of the display.

Open the Zone Trigger dialog to begin defining Areas.

Trigger Holdoff  Software Assisted Trigger ~ Zone Trigger  TriggerScan @ cLose
Draw Area Configuration List Boolean Logic Equation Troubleshoot Test

Rectangle Edit
Recall Selected Boolean equations can create a wider range of unique conditions, Enable Pass-Thru
D based on 'and’ or ‘or’ logic commands.
Build your own logic using the equation editor. .

Delet
slete Example: (A1 and not A2) or (A3 and A4)

Custom Save et
= Delete Troubleshoot your zone setup.
All Temporarily ignore all Area conditions.

Drawing Rectangles

1. Open the Zone Trigger dialog and choose Rectangle. You are now in Zone Edit Mode. The grid area will be a
lighter color and the words "Zone Trigger Editor" with a closebox appear in the upper-right corner of the grid.

Zone Trigger Editor

A1 and A2

Note: As long as you remain in Zone Edit Mode, you can draw Areas and define their conditions. Once
you leave Zone Edit Mode by clicking the closebox or clicking on the grid outside an Area, the touch
screen reverts to normal touch behaviors (e.g., rectangle zoom).
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2. Click (or touch) on the grid where you wish to place an Area, then drag to draw a rectangle.

As soon as you release, the Zone context menu appears next to the new Area.

Daon't Care

o C1

~
L2

0 c3
O C4
+ Add Point

== Remove Point

3. Choose whether the waveform must be In or Out of this Area, or if you Don't Care.

Note: "Don't Care" Areas do not affect the trigger. They disappear from the display when you leave
Zone Edit Mode, although the Area remains in position for you to later change the state to In or Out.
This is a convenient way to temporarily "turn off" an Area without having to delete it. "Don't Care"
Areas are saved with Zone configuration setup files.

4. Choose the input Source that must meet this condition.

5. Atthis point, the Area is complete. Follow the procedures in Editing Areas to further modify the rectangle.
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Drawing Custom Shapes
The Custom option allows you to draw freehand shapes by placing a series of points that define the Area. The Area
can be any kind of closed shape you devise.

1. Open the Zone Trigger dialog and choose Custom. You are now in Zone Edit Mode.

2. Click (or touch) on the grid where you wish to place the first point of the Area, then click where you wish to
place the next point. A straight line is drawn between both points.

3. Continue placing points until you have outlined the shape of the Area, finishing by clicking the first point.

As soon as you close the shape, the Zone context menu appears next to the new Area.
4. Choose whether the waveform must be In or Out of this Area, or if you Don't Care.
5. Choose the input Source that must meet this condition.

6. Atthis point, the Area is complete. Follow the procedures in Editing Areas to further modify the shape.
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Editing Areas
Once drawn, the shape of the Area can be modified by "touch" or by using the Edit dialog and context menu. If you
have left Zone Edit Mode, re-enter it by clicking on the Area to be modified.

Editing by Touch
The white points at the corners of the Area adjust the angles of the shape. Click/touch-and-drag points away
from/toward center or along a 360 degree arc.

The resizing handles (arrows) on the edges of the Area scale the shape along the selected plane. Click/touch-and-
drag handles in the direction of the arrows.

To add a point, right-click (touch-and-hold) on the side of the Area where you wish to add the point, then choose Add
Point from the context menu. A new point is added on that side between the original point and the next point. Adjust
the new point as desired.

To delete a point, right-click (touch-and-hold) on the point to be removed, then choose Remove Point from the
context menu.

Note: Whenever you add or delete points, a straight line is drawn between the two adjacent points. Points
are renumbered in clockwise order beginning from 1 in the top-left corner.

To move the entire Area, click inside (all points will be highlighted) then drag it to its new location on the grid.

To create another Area of the same shape and size, right-click (touch-and-hold) the Area and choose Duplicate.
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Editing Using the Edit Area Dialog
Double-click (double-tap) on the Area to open the Edit Area dialog. Most of the same actions as are in the context
menu can be invoked using this dialog.

Edit Area - Al

0]

Points
Point 1
Point 2
Paint 3
Point 4

Close

The dialog allows you to quickly change the In, Out or Don't Care condition of the Area, or the Source channel. If you
change the Source, the Area will move to the grid where that waveform is displayed, maintaining its grid position.
The Configuration List on the Zone Trigger dialog updates accordingly, showing the new Area source channel.

All the vertices defining the Area's shape are listed in Points, with the selected point highlighted in the list and on the
Area outline. You can use the Up or Down button to select the point to be edited, or click/tap on it in the list.

To add a point, select the point before which to add it and click the Plus button.
To delete a point, select it from the list and click the Minus button.

To set an exact grid position, select the point to be moved then enter the new Hor. Pos. (horizontal position) and Ver.
Pos. (vertical position). This feature is useful when you have exact tolerances for a waveform and wish to position
the Area exactly after drawing an approximation of it.

Deleting Areas
To completely remove an Area from the Zone trigger configuration, right-click on it and choose Delete from the
context menu.

Tip: To temporarily "turn off" an Area but keep it in the Zone configuration, change its condition to "Don't
Care."
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Using Boolean Logic

As new Areas are drawn, the Boolean Logic Equation area of the dialog is populated with default 'and' statements,
creating an equation such as "A1 and A2 and A3...". When all the conditions in the equation are true, the oscilloscope
acquires and displays the new, validated waveform.

By using the Logic Equation Virtual Keypad, you can create your own Boolean equations to express the relationship
between Areas that will trigger an acquisition. Click the Edit button to display the dialog.

r hl

Logic Equation Virtual Keypad

(A1 and A2} or (A3 and A4)

‘ ’ Back | Clear

A2 A3 Ad

Set to
Default

Cancel

Each Area will have a button on the dialog, along with operators 'and’, 'or' and 'not' and parentheses. Simply touch the
buttons in order to create the Boolean equation. Use Back to clear the last symbol or Clear to clear all. Set to Default
restores the default "and" for all Area conditions.

The same logic applies as with all Boolean equations:
e expressions in parentheses are evaluated first
» 'and' conjoins, both Area conditions surrounding it must be true
 ‘or' disjoins, either Area condition surrounding it may be true
* 'not' negates, the Area condition must not be true

All Areas that you want evaluated, whether displayed on different grids or drawn on different waveforms, should be
included in the Boolean equation. The logic of the entire equation must be satisfied for the Zone trigger to acquire.
Any signals that are off the screen or do not have Areas in the equation are ignored, like a "Don't Care." Similarly,
leaving the Boolean equation field blank acts like a pass-thru, and nothing is required to be true.

Debugging Zone Configurations

Because the zone trigger display normally only shows waveforms that meet both primary and secondary trigger
conditions (except in the case of Auto trigger mode), it can be difficult to see anomalies that are causing the trigger
to fail. In order to refine your Areas, you can temporarily turn off all Area conditions by checking Enable Pass-Thru.
This will keep the zone configuration on the screen, while using only the primary trigger to acquire waveforms. By
doing this in Normal or Single trigger mode, you will be able to see where Areas need adjusting.
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Saving/Recalling Zone Configurations
The Save button saves only the Zone configuration to a special Zone setup file. When you use the Recall button on
the Zone Trigger dialog, only the Zone configuration is recalled, not the entire waveform setup.
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- FregResponseTable
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Custom Save
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Note: Zone configurations are saved to and recalled with full oscilloscope setup (.Iss) files. This feature
allows you to save and recall only Zone configurations while retaining the rest of your acquisition and
measurement setup.
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Zone Descriptor Box

0

The Zone descriptor box appears to the right of the Trigger descriptor box as soon as there is an Area
on the screen. Using keywords and a colored "LED" display, it informs you of the current state of the
system's trigger (primary and secondary).

Trig'd

Zone Descriptor Statuses

i - LED Color
'II;;lgdger Passts tTh ru Keyword
Single or Disabled Waiting Waited >0.5 seconds for NA Primary trigger occured, but
Normal Primary hardware trigger. Zone conditions not all met.
Disabled Trig'd NA All primary trigger and NA
Enabled Pass-Thru NA Zone conditions met. Primary trigger occured, but
Requires Boolean logic to | zone conditions not all met.
be true. Waveform displayed anyway
(passes thru).
Auto Disabled Auto NA All Zone conditions met | Zone conditions not all met
since time of last Auto since time of last Auto trigger.
Enabled Auto NA trigger. Requires Boolean
logic to be true.
Stop Disabled Stop NA Acquisition shown met all | Acquisition shown failed some
Zone conditions. Zone conditions. Will only
Requires Boolean logic to | occur following Auto trigger or
be true. This may also after moving Areas so that
Enabled Stop NA occur after moving Areas |they are now "true’, since in
so that they are now Single or Normal mode, all con-
"true”. ditions must be met for acquis-
ition to occur.

Like all descriptor boxes, the Zone descriptor is also interactive:

» Toreopen the Zone Trigger dialog, touch the Zone descriptor.

e To quickly draw a new rectangle Area on the screen, drag the Zone descriptor to the desired grid.
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Software Assisted Trigger

Software Assisted Trigger is used to find the trigger-level crossing point closest to the hardware trigger point. It then
adjusts the time offset of the waveform so that it is aligned with the specified trigger level and slope.

In the following figure, the white trace is the waveform at the input to software-assisted trigger processing. The red
trace shows it after processing, aligned with the trigger point indicated by the red marker below the grid.

-1.000 ns Auto
L 4

Stop Normal

From the menu, choose Triggers > Trigger Setup, then touch the Software Assisted Trigger tab.

. Touch Enable.

Create a trigger window by entering a Hysteresis value. This value sets a boundary above and below the main
trigger level to exclude noise.

Choose Auto or Normal mode; this determines the trigger behavior when trigger crossings are not found in
the trigger source waveform.

 Auto mode allows all waveforms through the channel.

» Normal mode allows waveforms only with a trigger crossing within the horizontal gate region through
the channel.

Set Start and Stop time values on the Horizontal Gate part of the Software Assisted Trigger tab. These values
control where in the waveform the software-assisted trigger processing searches for trigger crossings.
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TriggerScan

TriggerScan is a debugging tool that helps you quickly discover waveform anomalies by automating the process of
building triggers designed to find rare events in an acquisition.

Triggerscan trains the system by looking at acquired waveforms. During the training, TriggerScan analyzes the
waveforms to determine what waveforms normally look like. Using this information, it generates a list of smart
triggers designed to isolate abnormal situations. All acquisition settings are preserved in the TriggerScan setup file
for future use.

After loading the trigger setups from the Trainer, TriggerScan scans new acquisitions for rare events by cycling the
different triggers. As triggers occur, the waveforms are displayed on the screen. AutoSaving waveform files with
each trigger allows you to capture the TriggerScan data.

Training TriggerScan
The TriggerScan Trainer inspects the current acquisition and automatically builds a list of trigger setups that could
potentially be used to find events of interest.

§=|| Note: Run the Trainer if you want to change the trigger types or if you change the channel or signal. You
must acquire and display at least 3 cycles of a signal before running the Trainer.

1. Touch Trigger > Trigger Setup... from the menu bar, then open the TriggerScan tab.
2. Touch the Trainer button.

3. Onthe TriggerScan Trainer pop-up, choose the Source channel on which to train and trigger, and select all the
trigger types you want to set up.

4. Touch the Start Training button. When training is complete, a list of smart trigger setups is displayed in the
Trigger List.

Modifying Trigger List
Follow these steps to change the triggers created by TriggerScan. Once you have finalized the Trigger List, you are
ready to start scanning.

Trigger TriggerScan

Control
Trainer Load oad the d Start
Selected
Triggers
Delete
ew 0 0 Selected

Save Setup Load Setup

= = Delete
Selected 0 All

1. Toadd a new trigger to the list: Set up the new trigger as desired on the Trigger dialog. Then, back on the
TriggerScan dialog, touch the Add New button to append the new trigger to the Trigger List.

2. Toreplace a trigger with one manually set up on the Trigger dialog: highlight the trigger in the Trigger List,
then touch the Update Selected button.

3. Todelete a trigger from the list: highlight the trigger in the Trigger List, then touch the Delete Selected button.
All trigger setups can be deleted in one step by touching the Delete All button.

4. Optionally:
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 Enter a Dwell Time the time instrument should wait before loading the next trigger.
» Check Stop On Trigger. You can use this to isolate events as triggers find them.

Saving TriggerScan Setups
You can preserve the Trigger List by saving it to a setup file. The current Trigger List is not preserved after exiting the
application unless you manually save it.

1. On the TriggerScan dialog, touch Setup File Name and enter a file name, or touch the Browse button and
select a location and file name.

2. Touch the Save Setup... button.

To reload a saved Trigger List, touch the Browse button, locating the file, then touch Load Setup....

Running TriggerScan
When the Trigger List is set, touch the Start Scan button on the Trigger Scan dialog. The instrument automatically
cycles through all the triggers in the list.

To run only a single trigger, select it from the Trigger List and touch Load Selected. The trigger settings are copied to
the Trigger dialog and will be used when you start acquisition.

Viewing Acquisition Status

All current acquisition settings can be viewed through the various Status dialogs. Access them by choosing the
Status option from the Vertical, Timebase, Trigger, Math, or Analysis menus. The available options will depend on
your model.

Trigger time C1..C4 F1...F4 F5...F8 -2 5.8 XY M1...M4 Others

500 ns 10.000000000 GS/s
100.000 ps
5.0000 kS

with
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Display

Display menu settings affect the number and style of grids that appear on screen and some of the visual
characteristics of traces, such as persistence.

The oscilloscope features a multi-grid display, where each separate grid represents the full number of 4096 vertical
levels. Auto Grid Mode is enabled by default. This feature adds a grid each time a new trace is turned on. Other Grid
Mode selections are available on the Display dialog; the icons show what the result of that selection will be.

Available with the Q-Scape option, the Q-Scape Display Modes divide the screen into multi-tab displays, each of
which can be configured with a different grid mode.

Display Set Up

To access the Display dialog, choose Display > Display Setup.

Open the Persistence dialog to apply persistence to the trace display.

Second Monitor Configuration

Open Monitor

Control Panel

Q-Scape Display Mode
The Display Mode setting determines the number and layout of Q-Scape display tabs. See Q-Scape Display.

Grid Mode

The Grid Mode setting determines the number and layout of display grids, each of which represents the full number
of vertical levels. The selection icon shows the number and arrangement of grids.

In Normal Display Mode, select one Grid Mode. In Q-Scape Display Mode, select a Grid Mode for each tab.

Grid Mode Number Orientation Notes

Auto variable [landscape [Automatically adds or deletes grids as traces turned on/off, up to the maximum sup-
(default) ported

Single 1 landscape | All traces share one grid

Dual 2 landscape |One top, one bottom

Tandem 2 portrait One left, one right

Triple 3 variable Two landscape grids left, one portrait grid right
Quad 4 landscape | Stacked top to bottom

Quattro 4 landscape |Oneineach quarter of screen

Octal 8 landscape | Two columns of four stacked top to bottom
Twelve 12 landscape | Three columns of four stacked top to bottom
Sixteen 16 landscape |Four columns of four stacked top to bottom
XY 1 portrait Single XY type grid

XYSingle 2 portrait One VT grid left, one XY grid right

Note; Additional grid modes may become available with the installation of software options.
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Other Grid Settings

To dim or brighten the background grid lines, touch Grid Intensity and enter a value from 0 to 100.

Grid on top superimposes the grid over the waveform.
Note: Some waveforms may be hidden from view with the grid on top.

Axis labels display the values represented by each division of the grid, based on your vertical scale and timebase.
Turned on by default, they may appear as absolute values or delta from center (0). Deselect the checkbox to remove
them from the display.

Trace Settings
Choose a line style for traces: solid Line or disconnected sample Points.
When more data is available than can actually be displayed given the number of vertical levels, Trace Intensity helps

to visualize significant events by applying an algorithm that dims less frequently occurring samples. Touch Intensity
and enter a value from 0 to 100.

Intensity 40% (left) dims samples that occur < 40% of the time to highlight the more frequent samples,
vs. intensity 100% (right) which shows all samples the same.

XY Plots

XY plots display the phase shift between otherwise identical signals. They can be used to display either voltage or
frequency on both axes, each axis now corresponding to a different signal input, rather than a different parameter.
The shape of the resulting pattern reveals information about phase difference and frequency ratio. See XY Cursors
Dialog for a description of the labels added to the XY display.

Note: The inputs can be any combination of channels, math functions or memories, but both sources must
have the same X-axis scale.

Choose an XY grid mode and select the sources for Input X and Input Y.

Sequence Display Mode
This setting is used to select the Display Mode used when sampling in Sequence mode.
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Q-Scape Display

Q-Scape divides the screen into multi-tab displays that can each be configured with different multi-grid display
modes. Many of the same functions you can perform in Normal mode, such as moving traces by drag-and-drop, you
can also perform in Q-Scape. Q-Scape oscilloscopes have an option for both the Display Mode and the Grid Mode.

Display Mode

The Display Mode setting determines the number and layout of display tabs, each of which can in turn have different
numbers and styles of grids within them. Choose either Normal (default), a single display with no tabs, or one of the
three Q-Scape display modes:

Q-Scape Single, a single set of four tabs stacked so
that only one at a time is visible. Each tab can have
any style of grid mode, same or different.

Q-Scape Dual, two sets of four stacked tabs.
Equivalent tabs in each set share the same grid mode,
but can display different traces. You can
simultaneously view one tab from each set, but they
must be different numbered tabs (e.g., Tab 1 from set
one and Tab 3 from set two).

Q-Scape Mosaic, a single set of four tabs arranged so
that all are viewed simultaneously. Note the tab at the
top of each display, which distinguishes Mosaic
display mode from Quad grid mode.

In Q-Scape modes, channel, math, memory, and zoom descriptors appear in the tab where the trace is open, while
Timebase and Trigger descriptors remain outside the tabs, since they are not associated with any one trace.
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Note: If you switch from Normal mode into any Q-Scape mode, all traces will move to Tab 1, from which you
can drag-and-drop to redistribute them to other grids. In Q-Scape Single mode, you will not be able to drag-
and-drop traces across tabs, only to other Tab1 grids.

Renaming Tabs

The labels shown on the Q-Scape tabs can be changed to something descriptive of what is shown within that display
to better orient you to complex screen layouts.

To rename Q-Scape tabs after they open:
1. Touch-and-hold (right-click) on the Tab n until Rename pops up.
2. Touch Rename.

3. Enter the New Alias, then touch OK.

Extended Display

Note: The "Extend Grids..." option only appears when a second monitor is connected. Minimize the
oscilloscope window and use the standard Windows Display controls to make the instrument the primary
display. It should be extended, not duplicated.

To take advantage of a second monitor display when in Q-Scape mode:
1. Onthe Display dialog, select Extend Grids Onto 2nd Monitor. The Select Grid pop-up opens.
2. Switch to the Extended Display submenu and choose a Grid style. Tab 1 and the external monitor will share

the same grid style.

Tip: Drag-and-drop descriptor boxes to place traces on the desired grids.To take full advantage of Q-Scape
on the larger display, choose File > Windowed on the instrument, then grab the window title bar and drag it
to the external monitor screen. Drag the Extended Display window to the instrument screen.
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Persistence Display

The Persistence feature retains waveform traces on the display for a set amount of time before allowing them to
gradually "decay," similar to the analog-style display of old, phosphor screen oscilloscopes. The display is generated
by repeated sampling of events over time and the accumulation of the sampled data into "persistence maps".
Statistical integrity is preserved because the duration (decay) is proportional to the persistence population for each
amplitude or time combination in the data.

The different persistence modes show the most frequent signal path in three-dimensional intensities of the same
color (Analog), or in a graded spectrum of colors (Color).

Access the Persistence dialog from the Display dialog or by choosing Display > Persistence Setup.

Display Persistence

3D Settings

All Locked

Per Trace

Turn On Persistence
7. Check Persistence On.

2. Tosetup all traces together, touch All Locked. This constrains all input channels to the same persistence
settings. To set up traces individually, touch Per Trace.

3. Use the buttons to select a persistence mode:

In Analog Mode, as a persistence data map develops, different intensities of the same
color are assigned to the range between a minimum and a maximum population. The
maximum population automatically gets the highest intensity, the minimum
population gets the lowest intensity, and intermediate populations get intensities in
between these extremes.

Color Mode persistence works on the same principle as Analog persistence, but
instead uses the entire color spectrum rather than intensities of a single hue: violet for
minimum population, red for maximum population.

3d Mode persistence creates a topographical view of your waveform from a selection

of shadings, textures, and hues. The advantage of the topographical view is that areas
of highest and lowest intensity are shown as peaks and valleys, in addition to color or brightness. The shape
of the peaks (pointed or flat) can reveal further information about the frequency of occurrences in your
waveform. You choose the Quality of the 3D display:

Solid quality can be either color or monochrome. Saturation is set at 50%, with
hotter colors indicating highest intensity.

In the monochrome view of solid, the lightest areas indicate highest intensity,
corresponding to the red areas in the color view.

73



HD06000B High Definition Oscilloscopes Operator's Manual

In shaded (projected light) quality, the shape of the pulses is emphasized. This
quality is monochrome only.

In wire frame quality, lines of equal intensity are used to construct the persistence
map. This display can be either color or Monochrome.

In 3d mode, X Axis Rotation and Y Axis Roation can range 180° from -90° to +90°. In the examples above, the
X-axis is rotated 60° an the Y-axis 15°.

Tip: To quickly rotate the graph, grab a corner of the persistence map and drag it in the desired
direction.

Select the Saturation level as a percentage of the total population. All populations above the saturation level
are assigned the highest color intensity. At the same time, all populations below the saturation level are
assigned the remaining intensities. Data populations are dynamically updated as data from new acquisitions
is accumulated. A saturation level of 100% spreads the intensity variation across the entire distribution; at
lower saturation levels, the intensity will saturate (become brighter) at a lower population, making visible
those events rarely seen at higher saturation levels.

In Persistence Time, enter the duration (S) after which persistence data is erased from the display.

. You can superimpose the last waveform over the persistence map by selecting Show Last Trace (not

available in 3d mode).

7. Todisplay traces as a continuous line (instead of a series of sample points), select Dot Joined.

Turn Off Persistence

To turn off persistence and return to the regular trace style, clear the Persistence On checkbox.
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Math and Measure

Teledyne LeCroy offers arich set of standard, pre-programmed tools for the "quickest time to insight" into the
characteristics of acquired waveforms. Most instruments calculate measurements on all samples in an acquisition,
enabling you to rapidly accumulate thousands or millions of parameter values. You can also apply a variety of
mathematical functions to the input waveform trace and view the transformation in a math trace.

Zooming

Zooms magnify a selected region of a trace by altering the horizontal and/or vertical scale relative to the source
trace. They may be created in several ways, using either the front panel or the touch screen.

The current settings for each zoom trace can be seen on the Zn dialogs, while the Zoom dialog is a convenient panel
for turning on/off different zooms or quickly changing the zoom source.

You can adjust zooms the same as any other trace by using the front panel Vertical and Horizontal knobs or the
touch screen zoom factor controls.

The MultiZoom feature locks the Horizontal Scale and Center of those traces that you choose to include in the
MultiZoom group. As you change the scale or position of any trace in the group, all traces change in unison.

Creating Zooms

Any type of trace can be zoomed by creating a new zoom trace (Zn) following the procedures here. Zoom traces
open in the next empty grid, with the zoomed portion of the source trace highlighted. If there are no more available
grids, zooms will open in the same grid as the source trace.

Note: On most instruments with OneTouch, traces can be "zoomed" by pinching/unpinching two fingers
over the trace, but this method does not create a separate zoom trace. Pinching channel traces will alter the
acquisition timebase and the scale of all traces. Create a separate zoom trace to avoid this.

Zoomed area of original trace highlighted. Zoom in new grid below.
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Quick Zoom

Use the front panel Zoom button to quickly create one zoom trace for each displayed channel trace. Quick zooms
are created at the same vertical scale as the source trace and 10:1 horizontal magnification. The MultiZoom feature
is turned on, and all the new zooms are automatically added to the MultiZoom group.

To turn off the quick zooms, press the Zoom button again.

Rectangle Zoom

To "rectangle zoom", touch-and-drag diagonally to draw a rectangle around the part of the
source trace you wish to magnify. If you choose a Zn location, a new zoom of that trace is
created; if you choose the source trace as the destination, you will rescale the original
trace.

A new zoom will expand the horizontal area selected to fit the full width of the grid, while
the vertical area will be rescaled proportionally. The degree of vertical and horizontal
magnification, therefore, depends on the size of the rectangle that you draw.

Alternatively, with OneTouch you can drag any Zn descriptor box over the Add New box, or
touch the Add New box and choose Zoom from the pop-up menu. The next available
zoom trace opens with its Zn dialog displayed for you to modify scale as needed.

Zoom Function

Finally, you can create a Zoom math function. This method creates a new Fn trace, rather than a new Zn trace, but it
can be rescaled in the same manner. It is a way to create more zooms than you have Zn slots available on your
instrument.

Index Zoom

If you are working in a serial decoder, you can zoom the region of the source trace that is represented by one index
(row) of the decoder result table simply by touching that row. This method works for many software options that
present tabular results, besides the decoders.

Adjusting Zoom Scale

The zoom's horizontal units will often differ from the signal timebase, because the zoom is only showing a portion of
the total acquisition spread across 10 divisions. You can adjust the zoom factor using the front panel knobs or the
zoom factor controls however you like without affecting the timebase (a characteristic shared with math and
memory traces).

Close Zoom
New zooms are turned on and visible by default. If the display becomes too crowded, you can close a particular
zoom and the zoom settings are saved in its Zn slot, ready to be turned on again when desired.

To close the zoom, right-click (touch-and-hold until the white box appears) on the zoom descriptor box, then from
the context menu choose Off.
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Zoom Dialog

Details_.. 5 (C1) Details...
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Choosing Math > Zoom Setup from the menu bar opens a dialog summarizing all active and inactive zoom trace

settings. Use the selection boxes to turn on/off zooms. There are also options to:

» Reset All, return all zooms to x1 magnification.

» Quick Zoom, create a corresponding zoom trace for each open channel trace, same as using the front panel
Zoom button.

e Turn on MultiZoom for all active zooms.

Zn Dialog

MultiZoom

50.0 mV

0.0mV

%1.00 W ver

C = ] Reset
Measure Zoom

Behind the main Zoom dialog is a separate tab for each potential zoom trace (Z1-Zn). Each Zn dialog reflects the
center and scale for that number zoom. Use the Zoom factor controls to adjust each zoom independently.

Trace Controls
Trace On shows/hides the zoom trace. It is selected by default when the zoom is created.

Source lets you change the source of the zoom to another trace while maintaining all other settings.

Segment Controls
These controls are used to select the segment(s) to be "zoomed" for display when sampling in Sequence Mode.

Zoom Factor Controls

» Outand In buttons increase/decrease zoom magnification and consequently change the Horizontal
and Vertical Scale settings. Touch either button until you've achieved the desired level.

 Var.checkbox enables zooming in single increments.

 Horizontal Scale/div sets the time represented by each horizontal division of the grid. It is the equivalent of
Time/div in channel traces, only unlike that setting, it may differ for each zoom trace.

 Vertical Scale/div sets the voltage level represented by each vertical division of the grid; it's the equivalent of
V/div in channel traces.

» Horizontal/Vertical Center sets the time/voltage at the center of the grid.

» Reset Zoom returns the zoom to x1 magnification.
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MultiZoom

MultiZoom unifies the Horizontal Scale (Time/div) setting of those traces that you add to the MultiZoom group. The
traces can be zooms or other types of calculated (as opposed to acquired) time traces, such as memories or math
functions. This allows you to zoom in/out on several traces in unison, even if they represent different sources, and
pan the entire group together by dragging one trace or using the Auto Scroll controls.

Note: Traces that cannot be in the same MultiZoom group because they are not time traces or are different
record lengths will be excluded from selection when setting up MultiZoom.

MultiZoom is automatically enabled when you use the Quick Zoom method, and all Quick Zooms are added to the
MultiZoom group. The descriptor boxes of those traces in the group are marked with a green underline.

When MultiZoom is enabled manually from the Zoom or MultiZoom dialogs, active zooms are automatically added
to the MultiZoom group, although other types of calculated traces must be added manually. As you add traces to the
group by checking the selection box on the MultiZoom dialog, they are set to the same Horizontal Scale as the first
trace that was added to the group since MultiZoom was last enabled. Once the group is set, modifying any member
of the group using the front panel Horizontal knobs or touch screen Horizontal controls will change the entire group.

Note: The lowest numbered zoom is usually the "master” trace to which all others are rescaled. When
MultiZzoom is used with decoded Serial Data waveforms, the result table functionality overrides this
behavior, and zooms created by touching a table cell will center on that part of the acquisition.

MultiZoom does not affect the Vertical Scale and Offset of any traces in the MultiZoom group. These continue to be
controlled independently for each trace.

Set Up MultiZoom
7o E MultiZoom

F1 = d{C1)dx

Independent

1. Choose Math > Zoom Setup... to open the Zoom dialog.
2. Check the MultiZoom box. Active zooms are added to the group and rescaled to the first active zoom.

3. To modify the group further by adding or removing other types of traces, open the MultiZoom dialog and
select all the traces that are In the MultiZoom group.

4. Optionally, choose an Independent Zoom Position to simultaneously view different time spans of different
traces, while continuing to zoom and scroll in unison. After you select Independent, open the individual trace
dialog (e.g., Zn) and change the Horizontal Center.

Note: Scrolling or dragging any of the MultiZoom group traces will shift the Horizontal Center of this
trace by the same amount of Delay as the others, however, it will remain proximate to the center you
set, which can be useful when wanting to step through two different sections of a longer acquisition.
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Scroll Waveforms

The Auto-Scroll controls appear at the right of the MultiZoom dialog. They work similarly to A/V controls to allow you
to continuously scroll all the selected traces in time-locked steps from the beginning to the end of the acquisition.

Cursors

Cursors are markers (lines, cross-hairs, and arrows) that identify horizontal and vertical values where they intersect
the X or Y axis. Use cursors to make fast, accurate measurements of points on the waveform.
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Both Relative cursors. The same cursor type is applied to all open traces.

Cursor Types

Horizontal Cursors

Horizontal cursors are positioned at points on the x-axis and will measure the source trace horizontal and vertical
values at that point.

Horizontal Cursor Readouts

The Horizontal Abs(olute) cursor displays a single line, X1. The readout below the Timebase and Trigger descriptors
shows the horizontal value where X1 intersects the x-axis, in whatever is the x-axis unit of the source trace. The
readout on the source trace descriptor box shows the vertical value where X1 intersects the source trace, y@X1, in
whatever is the y-axis unit of the source trace.

The Horizontal Rel(ative) cursor displays two lines: X1 with the down-pointing arrow, and X2 with the up-pointing
arrow. The readout below the Timebase and Trigger descriptors always shows:

» The value where each cursor intersects the x-axis (X1 and X2)
* The difference of X2 — X1 ((Ax)

» Fortime traces, the frequency in Hz calculated from the delta time (1/(Ax).

79



HD06000B High Definition Oscilloscopes Operator's Manual

Tip: On instruments with OneTouch, when you drag the horizontal cursor readout from below the Timebase
descriptor box onto a zoom trace grid or zoom descriptor box, the cursors will automatically adjust position
to reflect the difference in scale between the zoom and source traces.

The readout on the source trace descriptor box depends on which Show option is selected:
» Absolute shows the vertical values where X1 and X2 intersect the source trace.

+ Delta shows the difference in vertical value where each cursor intersects the source trace (marked by the
arrows), calculated as: y@X2 — y@X1 = Ay. When the X1 arrow is higher than the X2 arrow, this will be a
negative number, as it represents a drop (e.g., in voltage), even when X2 is positioned above the zero level.
When the X1 arrow is lower than the X2 arrow, this will be a positive number, as it represents arise.

» Abs + Delta shows both absolute and delta readouts.

 Slope calculates the difference in vertical value over the difference in horizontal value represented by the slope
from the X1 arrow to the X2 arrow, or: Ay/Ax. The value will be intelligently converted to whatever unit is
appropriate for the source trace. Like the Delta readout, it will be positive or negative depending on the vertical
position of X2 relative to X1, regardless of its horizontal position.

When horizontal cursors are not tracking, they can be dragged to any position along the x-axis individually. The
horizontal delta represents X2 — X1, which will be a positive number so long as X2 remains to the right of X1. If X2 is
moved to the left of X1, this will now be a negative number.

Horizontal Scale

Horizontal cursors can be placed on traces whose x-axis has a dimension other than time, such as an FFT or a
Trend. When there is at least one non-time-domain trace open, the Standard Cursors dialog contains an X-Axis
control where you can choose the units to be measured by the horizontal cursors. The options will be appropriate to
the types of traces open; for example, if there is an FFT trace, there is an option for Hz. The cursors are placed on
those traces that display x-axis values in the selected units, rather than those with an x-axis of time.

Vertical Cursors

Vertical cursors intersect the y-axis and show the vertical value at that point (e.g., a voltage). These cursors can go
"off trace" to show vertical scale values that are not represented in the acquisition. Vertical cursors have no
horizontal readout below the Timebase descriptor, as they do not have an x-axis element. As they are set by
divisions, they remain in the same position and do not "readjust” with changes in the scale of the underlying traces.

The Vertical Abs(olute) cursor displays a single line, Y1. The readout on the source trace descriptor box shows the
vertical value at the point where Y1 intersects the y-axis.

The Vertical Rel(ative) cursor displays two lines: the dashed-dotted line is Y1, and the dashed line is Y2. As with the
Horizontal Relative cursor, the readout on the source trace descriptor box depends on the Show selection:

» Absolute shows the vertical values where Y1 and Y2 intersect the y-axis.

* Delta shows the difference in value of Y2 = Y1 (Ay). As long as Y2 remains below Y1, this is a negative number,
even if Y2 is positioned above the zero level. If Y2 is moved above Y1, it will become a positive number.

e Abs + Delta shows both vertical readouts.

Combination Cursors

The Both Rel(ative) option places both Vertical Relative and Horizontal Relative cursors together. The readouts will
be the same as when placing the cursors individually.
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Apply and Position Cursors
To turn on cursors, either:

e From the menu bar, choose Cursors and select the desired cursor type from the drop-down list.

» On the front panel, press the Cursor button to turn on cursors, then continue pressing to cycle through all the
cursor types. Stop when the desired type is displayed.

Note: There must be a trace on the grid for cursors to execute, although acquisition may be in process or
stopped when you turn them on.

To turn off cursors, either:

e From the menu bar, choose Cursors > Off.

 Continue cycling the Cursor button until you reach "Off" (the cursor lines disappear).
To reposition a cursor:

» Drag-and-drop the cursor marker to a new position. Indicators outside the grid show to which trace the cursor
belongs when you have multiple traces on one grid.

Use the Position data entry controls on the Standard Cursors dialog to place cursors precisely.

 Alternatively, use the Front Panel Cursor knob. Push the knob until the correct cursor is selected, then turn the
knob to move it. The third press of the Cursor knob selects both cursors so they will track together when the
knob is turned.

Tip: When there are multiple traces on the same grid, first bring the desired trace to the foreground by
touching the trace or its descriptor box. The Cursor knob will only operate on the foreground trace.

On oscilloscopes with OneTouch, if Horizontal cursors are applied to a source trace but do not appear on its
dependent traces (e.g., a zoom) because of differences in scale, drag-and-drop the cursor readout from below the
Timebase descriptor box onto the target trace descriptor box. This will apply the cursor at the 5 (absolute) or 2.5 and
7.5 (relative) division marks of the target trace and adjust the source trace cursor accordingly.

To track cursors, moving both lines together at a consistent distance, check Track on the Standard Cursors dialog.
Drag the X1 or Y1 cursor marker, or select the set using the front panel controls and turn the Cursor knob. The delta
readouts should show little or no change when tracking, although absolute readouts will change depending on the
new position of the cursors. Moving the X2 or Y2 cursor will reset the relative distance and the delta, after which you
can again track by moving the X1 or Y1 markers.
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Standard Cursors Dialog

These controls can be used instead of the front panel controls to turn on cursors or to refine the cursor position.
Access the dialog by choosing Cursors > Cursors Setup from the menu bar.

Standard Cursors

Cursor Type buttons select the type of cursor displayed on the grid.

The Show controls determine what values are shown in the vertical readout when using relative cursors:

Absolute shows specific voltages for the two cursor locations.
 Delta shows the difference between the specific voltages at the cursor locations.

Abs+Delta shows both the absolute and delta readouts.

« Slope (Horizontal Relative only) shows the slope of the waveform between the cursor locations.
Refer to Cursor Types for a detailed explanation of what is shown with each option.

The Position controls at the right-side of the Standard Cursors dialog display the current cursor location and can be
used to set a new location.

» X1 and X2 sets the position of Horizontal cursors. They may be entered as time or a fraction of a division.
* Y1andY 2 sets the position of Vertical cursors, entered as a fraction of a division.

Track locks relative cursor lines so they move together, maintaining the same distance from each other. Only move
X1 or Y1 to reposition the cursors. Moving X2 or Y2 will change the relative distance.

XY Cursors Dialog

X-Y cursors read the vector magnitude (Radius) and Phase relative to the positive X axis as well as the voltages in
the source channel sample points. The cursor readings can track across the X-Y waveform displays, so that the
source components for any cursor measured vector are measured at the same time. This information is useful in
applications that use quadratic signal generation such as radar and digital communications, where an error in the
vector parameters can be traced easily to the source components.

If your Grid Mode selection includes an XY trace display, an XY Cursors dialog appears behind the Standard Cursors
dialog. Use it to exactly position and track cursors on XY traces, the same as you use the settings on the Standard
Cursors dialog for time traces. The user interface is the same.

The XY cursor readouts immediately below the XY plot show:

Marker Value shown

AY /[ AX = Ratio of AY and AX values

AY * AX = Product of AY and AX values

dB Ratio in dB calculated 20 * log10 (ratio)

Angle = Angle (polar) calculated arc tan (AY / AX) range [-180° to +180°]
Radius = Radius (distance to origin) calculated sqrt (AX * AX + AY * AY)
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Measure

Parameters are tools that give you access to a wide range of waveform properties, such as Rise Time, RMS voltage
and Peak-Peak voltage. The instrument offers a quick selection of standard parameters, or you can create a user-
defined set of parameters (My Measure) drawn from all available measurements.

On instruments equipped with CustomDSO (XDEV), custom scripts may be used to calculate a parameter. Several
scripting "languages" are supported, depending on the application. You can find these options in the Custom
submenu of the Measure Selector. Scripts may be imported or written in the instrument's Script Editor window. See
Using P Script for a description of the process.

Parameter readouts are shown in a dynamic Measure table that appears below the waveform grids. All active
measurements can be used as inputs to other processes, such as Pass/Fail tests, even when the Measure table is
hidden from view. The history of a parameter can be graphed as a histogram, track or trend for statistical analysis.

Measure Dialog

The Measure Dialog gives quick access to measurement features. Besides turning on/off parameters, use the
Measure dialog to display statistics, histicons and help markers for standard and user-defined parameter sets. You
can also gate parameters to limit the horizontal scope of the measurement.

Use the Parameter (Pn) dialogs to create a user-defined set of parameters.

Clear All 5 Gate

Definitions
Default Locic

Measure S o - . T e Quick

Setups
Std etups

Yertical Help Markers
e Show  Clear Clear
Horizontal ), On --- ) Oon --- All All Sweeps

Selecting Measurements

1. To open the Measure dialog, touch the Add New box and select Measurement, or choose Measure > Measure
Setup from the menu bar.

2. Check Show Table to display the readout. This is not required to take the measurement.
3. Choose the Std. Vertical or Std. Horizontal parameters.

Or, to turn on your own parameters, choose My Measure, then select the On checkbox next to each parameter
you wish to display. Open the Pn dialogs to define new parameters.

4. Optionally:
e Show Help Markers.
» Gate parameters to limit measurements to only edges inside the gates.
» Add Statistics and Histicons to the Measure Table.

Touch Clear Sweeps to reset all measurement counters and restart all statistics.

Touch Clear All Definitions to reset all parameters to "None".

A Caution: Definitions cannot be restored after clearing, you must repeat parameter set up.
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Standard Parameter Sets
The pre-configured standard parameter sets available on the Measure dialog are:

 Std Vertical: Pk-Pk, Ampl, Max, Min, Sdev, Mean, Base, Top
 Std Horizontal: Rise, Fall, Period, Frequency, Width, Duty Cycle, Delay, N Points

To quickly begin a new set of user-defined parameters based on the standard vertical or horizontal sets, touch Quick
Setups and choose the set to copy. Refine the settings on the Pn dialogs.

Statistics and Histicons

Checking Statistics On on the Measure dialog adds the mean, min, max and sdev of each parameter to the
measured value shown on the Measure table.

Statistics for each parameter are calculated once per acquisition and accumulate until you either Clear Sweeps or
the measurement buffer is full. The Num row of the Measure table shows the total number of measurements
included in the Statistics calculation. If the measurement is gated, the statistics are calculated for only the data
points between the gates, just as the parameter value itself will reflect the limits imposed by the gate.

Mean The weighted mean of the parameter calculated over the number of times shown.

Min The minimum value of the parameter measured over the number of times shown.

Max The maximum value of the parameter measured over the number of times shown.

Sdev The population standard deviation of the parameter calculated over the number of times shown.

Num For any parameter that computes once on an entire acquisition, Num represents the number of sweeps over

which the statistics are computed.

For any parameter that computes on every event within an acquisition, such as a full period, Num represents the
number of events per sweep times the number of sweeps computed. Thus, for a Single acquisition of five periods,
the Num shown for any per period measurements will be 5, as five measurements were made and the statistics
reflect those five measurements. After another Single acquisition, Num will be 10, or five measurements times two
sweeps. The statistics now reflect all 10 measurements.

_ | | Histicons are miniature histograms of measurements that may be added to the
histo Measure table . They let you see at a glance the statistical distribution of each

parameter. Check Histicons on the Measure dialog.

0 Tip: You can quickly display a full histogram by touching the histicon you want to enlarge.

Gating Measurements

All measurements are calculated on only that portion of the waveform trace that is visible on the grid and within the
measurement gates. Any setting that moves the trace outside the observation window or makes it appear "clipped"
will affect measurements.

The default starting positions of the measurement gate posts are 0 div and 10 div, which coincide with the left and
right edges of the grid, and the First and Last points. Therefore, the measurement gates initially enclose the entire
visible acquisition. By moving the measurement gates, you can focus the measurement on the section of the
acquisition of greatest interest. For example, if you "gate" six rising edges of a waveform, calculations are performed
only on the six pulses bounded by the gate posts.
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FAMWAAMNA

Measure P1:cveles(C1] P2:dper@lv(C1) P3:area(C1)
value 14 cve -2.943 ns 458.9155 pWb
mean 14 cvc -50 ps 458.9155 pWhb
min 14 cve -3.585 ns 4589155 pWb
max 14 cye 3.788 ns 458.9155 pWhb
sdev — 2.147 ns —
num 1 13 1
status v L L

Measure P1:cvcles(C1) P2:dper@!

value S cve 2. 5

mean dcve 328 ps 209.2512 pWhb
min 5cve -3.576 ns 209.2512 pWb
max Scve 2.552 ns 209.2512 pWh
sdev — 2496 ns

num 1 4

status v "

Gates (vertical white lines) limit the data measured and visibly change measurement calculations.

If you wish to gate all parameters to the same number of edges, use the Gate fields on the Measure dialog. For user-
defined parameter sets ("My Measure"), first check Lock to activate the Start and Stop fields. Standard parameter
sets are automatically gated to the same number of edges, you do not need to first Lock the gates. The quickest way
to set a gate is to drag the gate posts from the far left and right of the grid to the desired positions, or you can enter
the Start and Stop positions down to hundredths of a division. When gates are locked, all measurements will change
together when you drag either gate post to reposition the gate.

Deselect Lock to return gates to their last unlocked position. Touch Default to return gates to the edge of the grid.

To apply different gates to individual user-defined parameters, deselect Lock on the Measure dialog and use the
Gate subdialog of the Pn dialog to enter the Start and Stop positions. These positions will be resumed when gates
are unlocked.
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Help Markers

Help Markers clarify measurements by displaying lines, labels and hysteresis bands to mark the points being
measured on the trace. For "@Level" parameters, markers make it easier to see where your waveform intersects the
chosen level. If you change the set of parameters displayed, the markers will change, as well.

You can choose to use Simple markers, which are only the lines, or Detailed markers, which include the
measurement point labels.

You also have the option, by means of the Always On checkbox, to leave the markers displayed over traces after you
have closed the Measure dialogs or readout table.

Note: Unlike regular cursors, which are white and can be moved, help markers are blue and only augment
the display; they cannot be moved, and they do not reset the measurement points. Some optional analysis
software packages include markers designed specially for that domain of reference, which are documented
in the option manual.

Detailed Help Markers
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Parameter Set Up
Use the Pn dialogs to define a new set of measurement parameters ("My Measure”).

Dtime@level 1 Dtime@level 2 Gate Accept €3 cLose

Find level

1. From the menu bar, choose Measure > Measure Setup.

2. Choose Measure Mode My Measure.

3. Open the Pn dialog and check On to activate the parameter.

4. Select the Type Measure On Waveforms.

5. Touch the Source selectors and choose the trace to be measured. Some measurements require two sources.
6. Touch the Measure field and select the measurement from the pop-up menu.

7. Make any further selections on the subdialogs that appear after your Measure selection. These are explained
on the dialog and are necessary to fully define the measurement.

» For @Level parameters, enter the measurement level and optional hysteresis.
* For certain time-based measurements, choose the slope(s) on which to begin the measurement.

» Where relevant, choose to make the measurement per period or cycle.

8. Optionally, turn on help markers, or use the parameter subdialogs to:
» Gate measurements (limit the horizontal scope of the measurement)
» Accept only measurements that meet additional conditions

» Change the output units of measure.

Slope, Level and Hysteresis

Several time-based measurements enable you to select on which edge of the waveform the measurement begins, or
at what level the measurement is taken (e.g., *@level parameters). These measurements usually also offer options
for determining how the level is defined, and for setting up a hysteresis band to prevent unwanted waveform effects
from altering the measurement.

Slope

The Slope determines the edge of a pulse (the X axis point) at which measurements are made, or from which edge to
which edge a single period/cycle is counted. Slope can impact per period and cyclic measurements, as the number
of complete periods may be different depending on which edge is used.

For two-input parameters, such as Dtime@level, you can specify the Slope used for each input separately to
determine the points on each waveform to be compared.
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There are three possible settings for Slope:
» Positive, use the rising edge of a pulse

» Negative, use the falling edge of a pulse

» Both, use either edge, whichever next occurs that meets the other criteria

Here, the P1 Half Period parameter uses a Slope of Both, resulting in 10 measurements in this five period acquisition,
one every time the signal crosses the 50% Level, rising or falling (only the first rising edge measurement is marked by

the Help Marker).

167.771 ns
166.551 ns
164 668 ns
168.888 ns
1410 ns
10

'

330.784 ns
335.185 ns
1.449 ns

5

'

If Slope were set to Positive, there would be only five measurements in this acquisition, one every time the rising
edge crossed the 50% Level, but not the falling edge (the Num row shows the difference).

P1:hper(C1)
165.781 ns
165.744 ns
164 668 ns
168.147 ns

1274 ns
5
v

P2:period{C1)
3513 ns
333.095 ns
330.784 ns
335.185 ns
1.449 ns

5

o

88



Math and Measure

Level

Level is the point on the Vertical (Y) axis used to take a measurement. The default Level for measurements is 0 V or
50% amplitude, the center grid line when there is no Vertical Offset . When Level can be specified, it can usually be
set as either:

* An Absolute number of Volts, or whatever is the vertical unit of the source waveform
» A Percent of waveform amplitude, as determined by the Top-Base calculation

Measurements that may be calculated per period usually have a Levels setting to specify the Level on the rising edge
from which full periods are counted.

Hysteresis

The Hysteresis setting defines an amplitude "band” which the input signal must exceed before a crossing can be
determined. Some non-zero Hysteresis value is required to prevent false crossing determinations. The default value
is 500 millidivisions (mdiv), with the unit “divisions” being equal to oscilloscope vertical grid divisions.

» Lower hysteresis values improve the ability to detect crossings on a smaller amplitude signal, but with risk that
false crossings will be detected. This also means that the signal must meet a minimum amplitude requirement,
and be relatively noise free at lower amplitudes.

» Higher hysteresis values improve the ability to reject the impact of signal distortion or noise in determination of
the crossing, but with risk that accuracy of crossing detection will be reduced.

For example: a non-monotonic signal crosses the 50% measurement threshold on the rising edge nine times within
the observation window, although there are actually only four waveform cycles. Without Hysteresis, the non-
monotonicity period is incorrectly detected as crossing and therefore a measurement interval, which will result in
incorrect calculation of periodic measurements.

€One Measurement Interval®»| |€One Measurement Interval»| |€One Measurement Interval®| |€One Measurement Intervald)|

A A A A A

S\

Zero Crossing Level

> € > € > € > > €

One Measurement Interval One Measurement Interval One Measurement Interval One Measurement Interval One Measurement Interval

A Hysteresis level that is greater than the amplitude of the non-monotonicity results in only four measurement
intervals, avoiding false measurement calculations.

€ One Measurement Interval >|€ One Measurement Interval |€ One Measurement Interval | € One Measurement Interval >

BN

Hysteresis Zero Crossing Level
Band

89



HD06000B High Definition Oscilloscopes Operator's Manual

Periodic and Cyclic Measurements
Some measurement set up dialogs display a checkbox for Show one value per period or Cyclic.

Periodic measurements return one measurement per full waveform period in the acquisition. Usually, "per period” is
an option for Vertical parameters, like Amplitude, that would normally return only the value of the last full period in
the acquisition. By choosing Show one value per period, the Amplitude of each full period measured is computed
into the mean, and num will show the number of measurements used (value will still show the value of the last pulse
measured). The example below shows how the P1 Amplitude parameter Num statistic changes from 1 to 5 when
set to measure per period. A hysteresis band Help Marker also appears, showing the level at which the periods are
counted.

229.278 mV/ 333.293 ns
222 47T mV 331.425 ns
23421 mV 334.614 ns

4235 mV 1.124 ns
5 5
v v

Tip: A WaveScan set to Measurement mode on the same source and measurement will show all the per
period values within the acquisition.

Similarly, cyclic measurements are computed over the span of full periods in the acquisition, ignoring any partial
periods at the beginning or end of the acquisition. For example, if the Area parameter is set to Cyclic, and the
acquisition has five full cycles, then only the Area of those five cycles is calculated, as shown below. The blue Help
Markers show the five full periods, while the partial periods at the start and end of the acquisition are omitted.
Normally, the Area of the full, visible acquisition is calculated. In both cases, only one measurement value is returned,
but the value will be different.

F

P1:area(C1) P2:period{C1)
-79.27728 pWb 331425 ns
-79.27728 pWb 33 5
-79.27728 pWb 331425 ns
-79.27728 pWb 334614 ns

1.124 ns
5
v
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Counting Periods/Cycles

Per period and cyclic measurements are subject to the other measurement settings, such as the Slope and Level
from which to count the waveform periods. Always visit the subdialogs that appear when checking Show one value
per period or Cyclic to determine if there are further settings to be made.

When the measure gates are in their default positions of 0 and 10 div, the periods/cycles are counted across the full
width of the grid. If the gates are set elsewhere, then the measurements are computed on only as many full
periods/cycles are within the gate. As shown below, gating the cyclic Area measurement reduces the calculation to
the three full cycles that are within the measure gates.

Fy
P1:area(C1) P2:perod(C1)
46.66824 pWb 331.425ns
46 66824 pWb 333.293 ns
46.66824 pWb 331.425ns
46 66824 pWb 334 614 ns
1.124 ns
5
'

N-Cycle and N-Period Set Up

The measurements Period@level and Dperiod@level include settings to specify how often to make the
measurement and at which cycle to start, rather than using only the full integer number of cycles. The subdialogs
containing these settings are called variously N-Cycle Setup and N-Period Setup, but they do the same thing.

Group Size sets the interval of full cycles at which to take the measurement. For example, the image below shows an
acquisitive of five full cycles, which is evident from the P2 Period statistics showing Num 5, indicating that's how
many periods were calculated. P1 Dperiod@level, which by default measures the delta between two consecutive
periods, shows only a Num of 4, because using a Group Size of 1, four comparisons could be made—period 1 to
period 2, period 2 to period 3, and so forth.

Measure P1:dper@lv(C1) P2:pericd(C1)
value -1.686 ns 331.425 ns
mean 401 ps 333293 ns
min -1.686 ns 331.425 ns
max 1.253 ns 334.614 ns
sdev 1.239 ns 1.124 ns
num 4 5
status v v
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Note that although the Help Markers overlay the first two periods, the measurement value of -1.686 ns reported is
actually the final measurement comparing the last two periods, as would be shown by looking at a WaveScan of the
same acquisition.

When the Dperiod@level Group Size is changed to 2, the measurement is taken every other period, and because only
two measurements can be made out of the five period total (periods 1 to 3 and 2 to 4), the P1T Num changes to 2.

Measure P1:dper@Iv(C1) P2:penod(C1)
value -3.189 ns 331.425 ns
mean -803 ps 333293 ns
min -3.189 ns 331.425 ns
max 1.584 ns 334.614 ns
sdev 2 386 ns 1.124 ns
num 2 5
status v v

Start Cycle is the cycle from which to begin counting the measurement, which can be any number Group Size-1, as
the count will begin with the first full group. When the P1 Dperiod@level Start Cycle is changed from 0 to 1, period 1
is skipped, and the measurement begins at period 2. Now, Num has changed to 1, because only one measurement
can be made using periods 2 and 4, omitting 3 and 5 due to the Group Size of 2.

Measure P2-penod(C1)
ETS . 5 331.425ns
mean 172 ns 333.293 ns
min : 5 331.425ns
max 172 ns 334 614 ns
sdev 1.124 ns
num 5
status I
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Dperiod@level also allows you to also specify how the Group Size interval is treated, as a separator or a summation.
Use One Value Per Group (shown above) measures every nth cycle, the first in each group. Sum All Values in Group
(shown below) calculates the sum of all the cycles in the group and compares it to that of the next group.

Measure v(C1) P2:period(C1)
value -4 5 331.425 ns
mean -1 361 ns s
min -4 361 ns 331.425 ns
max -4 361 ns

sdev

num

status

Accepting Measurements

Some measurements can be constrained to a vertically or horizontally limited range of values, or to samples "gated"
by the state of a second waveform. Both constraints can operate together. This capability enables you to exclude

unwanted characteristics from your measurements. It is much more restrictive than a measurement gate, which is
used only to narrow the span of analysis along the horizontal axis.

Note: Since this feature operates on only a subset of the data, possible alerts or status indicators
concerning the measurement (such as "Data range too low") are not displayed.

If the measurement supports this feature, you will see the Accept subdialog next to the Pn dialog for you to define
your constraints.

N-Cycle Jitter Gate Accept

When Wform
C1

Level Type

Percent 4
== @ 4

= :
Find Range — Find Level

Range Limited Parameters

1. From the menu bar, choose Measure > Measure Setup..., then touch the Pn tab to open the parameter setup
dialog.

2. Onthe Accept subdialog, select Values In Range and enter the start and stop values, or touch the Find Range
button to quickly display the most recently measured range of values.
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Note: The correct units for the measurement (V, s, Hz, dB, etc.) are automatically displayed. If you
select a simple ratio parameter that yields a dimensionless number (such as power factor), units are
omitted.

Waveform Gated Parameters

1. From the menu bar, choose Measure > Measure Setup, then touch the Pn tab to open the parameter setup
dialog.

2. Onthe Accept subdialog, select Values Based on Waveform State.

3. Touch When Wform and select the gating waveform. It can be any waveform active at the same time as the
measurement source waveform.

4. Touch State Is and select High or Low from the pop-up menu. Measurements will only be taken when the
gating waveform is in the selected state.

5. Touch Level Type and select Absolute (voltage) or Percent (of amplitude) from the pop-up menu.
6. Enter the crossing Level value at which you want measurements to begin.
You can also touch the Find Level button to automatically set the level at 50% of the gating waveform.
Changing Units

Use the Units subdialog to change the output unit of a measurement parameter or math function trace. The dialog is
only active when there are alternative units in the equivalent dimension as the source unit.

Unit Category is the unit type, for example, Length, Velocity, or Time.

Units reflect the Category selection, for example, a Length unit of meters (m) versus a Velocity unit of meters per
second (m/s).

Gate Accept Units Delta Period More._. @ CLOSE

If de ferent unit from the same unit
s day

hour min

94



Math and Measure

List of Standard Measurements

Note: Unless otherwise stated, measurements are calculated according to IEEE standards. Additional
measurements may be available depending on the software options installed. The keyword to use in remote
control programs appears in Summary on the Pn dialog.

Waveform Measurements

Amplitude - Difference between the upper and lower levels in two-level (bi-modal) signals. Differs from Peak-to-Peak
(pkpk) in that noise, overshoot, undershoot, and ringing do not affect the measurement. Amplitude is calculated
using the formula for Top-Base. On signals that cannot be identified as bi-modal (e.g., triangle waveforms),
Amplitude returns the same value as Maximum — Minimum. Amplitude may be calculated once per period, rather
than once per acquisition, by selecting "Show one value per period" on the Amplitude subdialog.

Area - Integral of data. Computes the area of the waveform relative to the zero level. Values greater than zero
contribute positively to the area; values less than zero contribute negatively. If Cyclic is checked on the Area
subdialog, the area is calculated only over the total number of full cycles, rather than the entire acquisition. See
Periodic Measurements.

Base - Lower level in two-level (bi-modal) signals (the higher is Top), or lower of two most probable waveform states

on waveforms that are not bi-modal. Base differs from Minimum in that noise, overshoot, undershoot and ringing do

not affect the measurement. On signals that are not bi-modal (e.g., triangle waveforms), Base returns the same value
as Minimum. Base may be calculated once per period, rather than once per acquisition, by selecting "Show one value
per period" on the Base subdialog.

Bit Rate - Bit rate of input data stream, calculated on rising edges only, so it is not affected by DCD. The
measurement must be made on at least three rising edges, so that there is more than one interval between rising
edges. Otherwise, the measurement returns the clock frequency, and a warning symbol will appear on the Measure
table.

Cycles - Number of cycles in a periodic waveform that occur between the measurement gates (by default, 0 and 10
divisions, or the full acquisition). The first cycle begins at the first rising threshold crossing after the left
measurement gate.

Delay - Time from the acquisition trigger to the first 50% level crossing visible in the observation window. On
acquisitions without a Timebase Delay setting, this is usually a negative number.

Delta Delay - Time from the first 50% level crossing of Source1 to the first 50% level crossing of Source?2. Delta Delay
can be used to measure the propagation delay between two signals by triggering on one and measuring the Delay of
the other. It may yield a negative result in cases where the Source2 crossing occurs before the Source1 crossing.
See Gating Measurements.

Dperiod@level - Cycle-to-cycle deviation of the period measurement, measured from rising edges (Pos Slope), falling
edges (Neg Slope), or next crossing (Both Slope) at the specified Level. See Slope, Level and Hysteresis. By default, it
measures the adjacent cycle deviation (cycle-to-cycle jitter) for each cycle in a waveform, but it may be configured to
compare cycles at set intervals or the mean value of groups of cycles by using an N-Cycle Setup. See Periodic.
Measurements.

Dtime@level - Time between transitions on two, different input signals, measured on rising edges (Pos Slope), falling
edges (Neg Slope), or next crossing (Both Slope) at the specified Level. Dtime@level may yield a negative result in
cases where the Source?2 crossing occurs before the Sourcel crossing. See Gating Measurements and Slope, Level

and Hysteresis.
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Dtrig Time - Time from last acquisition trigger to the present acquisition trigger. For Sequence Mode acquisitions,
the time between segment triggers within a single segmented waveform.

Duration - Time from first acquisition trigger to last acquisition trigger included in an average, histogram, or
segmented waveform. For single-sweep acquisitions, Duration is 0. For segmented waveforms (Sequence mode
acquisitions), Duration is the time from the first segment trigger to the last segment trigger (that occurs between the
measurement gates). For averages, histograms and other waveforms calculated over a history of acquisitions,
Duration is the time from the first to the last accumulated waveform's trigger.

Duty Cycle - Percent of period for which data are above or below the 50% level of the signal, using a hysteresis band
of 22% of amplitude.

Duty@level - Percent of period for which data are above or below a specified level, measured on rising edges (Pos
Slope) or falling edges (Neg Slope). See Slope, Level and Hysteresis.

Dwidth@level - Difference between adjacent Widths, measured on rising edges (Pos Slope), falling edges (Neg
Slope), or next crossing (Both Slope) at the specified Level.

Edge to Edge - Time from the specified edge on Source1 to the specified edge on Source2.

Edge@level - Number of edges in waveform that cross the specified threshold Level, measured on rising edges (Pos
Slope), falling edges (Neg Slope), or next crossing (Both Slope). See Slope, Level and Hysteresis.

Fall 80-20% - Duration of a pulse waveform's falling transition from 80% to 20% of the amplitude, measured for all
falling transitions with the value for the last full pulse shown. On signals that do not have two major levels (e.g.,
triangle waveforms), the Top-Base measurement used to calculate Amplitude can default to Maximum and
Minimum, giving less predictable results.

Fall Time - Duration of a pulse waveform's falling transition from 90% to 10% of the Amplitude, measured for all
falling transitions, with the value for the last full pulse shown. On signals that do not have two major levels (e.g.,
triangle waveforms), the Top-Base measurement used to calculate Amplitude can default to Maximum and
Minimum, giving less predictable results.

Fall@level - Duration of pulse waveform's falling transition between two, user-specified transition levels, measured
for all falling transitions, with the value for the last full pulse shown. Two vertical values on the falling edge are used
to compute fall time:

High = upper threshhold value x Amplitude/100 + Base
Low = lower threshold value x Amplitude/100 + Base

See Slope, Level and Hysteresis.

First - Time at which the left measurement gate intersects the Horizontal axis, marking the first sample point
included in the measurement. By default, this is the time at 0 divisions, set at the far left of the grid.

Frequency - Reciprocal of each Period of cyclic signal. Period is measured as time between every pair of 50%
crossings on the rising edge, starting with the first rising transition after the left measurement gate.

Freg@level - Reciprocal of each Period of a cyclic signal. Period is measured as the time between every pair of
crossings at the specified level and edge, starting with first matching transition after left measurement gate. See
Slope, Level and Hysteresis.

Half Period - Half period of a waveform, measured as the time between adjacent transitions of opposite slope at a
specified level. You can configure this measurement to be taken from only rising edges to falling edges (Pos Slope),
from only falling edges to rising edges (Neg Slope), or from every crossing to the next (Both Slope). See Slope, Level

and Hysteresis.
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Hold Time - Time from the first data signal edge at specified slope and level (Source?), to nearest previous clock
signal edge at specified slope and level (Source1). Use Hold Clock subdialog to specify clock edge, and Hold Data
subdialog to specify the data edge.

Last - Time at which the right measurement gate intersects the Horizontal axis, marking the last sample point
included in the measurement. By default, this is the time at 10 divisions, set at the far right of the grid.

Level@X - Vertical value at the specified x-axis position, which may be set by entering a value or moving the white
measurement cursor. If the position is between two sample points, it gives the interpolated value. When the Nearest
point checkbox is selected, it gives the vertical value of the nearest data point.

Maximum- Largest vertical value in a waveform. Unlike Top, does not assume the waveform has two levels.

Mean - Average of vertical values in a waveform. Computed as centroid of distribution for a histogram of the data
values.

Median - Average of Top and Base values.
Minimum - Smallest vertical value in a waveform. Unlike Base, does not assume the waveform has two levels.

N-Cycle Jitter - Peak-to-peak jitter between edges measured at N Ul intervals. Results may be viewed in time (S) or
ul.

NBPhase - Narrow Band Phase, phase at a specified frequency of the signal.
NBPower - Narrow Band Power, power at a specified frequency of the signal.
Num Points - Number of data points in the source waveform between the measurement gates.

Overshoot- - Amount of overshoot following falling edges, represented as percentage of amplitude. Overshoot- is
calculated using the formula (Base - Minimum)/Amplitude x 100. On signals that do not have two major levels (e.g.,
triange waveforms), this measurement may not give predictable results.

Overshoot+ - Amount of overshoot following rising edges, represented as a percentage of amplitude. Overshoot+ is
calculated using the formula (Maximum - Top)/Amplitude x 100. On signals that do not have two major levels (e.g.,
triangle waveforms), this measurement may not give predictable results.

Peak to Peak - The difference between the maximum and minimum vertical values within the measurement gates.
Unlike Amplitude, does not assume a waveform has two levels.

Period - The time between 50% crossings on the rising edge, starting with the first transition after the left
measurement gate. Period is measured for each adjacent pair, with values averaged to give the final result.

Period@level - The time between crossings at a user-specified slope and level, starting with first transition after the
left measurement gate. See Slope, Level and Hysteresis. By default, Period is measured for each adjacent pair, with
values averaged to give the final result, but it can be configured to compare cycles at set intervals by using an N-
Period Setup. See Periodic Measurements.

Phase - Phase difference between analyzed and reference signals, measured from the 50% level of their rising
edges.

Rise 20-80% - Duration of a pulse waveform's rising transition from 20% to 80% of amplitude, measured for all rising
transitions with the value for the last full pulse shown. On signals that do not have two major levels (such as triangle
or saw-tooth waves), the Top-Base measurement used to calculate rise can default to Maximum and Minimum,
giving less predictable results.

Rise Time - Duration of a pulse waveform's rising transition from 10% to 90% of amplitude, measured for all rising
transitions with the value for the last full pulse shown. On signals that do not have two major levels (e.g., triangle
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waveforms), the Top-Base measurement used to calculate rise can default to Maximum and Minimum, giving less
predictable results.

Rise@level - Duration of a pulse waveform's rising edge between user-defined transition levels, measured for all
rising transitions with the value for the last full pulse shown The two values used to compute the rise time are
calculated as:

Low = lower threshold x Amplitude/100 + Base
High = upper threshold x Amplitude/100 + Base

See Slope, Level and Hysteresis.

RMS - Root Mean Square of the vertical values (between the measurement gates).

If Cyclic is checked on the RMS subdialog, the RMS is calculated over only full cycles, rather than the entire
acquisition. See Periodic Measurements.

Setup - Time from data edge (Source?) to next nearest clock edge (Source?).
Skew - Time of Clock2 edge (Source?) minus the time of previous Clock1 edge (SourceT).

Slew Rate - Slew rate (local dV/dt) at user-specified slope and level. See Slope, Level and Hysteresis.

Std Dev - Standard deviation of the vertical values between the measurement gates.

This is equivalent to the RMS for a zero-mean waveform. Also referred to as AC RMS.If Cyclic is checked on the Std
Dev subdialog, the standard deviation is calculated over only full cycles, rather than the entire acquisition. See
Periodic Measurements.

TIE@level - Difference between the measured crossing time at the specified slope and level and the ideal expected
time. The measurement may be given in time (S) or unit interval (Ul). A Ul equals one clock period. The Virtual Clock
(set up on the VClock subdialog) enables you to simulate your choice of Standard (1.544 MHz) or Custom reference
clocks. You can also use a mathematically derived Golden PLL to filter low frequency jitter. The cutoff frequency is
user selectable. See Slope, Level and Hysteresis.

Time@level - Time from trigger (t=0) to crossing at a specified slope and level. See Slope, Level and Hysteresis.

Top - Higher vertical value in two-level (bi-modal) signals (the lower is Base), or higher of two most probable
waveform states on waveforms that are not bi-modal. Top differs from Maximum in that noise, overshoot,
undershoot and ringing do not affect the measurement. On signals that do not have two major levels (e.g., triangle
waveforms), Top returns the same value as Maximum. Top may be calculated once per period, rather than once per
acquisition, by selecting "Show one value per period" on the Top subdialog.

Width - Width of cyclic signal at 50% level and positive slope, using a hysteresis of 22% of amplitude, measured for
all transitions with the value for the last full pulse shown.

WidthN - Width of cyclic signal at 50% level and negative slope, using a hysteresis of 22% of amplitude, measured for
all transitions with the value for the last full pulse shown.

Width@level - Width of cyclic signal at a user-specified level, slope and hysteresis, measured for all transitions with
the value for the last full pulse shown. See Slope, Level and Hysteresis.

X@max - The horizontal axis location of the maximum vertical value between the measurement gates.

X@min - The horizontal axis location of the minimum vertical value between the measurement gates.
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Histogram Measurements
These measurements can be made on histogram math functions. You will receive an error status if you attempt to
place them on a pulse waveform or other incompatible source.

FWXX - Full Width at xx%, width of the largest area histogram peak at a user-specified percentage of the population
of the highest peak.

Hist ampl - Difference in value of the two most populated peaks in a histogram when the distribution is bi-modal. If
the distribution is not bi-modal, it is the difference between the Maximum and Minimum values in the histogram.

Hist base - Value of the left-most of the two most populated histogram peaks.
Hist max pop - Count of the maximum population (highest) peak in a histogram.
Hist maximum - Highest measured value in a histogram.

Hist mean - Average or mean value of measurements in a histogram.

Hist median - Median value of measurements in a histogram, the 'X-axis' of a histogram that divides the population
into two equal halves.

Hist minimum - Lowest measured value in a histogram.
Hist mode - Value represented by the highest histogram peak, shown in the unit of the histogrammed parameter.

Hist pop@x - Population of the histogram bin at a specified horizontal position.It is helpful to Stop Trigger and turn
on Axis Labels for this measurement so you can see the visible range of horizontal values. Once you enter a value in
this range, the histogram cursor will appear for you to drag to different positions along the X axis. The value reported
on the Measure table will change as you drag the cursor.

Hist range - The Max-to-Min range of a histogram.

Hist rms - Root mean square of the values in a histogram.

Hist sdev - Standard deviation of the values in a histogram.

Hist top - Value of the right-most histogram peak.

Hist X@peak - Value of the nth highest histogram peak. You supply the value of n.

Peaks - Number of peaks in a histogram.

Percentile - Horizontal data value that divides a histogram so that the population to the left is xx% of the total.

Total Pop - Total population (number of values plotted) of a histogram.

Custom Measurements

These "measurements” enable you to insert a custom script into the oscilloscope process and read back results into
the parameter in real time.The script must yield a numeric result.

Custom measurements are standard on WaveMaster, LabMaster, DDA and SDA models. They are enabled with the
XDEV option on others.

ExcelParam - Custom measurement calculated in Excel. The measurement will transfer one or two waveforms (as a
series of time-value pairs) into an Excel spreadsheet and read the result of the function into the parameter.
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Fast Multiwave Port - Provides memory mapped C++ file access using multiple inputs for custom measurement
calculation. The result may optionally be read back into the parameter.

HParamScript - Custom Visual Basic or Java script that calculates a measurement on one or two input histograms,
as opposed to waveforms.

MathCad param - Custom MathCad function that calculates a measurement.

MATLAB param - Custom MATLAB function that calculates a measurement. You may write a MATLAB script on the
oscilloscope, or call a pre-existing MATLAB function into a script. MATLAB can run locally on the oscilloscope, or
remotely on a host that is accessible to the oscilloscope. See the MAUI Oscilloscopes Remote Control and
Automation Manual for instructions on connecting to MATLAB remotely.

ParamScript - Visual Basic or Java script that calculates a measurement from one or two input waveforms. The
script may run locally on the oscilloscope, or remotely on a host that is accessible to the oscilloscope. See the MAUI
Oscilloscopes Remote Control and Automation Manual for instructions on connecting remotely.

Determining Top and Base Lines

Proper determination of the Top and Base reference lines is fundamental for ensuring correct parameter
calculations. The analysis begins by computing a histogram of the waveform data over the time interval spanned by
the left and right measurement gates. For example, the histogram of a waveform transitioning in two states will
contain two peaks (see figure). The analysis will attempt to identify the two clusters that contain the largest data
density. Then the most probable state (centroids) associated with these two clusters will be computed to determine
the Top and Base reference levels: the top line corresponds to the top and the base line to the bottom centroid.
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Determining Rise and Fall Times

Once Top and Base are estimated, calculation of the rise and fall times is easily done (see figure). The appropriate
threshold levels are automatically determined by the instrument, using the amplitude (ampl) parameter.

Threshold levels for rise or fall time can also be selected using absolute or relative settings (if @level measurements
are included with your model). If absolute settings are chosen, the rise or fall time is measured as the time interval
separating the two crossing points on a rising or falling edge. But when relative settings are chosen, the vertical
interval spanned between the base and top lines is subdivided into a percentile scale (base = 0 %, top = 100 %) to
determine the vertical position of the crossing points.

The time interval separating the points on the rising or falling edges is then estimated to yield the rise or fall time.
These results are averaged over the number of transition edges that occur within the observation window.
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crosses the x% level, and & the time when falling edge i crosses the x% level.
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Measure Table

The header of the Measure table shows the parameters configured for each measurement slot (P1-Pn).

The value row of the Measure table shows the measurements taken for each parameter on the last acquisition. You
may optionally calculate and display the statistical mean, min, max and sdev of all parameters. Statistics are
calculated once per acquisition and accumulate over multiple acquisitions, up to the two billion value limit of the
measurement buffer.
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To quickly set up the table, drag any configured cell onto an empty cell of the Measure table. Then, drag the
descriptor box of the trace to be measured onto the new parameter. Touch the cell to choose a new measurement
or make any other modifications on the Pn dialog.

Close setup dialogs when the Measure table is displayed to maximize the area available for viewing waveforms. The
table itself can be used to reopen setup dialogs. To open the Parameter Setup (Pn) dialog, touch the Pn cell of the
table. Touch the far left Measure column to open the Measure dialog and modify the table. The table is static when
using standard measurement sets, as these cannot be changed.

Symbols in the status row of the Measure table indicate the following:

OK: valid value returned.

Warning: there is a problem with the signal or the setup that prevents measuring. Touch the parameter cell
to see an explanation in the message bar.

No Pulse/Insufficient Data: The software is unable to determine top and base. This may indicate that there
is insufficient difference between the maximum and minimum for the software to detect a pulse, or there
may be an insufficient number of points in the visible top or base of a pulse, such as when closely
examining a step response.

Underflow Condition: The bottom most (negative) sample point of the waveform falls below the ADC
range. Probably, the bottom of the pulses appear to be cut off.

Probably, the top of the pulses appear to be cut off.

Simultaneous Underflow and Overflow Condition: Both conditions are present at once.

Overflow Condition: The top most (positive) sample point of the waveform is above the ADC range.
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Parameter Math

In addition to measuring waveforms, you can set up a parameter that performs mathematical operations on the
results of other parameters. Parameter math differs from math functions in that the input and the output are still
numerical values that display in the Measure table. Math functions, on the other hand, input and output waveform
traces that appear on the grid.

The setup for parameter math is much like that for other parameters. Some parameters can be qualified on the
Accept subdialog using value ranges or gating waveforms, as can regular waveform measurements. If you have the
Advanced Customization (XDEV) option, there is functionality for applying custom scripts to calculate the results.

Exclusions
The following are not supported by Parameter Math:

» Multiplication and division of parameters that return logarithmic values

» Source parameters that are the result of other parameter math operations

Setting Up Parameter Math
1. From the menu bar, choose Measure > Measure Setup....
2. Choose Measure Mode My Measure and open a parameter setup (Pn) dialog.
3. Touch the Math on Parameters button.
4. Touch Math Operator and choose an operation from the Select Measurement menu.
5. Touch the Source fields and select the parameters that are the inputs to the measurement.

6. Check Onto enable the new output parameter and add it to the measurement readout.

Using P Script (Custom Parameter Math)

On instruments installed with the Advanced Customization option (XDEV), you can write your own VBScript or
JavaScript to apply a mathematical operation to one or two input parameters. Choose the Math Operator P Script.
Scripting can be done directly on the instrument in the Script Editor window, or you can import an existing script.

Note: Param Script is a VBScript or JavaScript that performs a measurement on one or two waveforms to
output a parameter. P Script, which is Parameter Math, is a VBScript or JavaScript that inputs one or two
parameter values and performs a math operation on them to output another parameter.

B Math Operafor
| P Script

Summa ry
pscript(P2,P3)

1. Choose Measure > Measure Setup from the menu bar.

2. Touch the Pn tab of the output parameter to display the parameter setup dialog.
3. Touch the Math on Parameters button.

4. Touch Math Operator and choose P Script.

5. Enter the Source input parameter(s).
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6. On the Script Math subdialog, touch Script Language and choose either VBScript or JScript.

7. Touch the Edit Code button to open the Script Editor window.

CutResult.Value = InResultl.Value * InResult2.Value
CutResult.VerticallUnits = "HZI"

Function

foault Status : OK Impcrr_t Exp_crrt
Code from File to File

Cancel Apply

8. Enter your code in the window, or Import from File an existing script. Click Apply and OK to finish.

Scripts created in this window can be exported to a new file for future use.
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Using Web Editor

Whereas with Parameter Math you can apply a single math operation to measurement parameters, the Web Editor
enables you to create processes that chain many operations on multiple inputs, including custom math and
measurements (with the XDEV option), and yield multiple outputs. These processes are integral to the operation of
the instrument; there is no need to export data to other programs.

Processes are "programmed" in the X-Stream application simply by arranging a series of blocks representing
different math functions or measurements and connecting them to form a flow chart—a "processing web." The
terminal parameters and functions represent the final outputs of this process.

Create Processing Web

1. From the menu bar, choose Measure > Measure Setup.
2. Onthe Measure dialog, choose Measure Mode My Measure.

3. Open the Pn dialog and select Advanced Web Edit.

@ close

web edit
or P1 Help

el

Histogram

4. Touch the Show Processing Web button. You will see a "peg board" display with potential input sources
aligned along the left, and a terminal marked with the parameter number to the far right.

Web Editor Math M Source Filter

Add

SEL to the

+ Meas. Add new measurement to
the web

Add new parameter math to

SR the web

5. Onthe Source Filter subdialog, deselect any types (e.g., zooms) that you do not want to use in the process.
This simplifes the display and reduces the need to scroll.
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6. Onthe Wed Editor dialog, choose the type of process to add to the flow. You can Add Math, Add Measure, or
Add Param Math.

7. From the pop-up, choose the operation or measurement that will occur at that node. A new block appears on
the display. Drag the block to a location in the flow.

Tip: Touch the location to place a green plus sign before adding the node. Then, the new block will be
created at this spot. Otherwise, blocks may cover one another until moved.

8. The process block will have a input "pin" on the left. If a waveform is required, the pin is blue; if a number is
required, the pin is purple. Touch and drag a matching colored pin from the sources on the left of the screen
to the block. Choose as many sources as there are input pins on the block.

Tip: You may need to scroll to see all the available sources. For convenience, the Math and Measure
dialogs behind the Web Editor dialog summarize what is currently configured for those sources.

When you drop the pin, a line is drawn from the source to the process. If a source is incompatible with a
process, you will not be able to pin it.

Web Editor Math Measure se @ cLose

Add Processing Nodes
mber of points in the output

+Math tot o Previewed nodes appear only in L T R S D

the Web Editor.

e ement to
+ Meas. th o Sparsing factor

+ PMath d new parameter math to

the ing web

9. If the process requires additional configuration, a subdialog appears next to the Web Editor dialog. Use it to
enter the values to apply to that processing node.

10. Continue to add processes as needed, pinning the output of each block to the input of the next block in the
flow. The final process should be the same type as the terminal (in this example, a measurement).

Tip: The color of the input/output arrows indicates which connections are compatible. The flow does
not need to be strictly sequential, as many processes can accept inputs that have undergone other
processes. The only requirement is that the outputs are pinned to acceptable inputs.

11. Drag the output pin from the final process block to the input pin on the terminal.
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Preview Outputs

You can add preview "windows" to see the output of a process at any stage in the flow. These previews apply only to
the Web Editor.

Select the output pin of the processing block you wish to preview. It will turn bright green. Then, on the Web Editor
dialog choose Add Preview.

Delete Process/Connection

To delete any process from the web, select the block then touch Delete. All the connections to/from it are
automatically deleted.

To remove a connection between process blocks, touch the line. A scissor icon appears above it. Confirm whether or
not to "cut" the connection.

Add Other Terminals to Processing Web

Other measurements or math functions can share the same processing web. For example, you may wish to create a
math function of the waveform that would result from a sub-processing node, while the final output of the full
process is a measurement parameter.

To add a terminal:
1. Open the Math or Measure dialog behind the Web Editor dialog.

2. Touch the Web Edit icon following the location (Pn or Fn). The summary changes to Web Edit, and a new
terminal block appears on the Web Editor peg board.

3. Connect the output pin of the desired process to the input pin of the terminal. You can select outputs that are
already pinned to other blocks.

Exit Web Editor

When your processing web is complete, close the Web Editor dialog or choose Scope Display from the Display
menu. The screen will resume the regular oscilloscope display.
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Using Histograms

Histograms display the statistical distribution of parameter values using bars of varying heights to represent
measurement frequency. The Histogram math function plots the number of parameter measurements that fall
within a small range, known as a bin, as a function of the parameter value. Each bin is represented by a bar on the
chart. The histogram can use from 20 to 5000 bins, each representing a consecutive sub-range of measured values,
and it can hold up to two billion measured values.

The Phistogram function creates a histogram of parameter values falling within a vertical or horizontal "slice" of a
persistence map (the trace created when Persistence display is turned on during acquisition).

The Histogram function descriptor box shows: the number of values represented by each
EONESRAY  vertical grid division of the histogram bars (#/div), the bin width represented by each bar of the

SEEIGTY histogram (vertical or horizontal units/div), and the total number of values computed in the
WPTERSE  histogram (#).

Thumbnail versions of parameter histograms are called Histicons. They are available as a checkbox option on the
Measure dialog. Histicons appear on the Measure table, rather than as a new math trace, although they can be
converted to a regular histogram function simply by touching them.

Uses of Histograms

Histograms show the distribution and probability density of waveform parameter values over multiple acquisitions.
They are especially useful for visualizing and quantifying random processes, such as jitter. Comparing the total
populations of each bin of the histogram can help quantify rarely occurring events that might otherwise be
overlooked, one advantage of the statistical study of measured data. Example applications of histograms include:

e Characterizing DDR read/write timing limits

e Examing systemic and random variations that produce jitter and time interval error

» Measuring rise time, setup / hold time, and propagation delay of electronic devices

e Detecting and diagnosing circuit problems, such as crossover distortion

The shape of the histogram yields immediate information about the parameter being measured:

Gaussian/Unimodal histograms have one peak near the center of the distribution with roughly equilateral roll off on
each side. The Gaussian distribution is a good indication that a random process is shaping variations in the
measurement, such as the effect of random jitter on a pulse measurement.

Bimodal histograms have two, distinct peaks in the distribution at the outer edges, indicative of steady-state high
and low values.

Uniform/Symmetric histograms look rectangular, indicating a wide distribution of values.

Skewed histograms show a peak at either the negative or positive edge of the measurement range, with a steady roll
off toward the other side.

Because the shape of histogram distributions is particularly interesting, additional histogram measurements are
available for analyzing these distributions. They are generally centered on one of several peak value bins. You will
find the histogram measurements in the Statistics sub-menu of the Measure Selector.
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Histogram Calculation

Histograms are calculated on the portion of the waveform within the acquisition window and the measurement
gates, just as are the parameters. Likewise, histogram measurements are limited to the bars of the histogram that
are visible on the grid and that fall within the measurement gates.

In Sequence sampling mode, one acquisition for each segment occurs prior to parameter calculations, and a sweep
is equivalent to acquisitions for all segments (for non-segmented waveforms, an acquisition is identical to a sweep).
If a single segment of a sequence-mode acquisition is selected for viewing, histograms will be recalculated for only
the measurements on that segment.

Measurements calculated once per acquisition (Amplitude, Area, Base, Cycles, Delay, Delta Delay, Duration, First,
Last, Maximum, Mean, Median, Minimum, Nb Phase, Nb Power, Overshoot+, Overshoot-, Peak-Peak, Phase, Points,
RMS, Std Dev,, etc.) will not produce characteristic histogram distributions, unless you allow sweeps to accumulate.

Plotting Histograms

1. Open the parameter setup dialog (Pn) for the parameter you wish to histogram.
0 Tip: A quick way to do this is to touch the Measure table Pn cell.

2. Touch the Histogram action button at the bottom of the Pn dialog and choose the function (Fn) in which to
draw the histogram.

3. Touch the new hist descriptor box to display the Fn dialog, then open the Histogram subdialog and define the
histogram Buffer and Scaling.

Histogram

Scaling

#\

1000 50.0 0mv

0 Find Center
1000 and Width
0
Clear
Sweeps

Pressing Clear Sweeps at any time resets the measurement counter and restarts the histogram.

Histogram Buffer
Enter the maximum #Values in one bin of the histogram. This determines the total number of measurements that

are represented by a bar at full height. Once this number is reached, the histogram will be rescaled according to the
Vertical Scale method selected, as it continues to accumulate data.

Histograms are dynamically computed using the last N measurements in the parameter buffer, up to two billion. If
#Values is modified, the histogram is redrawn using the last N events required.

If the parameter source is a memory, storing new data to memory effectively acts as an acquisition trigger/sweep
and updates the parameter buffer and the histogram.
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Histogram Scaling

Bins

First, enter the total #Bins that comprise the histogram. This determines how many bars appear in the histogram.
Histogram peak bin values are useful because they indicate the dominant values of a parameter, but using a too high
number of bins can yield a spiky histogram, making meaningful peaks hard to distinguish. An optimal bin number is
one where the change in bin value is insignificant, and the histogram distribution does not have a jagged
appearance.

 For Vertical (amplitude) parameters, the default value of 100 is a good number .
» For Horizontal (timing) parameters, it is safe to use up to the maximum number of bins.

The instrument analyzes histogram data to identify peaks from background noise and histogram definition artifacts
such as small gaps, which are due to very narrow bins.

Histogram bins represent a sub-range of parameter measurements, and measurements within a bin may have a
value anywhere within that sub-range. However, measurements of the histogram itself assume that all
measurements in a bin have a single value. The instrument uses the center value of each bin in all its histogram
measurements. The greater the number of bins used to subdivide a histogram'’s range, the less the potential
deviation between actual center values and the values used in histogram measurements. However, more bins may
require a greater number of sweeps to populate the bins sufficiently to yield a characteristic histogram distribution.

Center and Width
How parameter values are distributed into the bins is determined by the Center and Width values.

The Center is the center value of the measurement range represented by the histogram. This will generally be a value
near the expected peak value, or a center bar in a symmetric histogram. Examine the mean value of the parameter
you wish to histogram to determine a good value to place at center.

The Width is the measurement interval represented by each bin of the histogram, which is counted in vertical
units/div for Vertical parameters, or horizontal units/div for Horizontal parameters. If Width is 500 ns, a Horizontal
measurement between 0 (center) and 500 ns falls into the first positive bin, and one between 0 and -500 ns falls into
the first negative bin, and so forth. The more bins that are in the histogram, the smaller the Width should be to
ensure that values will distribute across the histogram, showing a meaningful deviation from center.

The instrument's range finding function, Find Center and Width, can be used to calculate an optimal range and
redraw the histogram using it. The instrument gives a running count of where values fall relative to the range on the
Histogram function subdialog, and if any fall above or below it, the range finder can recalculate the histogram using
those values while still in the buffer. First check Enable Auto Find to use this feature.

Vertical Scale

Histograms build vertically as data accumulates over multiple acquisitions. It is possible that, after a sufficient
number of sweeps, the peak bars of a histogram will reach the grid maximum, causing an overflow condition, and
the histogram must be rescaled to accurately reflect the distribution. Choose a Vertical Scale method by which to
handle situations where the histogram buffer is full:

* Linear rescales the number of values represented by each vertical division as the histogram reaches the top of
the grid. The histogram will appear to shrink then grow again as more data is accumulated, until another
rescaling of the values/div is required.

» LinConstMax keeps the histogram at near full scale when it reaches the top of the grid, but changes the
numbers on the vertical axis as more data is accumulated.
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Using Trends

The Trend math function plots a waveform composed of parameter measurements arranged in the order the
measurements were made. The vertical units are the source parameter values, and the horizontal unit is the
measurement number. The Trend contains a single value for each unique measurement, and therefore may not be
time synchronous with the source waveform, where the same measured value may occur successively over time.

Uses of Trends

Trends are especially useful for visualizing the history of a parameter over an extended period of time or over
multiple acquisitions. Think of Trend as a strip chart recorder for your instrument. Example applications of Trend
include:

Data logging multiple circuit parameters

Power line monitoring

Measuring output regulation and ripple

Characterizing the dynamic tracking response of PLL-based circuits

Locating clock jitter anomalies

Plotting Trends
Although a Trend plots parameter values, it is created as a Math function on the Function (Fn) dialogs.

1.

Open the parameter setup (Pn) dialog for the measurement you wish to trend. A quick way to do this is to
touch the Measure table cell.

Touch the Trend button at the bottom of the Pn dialog, then choose the function (Fn) in which to draw the
plot. The Trend opens in a new grid along with its function descriptor box.

Touch the new Trend descriptor box to display the Fn dialog, then open the Trend subdialog.

Zoom Trend

Forms a list of measurement
values

ov

5.00 mv

Clear
Sweeps

4. Choose a computation Mode of All (measurements per acquisition) or Average (one measurement per

acquisition).

5. Enter the number of measured Values to Trend.
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Using Tracks

A Track is a waveform composed of parameter measurements that are time synchronous with the source
waveform. The vertical units are those of the source parameter and the horizontal units are seconds. Due to the time
synchronization, the number of points in the Track function is identical to the number of samples in the source
waveform, and a Track is limited to the samples in a single acquisition. The Track may contain many redundant

values.

Uses of Tracks

In general, Track is the tool to use if you want to capture a continuous stream of data spaced closely together. It is
also useful in applications that require time synchronization, or for locating anomalous parameter values in a long
acquisition. Example applications of Track include:

» Modulation analysis of PWM signals

e Measuring phase error in PLLs

» Measuring settling time of waveforms with decaying amplitudes

» Radar measurements to characterize PRI stagger during walkoff

Plotting Tracks
Although a Track plots parameter values, it is created as a Math function and controlled on the Function (Fn) dialogs.

1.

Open the parameter setup (Pn) dialog for the measurement you wish to track. A quick way to do this is to
touch the Measure table cell.

Touch the Track toolbar button at the bottom of the Pn dialog and choose the function (Fn) in which to draw
the plot.

Touch the new Track descriptor box to display the Fn dialog, then open the Track subdialog.

Zoom

Vertical Scale
"Track™ function, giving a [ cl
f eguivalent Interpolate

orm, but of a v
urement on that A
waveform.

Find

4. Onthe Track subdialog, choose a method to Connect the points in the track into a waveform: Interpolate

points between samples, or Extend the line directly point to point.
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Track vs. Trend
The table below summarizes the differences between Track and Trend.

Track Trend
(Parameter value vs. time) (Parameter value vs. event)
Cumulative? No, resets after every acquisition Cumulative over unlimited number of
acquisitions, up to two billion events
Time correlates to other data? | Yes No
Monitors Frequency domain? | Yes No, points are not evenly spaced in time and
therefore cannot be used for an FFT
Monitors parameters over No, resets after every acquisition Yes
multiple acquisitions?
Preserves all measurement Yes, although maximum time period that can | No, data can be missed during time
data? be captured is limited by acquisition memory | oscilloscope takes to re-arm between
and sampling rate acquisitions

EMC Pulse Parameter Software Package

The EMC option enhances the oscilloscope's Measure functionality with features designed to ignore undershoot,
overshoot, or tail perturbations while measuring rise time, fall time, or width characteristics according to specific
EMC/ESD standards.

At Level Parameters

For the parameters Rise@Level, Fall@Level, Width@Level, Time@Level, and dTime@level, in addition to setting the
crossing threshold level using the absolute voltage or percentage of amplitude based on the computed Top and
Base lines, you may set the level using:

* actual Peak to Peak
e QV-Max
e OV-Min

Once the option is activated, the new selections are added to the Level pop-up menu. Otherwise, parameters are
configured exactly the same as before.

EMC Parameters
Two parameters designed for EMC measurements are added to the IEC-EMC submenu of the Measure Selector:

» EMCIvIPulse—EMC Level After Pulse enables you to measure the signal level following the specified pulse
transition, omitting earlier portions of the signal.

» EMCt2Val—EMC Time to Half Value computes time between interpolated time at 0% on rising edge and
crossing time at middle level on falling edge. The interpolated time at 0% is obtained by linear extrapolation
using the low crossing and high crossing thresholds.
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Math

Math function traces (Fn) display the result of applying a mathematical operation to a source trace. The output of a
math function is always another trace, whereas the output of a measurement parameter is a tabular readout of the
measurement.

Math can be applied to any channel (Cn), zoom (Zn), or memory (Mn) trace. It can even be applied to another math
trace, allowing you to chain operations (for example, trace F1 can show the average of C1, while trace F2 provides
the integral of F1).

On instruments equipped with CustomDSO (XDEV), custom scripts may be used to define a math function. Several
scripting "languages" are supported, depending on the application. You can find these options in the Custom
submenu of the Math Selector. Scripts may be imported or written in the instrument's Script Editor window and
saved for future use. See Using P Script for a description of the process.

In addition to the extensive math capabilities that are standard with every instrument, enhanced math analysis tools
customized for various industries and applications are offered through optional software packages. To learn about
math tools available in each optional package, see the product datasheets at teledynelecroy.com.

If you have installed software options, the new capabilities are usually accessed through the Analysis menu, rather
than the Math menu, although special math functions will be available when using the standard Math dialogs.

Math Function Set Up

Use the Function dialog to set up math function traces. Math functions take as input one or more channel, zoom,
memory or math traces and output a new math trace (Fn). Any additional settings required for the operator will
appear on a subdialog at the right of the screen.

Single functions perform one operation on one or two input sources.

Dual functions chain two operations to arrive at a single result. This saves you the effort of having to chain two
separate math functions. As with single functions, the number of sources required will vary based on the operation.
You may need only one source for Operator1, but two for Operator?2 (the result of the first operation counts as one
source).

Setting Up New Functions
E3

Operatort
il Fer

Summary
FFT(P4)
Actions for trace F2

— ¥ 4 % Hel
Measure Label Next Simpl

1. From the menu bar choose Math > Math Setup, then open one of the Fn tabs.
0 Tip: You can select Fn Setup right from the Math menu.

2. Choose a single f(x) or dual g(f(x) operator function.

You can also choose Web Edit, in which case this function is added as a terminal to the processing web. See
the instructions for Using Wed Edit to set up the function.

3. InOperator1, choose the math operation to perform.
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Note: On instruments with the Advanced Customization (XDEV) option, the Operator can be a
custom script written in one of several scripting "languages." Choose from the Custom submenu and
import or write the script in the Script Editor. See Using PScript for a description of the process.

4. The choice of operator drives the number of Source fields you will see displayed. Make a selection in each
field, or drag the source channel descriptor box to the field.

A Summary of the function you are building appears on the dialog. Refer to this to be sure your sources are in
the proper order to yield the function you want (e.g., C1-C2 vs. C2-C1).

5. If the operator you've selected has any other configurable settings, you'll see a subdialog of the same name
as the operator. Touch the tab to open the dialog and make any further settings. These are explained on the
dialog.

6. If you're creating a dual function, repeat the procedure for the second operator.
7. Check Trace On to display the new math trace.
Following acquisition, you should see a new math waveform appear on the oscilloscope display. Drag-and-drop the

Fn descriptor box to move it to the desired grid.

Note: If there is a processing error (e.g., overflow) when calculating a math function, a small letter "i" inside a
bubble will appear on the Fn descriptor box to indicate there is more information regarding the waveform
status. See Finding Waveform Status for instructions on finding the error.

Graphing
The Graph button on the Function (Fn) dialogs allows you to choose a parameter to plot as a histogram, track, or
trend.

0 Tip: The plots are the same as those created using the toolbar on the Parameter (Pn) dialog.

As with other math functions, configurable settings will appear on subdialogs after the plot is selected.

Adjusting Memory or Math Traces

Unlike channel traces, the scale of memory (Mn) or math function (Fn) traces can be adjusted directly without having
to create a separate zoom trace. The same set of zoom factor controls used for zoom traces appear on the Zoom
subdialog, but in this context they only rescale the active math or memory trace rather than create a new zoom. This
applies to any trace that is created as a math function (Fn) trace, including traces generated through analysis
options and graphs.

You can, if you wish, create a separate zoom trace from a memory or function trace the same as you would normally
create a zoom (draw a selection box, etc.). In this case, you choose one of the zoom locations (Zn) in which to draw
the trace, but the source trace remains at the original scale.
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Math Dialog

Once a math function has been created and saved on the Function (Fn) dialog, use the main Math dialog to quickly
enable/disable it. You can also use this dialog to quickly turn on/off zoom traces.

FFT(C1) 5 On  zoom(C1)

zoom{C2)

zoom{C4) On  zoom(C4)

To open the Math dialogs, from the menu bar choose Math > Math Setup. Select the On checkbox next to each
function you wish to display.

To change the function, touch the Fn button.
To erase all functions from their locations, touch Reset All.

To restart the counter on cumulative functions (like Average), touch Clear Sweeps.

List of Standard Math Operators

Note: The installation of software options on the oscilloscope may add math operators to this list.

Standard Operators
Absolute - Calculates distance away from zero for every point in the waveform. For values greater than zero, this is
the same as the value. For values less than zero, the magnitude without regard to its sign is used.

Average - Calculates either a summed or continuous average of a selected number of sweeps. See Average
Function. The maximum number of sweeps is determined by the oscilloscope model and memory.

Copy - Copies waveform in its unprocessed state to the first available memory location.

Correlation - Calculates a measure of similarity of two waveforms, or a waveform against itself, as a function of a
time-lag applied to one of them.

Derivative - Calculates the derivative of adjacent samples using the formula:
(next sample value — current sample value) / (horizontal sample interval)

Deskew - Shifts trace in time the amount of the deskew factor.

Difference - For every point in the waveform, subtracts the value of Source2 from the value of Sourcel. Sourcel and
Source? must have the same horizontal and vertical units and scale.

Envelope - Calculates highest and lowest vertical values of a waveform at each horizontal value for a specified
number of sweeps.

ERes - Applies a noise reduction and smoothing filter by adding a specified number of bits. See Enhanced
Resolution.

Exp - Calculates the antilog to the base e of the source; that is, e raised to the power equal to the source.

Exp10 - Same as Exp, using base 10.
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FFT - Computes a frequency spectrum with optional Rectangular, Von Hann, Flat Top, Hamming, Blackman-Harris,
or Gaussian window. Allows FFT Averaging through use of a second math operator. See FFT.

Floor - Calculates the lowest vertical values of a waveform at each horizontal value for a specified number of
sweeps.

Histogram - Plots the number of data points that fall into statistically significant intervals or bins. Bar height relates
to the frequency at which data points fall into each interval/bin.

Integral - Calculates the linearly rescaled integral (with multiplier and adder) of a waveform input starting from the
left edge of the screen using the formula: (current sample value + next sample value) * (horizontal sample interval).
Each calculated area is summed with the previous sum of areas. The multiplier and adder are applied before the
integration function.

Interpolate - Inserts points between sampled points (upsamples) according to one of three algorithms: Linear
(straight line), Sinx/x (curved), and Cubic (spine). The Interpolation Factor determines the number of points in the
upsample.

Invert - For every point in the waveform, the inverse of that point is calculated.
Ln - Peforms a natural log of a waveform. Values less than or equal to zero are set to underflow.
Log10 - Performs a log base 10 of a waveform. Values less than or equal to zero are set to underflow.

Phistogram - Creates a histogram based on the displayed pixels of a persistence map falling within a user-defined
vertical and/or horizontal box (slice). The source trace must have Persistence turned "on."

Product - For every point in the waveform, the value of SourceT is multiplied by the value of Source 2. Sourcel and
Source? must have the same horizontal units and scale.

Ptrace mean - Plots the mean value of each sample point in a persistence map. The source trace must have
Persistence turned "on."

Ptrace range - Generates a waveform with a width derived from the population range of a persistence map. The
source trace must have Persistence turned "on."

Ptrace sigma - Generates a waveform with a width derived from the sigma (sum) of a persistence map. The source
trace must have Persistence turned "on."

Ratio - For every point in the waveform, divides the value of Source1 by the value of Source2. Source and Source?
must have the same horizontal units and scale.

Reciprocal - For every point in the waveform, calculates the inverse using the formula: 1/ (sample value).

Rescale - For every point in the waveform, multiplies the sample value by the specified Multiplier, then adds the
specified Additive Constant value. See Rescale Function.

Roof - Calculates the highest vertical value at each sample point for a specified number of sweeps.

Segment - Selects one segment [#] from a segmented waveform and copies it into the function, enabling it to be
rescaled independent of the source trace.

Sinx/x - Performs 10-to-1 interpolation using a Sin(x)/x filter.

Sparse - “Thins" (decimates) an incoming acquisition by dropping sample points at regular intervals. Sparsing Factor
specifies the Nth sample point in sequence to retain (e.g., factor of 4 drops 3 points and retains the 4th). Sparsing
Offset specifies the point at which to begin the sparsing count (e.g., offset of 3 begins count on the 3rd sample
point).
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Square - For every point in the waveform, calculates the square of the sample value.
Square Root - For every point in the waveform, calculates the square root of the sample value.

Sum - For every point in the waveform, adds the value of Source1 to the value of Source 2. Source1 and Source?
must have the same horizontal and vertical units and scale.

Track - Generates a waveform composed of measurement parameter values that are time synchronous with the
source waveform. The vertical units are those of the source parameter value; the horizontal units are seconds.
Values are posted at the sampling rate.

Trend - Produces a waveform composed of a series of measurement parameter values in the order the
measurements were taken. The vertical units are those of the source parameter; the horizontal unit is measurement
number. The trend contains a single value for each unigue measurement.

Zoom - Produces a magnified trace of a selected portion of the input waveform. See Zooming Traces.

Custom Math Operators

These "operators” enable you to insert a custom script into the oscilloscope process and view the resulting
waveform in real time.

Excel math - Custom math performed in Excel. The operator will transfer one or two waveforms (as a series of time-
value pairs) into an Excel spreadsheet and display the resulting waveform.

Fast Wave Port - Provides memory mapped C++ file access for custom math calculations.
Math script - Visual Basic or Java script that produces a waveform from one or two input waveforms.
Mathcad math - Produces a waveform using a custom Mathcad function.

MATLAB math - Produces a waveform using a custom MATLAB function. You may write a MATLAB script on the
oscilloscope, or call a pre-existing MATLAB function into a script. MATLAB can run locally on the oscilloscope, or
remotely on a host that is accessible to the oscilloscope. See the MAUI Oscilloscopes Remote Control and
Automation Manual for instructions on connecting to MATLAB remotely.

118


http://teledynelecroy.com/doc/docview.aspx?id=9905
http://teledynelecroy.com/doc/docview.aspx?id=9905

Math and Measure

Average Function

The summed or continuous average of all data samples from multiple acquisitions can be displayed as a new
waveform trace using the Average function.

Setting Up an Average Function

1. Follow the usual steps to set up a math fuction, selecting Average from the Basic Math submenu.

2. Onthe Average subdialog, choose Summed or Continuous.

3. Touch Sweeps and provide the number of sweeps to average.

Summed Averaging

Summed Averaging is the repeated addition, with equal weight, of successive source waveform records. If a stable
trigger is available, the resulting average has a random noise component lower than that of a single-shot record.
Whenever the maximum number of sweeps is reached, the averaging process stops. In Summed averaging, you
specify the number of acquisitions to be averaged. The averaged data is updated at regular intervals.

An even larger number of records can be accumulated simply by changing the number in the dialog. However, the
other parameters must be left unchanged or a new averaging calculation will be started. You can pause averaging by
changing the trigger mode to Stop. The instrument resumes averaging when you resume the trigger.

You can reset the accumulated average by pushing the Clear Sweeps button or by changing an acquisition
parameter such as input gain, offset, coupling, trigger condition, timebase, or bandwidth limit. The number of current
averaged waveforms of the function, or its zoom, is shown in the acquisition status dialog. When summed averaging
is performed, the display is refreshed at a reduced rate to increase the averaging speed (points/events per second).

Continuous Averaging

Continuous Averaging, the default setting, is the repeated addition, with unequal weight, of successive source
waveforms. It is particularly useful for reducing noise on signals that drift very slowly in time or amplitude. The most
recently acquired waveform has more weight than all the previously acquired ones: the continuous average is
dominated by the statistical fluctuations of the most recently acquired waveform. The weight of ‘old' waveforms
tends to zero (following an exponential rule) as the number of new waveforms increases.

You determine the importance of new data vs. old data by assigning a weighting factor. The formula for continuous
averaging is: new average = (new data + weight * old average)/(weight + 1)

By setting a Sweeps value, you establish a fixed weight that is assigned to the old average once the number of
sweeps is reached. For example, for a sweeps (weight) value of 4:

Sweep New Average =

1 (no old average yet) new data +0 * old average)/(0 + 1) = new data only

new data + 1*old average)/(1 + 1) = 1/2 new data +1/2 old average

new data + 2 * old average)/(2 + 1) = 1/3 new data + 2/3 old average
new data + 3 * old average)/(3 + 1) = 1/4 new data + 3/4 old average
new data + 4 * old average)/(4 + 1) = 1/5 new data + 4/5 old average
new data + 4 * old average)/(4 + 1) = 1/5 new data + 4/5 old average, Etc.

o WIN
~[= ===

Note: The number of sweeps averaged is displayed at the bottom of the trace descriptor box.
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Copy Function

The Copy math function saves a copy of your present waveform in its unprocessed state to the first available
memory location. The memory enables faster throughput, in some cases, by preserving the original data, while math
and measure processing continues on the original waveform. This benefit of faster throughput, however, comes at
the expense of memory usage.

Follow the ususal steps to set up a math function, selecting Copy from the Misc submenu.

On the Wform Copy subdialog, optionally Reset Count or Change BatchSize.

ERes Function

ERes (Enhanced Resolution) filtering increases vertical resolution, allowing you to distinguish closely spaced voltage
levels. The instrument's ERes function is similar to smoothing the signal with a simple, moving-average filter, but is
more efficient concerning bandwidth and pass-band filtering. Use ERes:

» On single acquisitions or where the data is slowly repetitive (and you cannot use averaging).
» To reduce noise on noticeably noisy signals when you do not need to perform noise measurements.

» As alow-pass filter. The ERes filter rejects high-frequency components from the signal. The higher the bit
enhancement, the lower the resulting bandwidth.

» When performing high-precision voltage measurements (e.g., zooming with high vertical gain).

Setting Up an ERes Function

1. Follow the usual steps to set up a math function, selecting Eres from the Filter submenu.

2. Touch the Trace On checkbox.

3. Onthe Eres subdialog, select the number of bits of improvement from the pop-up menu.

Tip: To quickly set up ERes as a pre-processing function, access the channel setup dialog (Cn) and select a
Noise Filter (ERes) bit size.

How ERes Is Applied

The instrument's ERes feature improves vertical resolution by a fixed amount for each filter. This real increase in
resolution occurs whether or not the signal is noisy, or whether it is single-shot or repetitive. The signal-to-noise ratio
(SNR) improvement depends on the form of the noise in the original signal. ERes filtering decreases the bandwidth
of the signal, filtering out some of the noise.

The instrument's constant phase finite impulse response (FIR) filters provide fast computation, excellent step
response in 0.5 bit steps, and minimum bandwidth reduction for resolution improvements of between 0.5 and 3 bits.
Each step corresponds to a bandwidth reduction factor of two, allowing easy control of the bandwidth resolution
trade-off.

Resolution Increase -3 dB Bandwidth (x Nyquist) Filter Length (Samples)
0.5 0.5 2
1.0 0.241 5
1.5 0.121 10
2.0 0.058 24
2.5 0.029 51
3.0 0.016 117
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With low-pass filters, the actual SNR increase obtained in any particular situation depends on the power spectral
density of the noise on the signal.

The improvement in SNR corresponds to the improvement in resolution if the noise in the signal is white (evenly
distributed across the frequency spectrum). If the noise power is biased towards high frequencies, the SNR
improvement will be better than the resolution improvement.

The opposite may be true if the noise is mostly at lower frequencies. SNR improvement due to the removal of
coherent noise signals—feed-through of clock signals, for example—is determined by the fall of the dominant
frequency components of the signal in the passband. This is easily ascertained using spectral analysis. The filters
have a precisely constant zero-phase response. This has two benefits. First, the filters do not distort the relative
position of different events in the waveform, even if the events' frequency content is different. Second, because the
waveforms are stored, the delay normally associated with filtering (between the input and output waveforms) can be
exactly compensated during the computation of the filtered waveform.

The filters have been given exact unity gain at low frequency. ERes should therefore not cause overflow if the source
data is not overflowed. If part of the source trace were to overflow, filtering would be allowed, but the results in the
vicinity of the overflowed data—the filter impulse response length—would be incorrect. This is because in some
circumstances an overflow may be a spike of only one or two samples, and the energy in this spike may not be
enough to significantly affect the results. It would then be undesirable to disallow the whole trace.

Note: While ERes improves the resolution of a trace, it cannot improve the accuracy or linearity of the
original quantization. The pass-band causes signal attenuation for signals near the cut-off frequency. The
highest frequencies passed may be slightly attenuated. Perform the filtering on finite record lengths. Data is
lost at the start and end of the waveform and the trace ends up slightly shorter after filtering. The number of
samples lost is exactly equal to the length of the impulse response of the filter used: between 2 and 117
samples. Normally this loss (just 0.2 % of a 50,000 point trace) is not noticed. However, you might filter a
record so short that no data is output. In that case, however, the instrument would not allow you to use the
ERes feature.
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Fast Wave Port Function

Fast Wave Port is an Advanced Customization (XDEV) function of Teledyne LeCroy X-Stream oscilloscopes that
enables you to insert a custom algorithm written in the C/C++ language into the oscilloscope's processing stream as
a Math function (Fn). It helps to maximize data throughput from the acquisition system to your custom algorithm for
purposes of debugging or external processing. Custom algorithms can be written right on the oscilloscope using the
Script Editor.

Because two Windows system processes may share a single region of memory, Fast Wave Port enables high-speed
data transfer between the acquisition system and the custom algorithm, which runs in a separate process from the
oscilloscope application. A major benefit of Fast Wave Port is that your algorithm may be implemented and, more
importantly, debugged independently of the main application.

Transferring the results of your algorithm back into the MAUI processing stream is optional. If performance is the
primary goal, and further processing or display of the results within the MAUI application is not required, this step
may be skipped.

Fast Wave Port was designed for use with the C/C++ programming language. However, it is theoretically possible for
the processing to be implemented in any language supporting Windows named events (Mutex) that can open a
named memory-mapped file. We do not guarantee the behavior of the function using anything but C/C++.

The size of the memory window is fixed at 80 MB, equating to 40 MS.

Setting Up Fast Wave Port
To use Fast Wave Port, follow the usual steps to set up a math function, selecting Fast Wave Port as the Operator,
then make the appropriate settings on the Fast Wave Port subdialog.

Zoom Fast Wave Port

Summary

f(x) g{f(x)) fastwaveport(C1)

Actions for trace F1

-t Add / Edit

Measure Store Name

The Port Name is critical, indicating the base name of the memory window and the global objects within the
Windows 0/S. Only change the default value if using multiple Fast Wave Port functions in parallel.

Note: The base name used in the client application must match that configured for the MAUI Automation
CVAR app.Math.Fn.Operator1Setup.PortName.
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The full names of the default global objects are as follows:

Object Full Name

Memory Mapped File FastWavePort1File
Data Available Event FastWavePort1MutexDataAvailable
Processing Complete Event | FastWavePort1MutexProcessingComplete

The Timeout control specifies the amount of time the DSO waits for the custom processing function to complete.
This prevents the DSO from waiting indefinitely for a custom processing function which may never arrive. Be careful
to set this control to a reasonable value, meaning a time longer by a reasonable margin than the custom processing
is ever expected to take.

Example Fast Wave Port Application
This simple C++ application may be used as a starting point for a custom algorithm. It demonstrates how to:

 Create handles to the global objects (the memory window and the two events)

» Read data from the memory window when the DSO flags it as available

» Scale the data into units of volts using data in the header stored at the beginning of the memory window.
» Perform a simple processing function (in this case the absolute value)

» Define the physical units of the output of the processing function (in this case Amps)

» Flag the X-Stream application that processing is complete

/1

// FastWavePortClient.cpp :

/!

// Prototype C++ client application for "FastWavePort' Math Processor
//

// Compatibility:

// Microsoft Visual C++ 6.0, 7.1

// MinGW 'gcc' based compiler (free download from www.mingw.org/)

// Compile with: mingw32-c++ -0 fastWavePortClient.exe fastwaveportclient.cpp

//
#include "windows.h"

#include <stdio.h>

//
// FastWavePort header, describes various properties of the waveform passed to the user-processing
// function. Also used to carry the properties of the processed waveform back to the DSO.

//

#define FLAGS_OUTPUT_VALID 0x01
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typedef unsigned _int64 lecTimeStamp;
lecTimeStamp lecTimeStampOneSecond = 1000000000; // 1 ns units in a second
#pragma pack(push, 4) // pack on 4-byte boundaries (Important!)
struct CDescHeader
{
int descVersion; // header version number
int flags; // misc. flags indicating the status of input, and how to treat the output
int headerSize; // size of the header, data starts immediately after the hdr.
int windowSize; // total size of the window (header + data)
int numSamples; // total number of samples in the input waveform
int segmentindex; // index of this segment, usually zero when input waveform is not a sequence
int numSweeps;
int _dummyT; // not used
double verGain; // scale factor that relates integer sample data values to the vertical units of the waveform.
double verOffset; // vertical offset (in vertical units, e.g. Volts) of the waveform
double verResolution; // vertical resolution of the measurement system (also in vertical units)
double horinterval; // scale factor that relates integer sample indices to the horizontal units of the waveform.
double horOffset; // horizontal offset (in horizontal units, e.g. seconds) of the waveform
double horResolution; // horizontal resolution of the measurement system (also in horizontal units)
lecTimeStamp trigTime; // trigger time, units of Tns since 00:00:00 on Jan 1st 2000, 64-bit unsigned integer
char verUnit[48]; // vertical units of the waveform ("V" for example)
char horUnit[48]; // horizontal units of the waveform ('s" for example)
%
#pragma pack(pop) // restore packing

/1

// The buffer size is 80MB (40,000,000 samples, stored as short integers) plus 0x1000 bytes for the header.
const unsigned long HEADER_SIZE = 0x1000

const unsigned long MEM_MAP_FILE_SIZE = 80000000 + HEADER_SIZE; // = 40MSamples, or 80MBytes
int main(int argc, char* argv[])

{
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// names based on 'FastWavePort1' name defined in Processor setup.

char szMapFileName[] = "FastWavePort1File";

char szMutexDataAvailableName[] = "FastWavePort1MutexDataAvailable";

char szMutexProcessingCompleteName(] = "FastWavePort1MutexProcessingComplete”,
// Associate shared memory file handle value.

HANDLE m_hMMFile = CreateFileMapping ((HANDLE)Oxffffffff, NULL, PAGE_READWRITE, 0, MEM_MAP_FILE_
SIZE, szMapFileName);

if(m_hMMFile == 0)
{
printf("Unable to create file mapping\n");

return O;

}

// Map a view of this file for writing.

short *m_IpMMFile = (short *)MapViewOfFile (m_hMMFile, FILE_MAP_ALL_ACCESS, 0, 0, 0);
if(m_lpMMFile == 0)

{

printf("Unable to map view of file\n");

return O;

}

// create/open events used for synchronization

// if the client app. was run before the oscilloscope then these events will be created, if the oscilloscope was run
first then these events

// will just be opened
HANDLE m_hDataAvailable = CreateEvent(NULL, FALSE, FALSE /* initial state */, szMutexDataAvailableName);

HANDLE m_hProcessingComplete = CreateEvent(NULL, FALSE, FALSE /* initial state */,
szMutexProcessingCompleteName);

if(m_hDataAvailable == 0 || m_hProcessingComplete == 0)
{

printf("Unable to open events\n");

return O;

}

// main loop
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while(1)
{
inti=0;

printf("Waiting for new data..\n";

// wait an infinite amount of time for data to be available

DWORD waitSuccess = WaitForSingleObject(m_hDataAvailable, INFINITE);

// print the first few bytes of the input waveform

CDescHeader *descHeader = (CDescHeader *) &m_IpMMFile[0];

short *m_IpWaveform = &m_IpMMFile[descHeader->headerSize / sizeof(short)];
for(i = 0; i < 4; ++)

printf("%f ", (m_lpWaveformli] * descHeader->verGain) + descHeader->verOffset);

// compute the mean of all data values, while computing the abs value of the waveform in-place
double sum = 0.0;

for(i = 0; i < descHeader->numSamples; ++i)

{

sum += (m_lpWaveform[i] * descHeader->verGain) + descHeader->verOffset;
m_IpWaveform[i] = abs(m_lpWaveform(i]);

}

sum /= descHeader->numSamples;

// modify the output units, set to Amps

strcpy(descHeader->verUnit, "A");

// print the mean, numer of samples, trigger time in seconds, and the segment index

printf(" (%f) %d %d %d\n", sum, descHeader->numSamples, (int) (descHeader->trigTime /
lecTimeStampOneSecond), descHeader->segmentindex);

// use to flag that the output is not valid, increasing performance when
// itis not necessary to read data back into the DSO
//descHeader->flags &= ~FLAGS_OUTPUT_VALID;

// flag that processing is complete
SetEvent(m_hProcessingComplete);

}

return O;
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Header Description

int descVersion; // header version number

int flags; // misc. flags indicating the status of input, and how to treat the output

int headerSize; // size of the header, data starts immediately after the hdr.

int windowSize; // total size of the window (header + data)

int numSamples; // total number of samples in the input waveform

int segmentindex; // index of this segment, usually zero when input waveform is not a sequence

int numSweeps,

int _dummy?1; // not used

double verGain; // scale factor that relates integer sample data values to the vertical units of the waveform.
double verOffset; // vertical offset (in vertical units, e.g. Volts) of the waveform

double verResolution; // vertical resolution of the measurement system (also in vertical units)

double horlnterval; // scale factor that relates integer sample indices to the horizontal units of the waveform.
double horOffset; // horizontal offset (in horizontal units, e.g. seconds) of the waveform

double horResolution; // horizontal resolution of the measurement system (also in horizontal units)
lecTimeStamp trigTime; // trigger time, units of Tns since 00:00:00 on Jan 1st 2000, 64-bit unsigned integer
char verUnit[48]; // vertical units of the waveform ("V" for example)

char horUnit[48]; // horizontal units of the waveform ('s" for example)
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Fast MultiWave Port

access oscilloscope data via the shared memory and process it in a separate stream from the oscilloscope
application. If desired, the results of the external process may be returned to the oscilloscope application as multiple
parameter values (Pn) or math function waveforms (Fn).

Fast MultiWave Port supports:
» Up-to-four waveform and two parameter inputs
» Up-to-eight parameter and four waveform outputs
» Batching an entire sequence of waveforms prior to the exchange between applications

* Client control of how much named memory is mapped and for which named memory spaces, as opposed to
the fixed 80 MB limit for Fast Wave Port

» Support for multiple waveform segments and multi-valued parameters at each output pin (when used in the
Web Editor)

Requirements
» Fast Multiwave Port is enabled by the DDA and XDEV options.

» Adevelopment environment (like MSDEV) is required to develop the client application. Any language that will
support a deterministic memory layout may be used. C and C++ are one such choice. For example client
application code, see LAB WM785 - FastMultiWavePort: A new processor for the LeCroy XStream Scopes.

Setting Up Fast MultiWave Port
The client application is "linked" to the oscilloscope application via a custom parameter (Pn) configured with the Fast
MultiWave Port processor.

Note: The Fast MultiWave Port processor is always added as a custom measurement, even if the final
output is a waveform.

Single Parameter
If the client application inputs two or fewer waveforms and returns only one parameter (or none), Fast MultiWave
Port may be invoked from the user-defined ("MyMeasure") measurement setup dialogs.

Su mmary

fmwport(C1) Clear Action
Actions for P1 Help Sweeps

Action Action
i Iy s
Histogram

On the MultiWavePort subdialog, enter the Port Name of the Fast MultiWave Port processor in your client
application, if changed from the default FMWavePort1. The base name must match that configured for the
Automation CVAR app.Measure.Pn.Operator.PortName.

Optionally:
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Enter a Timeout at the end of which to return control to the oscilloscope application if the client has not
indicated processing is complete.

Select Clear Cumulative to Clear Sweeps automatically before each acquisition. This will reset parameter
statistics to only the results of the last acquisition.

Select Reframe Waveforms to check after each acquisition for the value range of waveforms and reframe
(rescale) the signal so that it fits vertically into a grid. Otherwise, calculated waveforms may be clipped if the
resolution is too high to fit the signal into the full scale range.

Select Clear Sweeps to reset all measurement counters while the process is running.

Action 2 through Action 4 are reserved for future use.

Multi-Parameter & Waveform Processing Web

To import multiple waveforms and parameters from MAUI, or to return multiple parameters and waveforms to MAUI
from the client application, you must add the Fast MultiWave Port processor to a processing web from within the
Web Editor.

1.

For each math function and parameter that will receive an output from the client application, choose Type
web edit/advanced web edit. This will add them to the processing web as output terminals.

If you do not wish to return anything to MAUI, it is sufficient to set it for one parameter slot.

Measure

Click Show Processing Web on any setup dialog when you are ready to edit.
In the Web Editor, click + Meas. and choose Fast MultiWave Port from the Custom submenu.

Connect the oscilloscope data used by the client application to the Fast MultiWavePort node inputs. You may
input up-to-four waveforms (Inn) selected from the oscilloscope's channels, math functions, memories or
zoom traces, and two parameters (Pin).

Connect the outputs of the Fast MultiWave Port processor to the appropriate terminal blocks:
 Tooutput a waveform, connect a waveform (Wfn) to an Fn terminal.
» To output a measurement, connect a parameter (Pmn) to a Pn terminal.
» Tochange units or rescale the measurement as it is returned to MAUI, connect the output parameter to

an intermediate + PMath node configured with P Rescale.

Note: Outputs may be used as intermediate inputs to other processing nodes in the web, rather than
directly connected to any terminal blocks. Alternatively, you may omit connecting any outputs to
processors or terminals, in which case the Fast MultiWave Port processor will simply port the
oscilloscope data to your client application.
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Client Programming Considerations
The program ID is: LeCroy.FastMultiWavePort.1

A waveform descriptor is supplied in the MultiWavePort.h header file. There is also a “mini-descriptor” block which
contains incremental information to characterize each additional waveform data block.

Likewise, a descriptor header has been provided for parameter results, and a protocol for supplying parameter
values.

The client application creates the named memory spaces which are used to communicate between the client and
MAUI processes. The base name of the mapped memory is specified in the MAUI Automation control variable
app.Measure.Pn.Operator.PortName and by default is “FMWavePort1".

The named spaces are:

» FMWavePort1Filelnn—Input/output waveforms; 'n" equals 1 to 4

"won

» FMWavePort1FileOutn—Qutput parameters; 'n" equals 1to 8

Note: The base name for these named memory spaces will need to change from the 1-based name if you
want to have two processors of this kind active at the same time.

Once the client application creates whatever named spaces it wishes to use, the oscilloscope processor “opens”
them if they're present, also learning their size from data structures initialized there by the client application.

Context switching between the two processes sharing the memory has an associated cost of around 30 to 50 pS, so
an overall exchange costs between 60 and 100 uS. This overhead is minimized by handling multiple waveform
acquisition in a “per-batch” or per sequence fashion.

There are up-to-four data structures that communicate the state of the input waveforms to the client application,
and similar structures for the parameter descriptor and parameter values. These are described in the header file.

Each of the parameter blocks is invalidated every time the control is passed to the client application. If you do not
explicitly validate them each time the client application updates, the result will not be passed forward. This is one
way to omit returning parameter results to the oscilloscope application when using Fast MultiWave Port solely to
access oscilloscope data.

There are two named "mutex’es used to implement a mutual exclusion scenario for shared access to the memory
resource.

» FMWavePortTMutexDataAvailable—Signal from the oscilloscope that data is “available” to the client
application.

» FMWavePort1MutexProcessingComplete—Signal from the client application indicating the external processing
has been completed.

The two processes access the named memory as shared memory in a mutual-exclusion scenario.
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FFT Function

For a large class of signals, you can gain greater insight by looking at spectral representation rather than time
description. Signals encountered in the frequency response of amplifiers, oscillator phase noise and mechanical
vibration analysis, for example, are easier to observe in the frequency domain.

If sampling is done at a rate fast enough to faithfully approximate the original waveform (usually five times the
highest frequency component in the signal), the resulting discrete data series will uniquely describe the analog
signal. This is of particular value when dealing with transient signals, which conventional swept spectrum analyzers
cannot handle.

While FFT has become a popular analysis tool, some care must be taken with it. In most instances, incorrect
positioning of the signal within the display grid will significantly alter the spectrum, producing effects such as
leakage and aliasing that distort the spectrum. An effective way to reduce these effects is to maximize the
acquisition record length. Record length directly controls the effective sampling rate and therefore determines the
frequency resolution and span at which spectral analysis can be carried out.

Setting Up an FFT Function

1. Follow the usual steps to set up a math function, selecting FFT from the Frequency Analysis submenu.

2. Open the FFT subdialog.

zero Fill

3. Choose an Output type:

» Magnitude is the amplitude output in linear units. This reads the peak value of a sine at each frequency.
This trace is useful as an input to math operations like adding and subtracting spectra.

Note: A Magnitude spectrum will normally display the input source unit on the vertical axis.

* Phase

» Power Spectrum is the square of the magnitude spectrum (0 dBm corresponds to voltage equivalent of
T mW into 50 ohms). This is the representation of choice for signals containing isolated peaks, such as
periodic signals. It is a good general purpose view offering wide dynamic range so that you can see
small spectral details.

4. If your Output Type is Power Spectrum, also enter Line Impedence. By default, the FFT function assumes a
termination of 50 Ohms. If an external terminator is being used, this setting can be changed to properly
calculate the FFT based on the new termination value.
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If your Output type is Phase, enter a Group Delay Shift value.
5. Check the Suppress DC box to make the DC bin go to zero. Otherwise, leave it unchecked.
6. Optionally, choose a weighting Window (see below).
7. Choose the Algorithm used to calculate the spectrum:

» Least Prime, the default algorithm, computes FFTs on transform sizes having lengths that can be
expressed as factors of 2N*5K. This is very compatible with the record lengths encountered in the
oscilloscope, which are often multiples of 1, 2, 4, 5, or 10. Remaining points are discarded based on your
truncation selection.

« Power (of) 2computes the FFT on 2N points of the source record. For example, if you acquired 2 Gpts in
your source trace, the FFT would use only 1,073,741,824 points, discarding the remainder based on your
truncation selection. The Power of 2 algorithm generally runs faster than the Least Primes algorithm.
The price paid is a transform record length that is not the same as that of the acquired signal.

8. When the FFT transform size does not match the record length, you can choose how to truncate the record to
perform an FFT on the shorter record (this will increase the resolution bandwidth), or add points to lengthen
the record.

» The first trunc(ate) button keeps the center number of points equal to the transform length and discards
any excess at the beginning and end.

 zerofill is useful when the source data for the FFT comes from a math operation that shortens the
record. This is commonly encountered in filtering operations like enhanced resolution. The missing data
points are replaced by data values, whose amplitudes are interpolated to fit between the last data point
and the first data point in the record. This guarantees that there is not a first-order discontinuity in the
filled data. Since the data at the end of the record is "filled" data, it is advisable to select a weighting
window other than rectangular to minimize the effect of the fill on the resulting spectrum.

» The second trunc(ate) button keeps the first number of points equal to the transform length and
discards any excess at the end of the record.

Choosing a Window

If you think of an FFT as synthesizing a bank of parallel band-pass filters, weighting functions control the filter
response shape and affect noise bandwidth as well as side lobe levels. The window type defines the bandwidth and
shape of the equivalent filter to be used in the FFT processing.

The choice of window is dictated by the signal's characteristics. Rectangular windows provide the highest frequency
resolution and are useful for estimating the type of harmonics present in the signal. Because the rectangular window
decays as a (SinX)/X function in the spectral domain, slight attenuation will be induced. Functions with less
attenuation (Flat Top and Blackman-Harris) provide maximum amplitude at the expense of frequency resolution,
whereas Hamming and Von Hann are good for general purpose use with continuous waveforms.

Window Type Applications and Limitations

Rectangular Normally used when the signal is transient (completely contained in the time-domain window) or
known to have a fundamental frequency component that is an integer multiple of the fundamental
frequency of the window. Signals other than these types will show varying amounts of spectral leak-
age and scallop loss, which can be corrected by selecting another type of window.

Hanning (Von Hann) & |Reduces leakage and improves amplitude accuracy. However, frequency resolution is also reduced.
Hamming

Flat Top Provides excellent amplitude accuracy with moderate reduction of leakage, but with reduced fre-
quency resolution.
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Window Type Applications and Limitations
Blackman-Harris Reduces leakage to a minimum, but with reduced frequency resolution.
Gaussian

FFT Window Filter Parameters

Window Type wg;‘ cEisltalel: Scallop Loss (dB) ENBW (bins) Coherent Gain (dB)

Rectangular -13 3.92 1.0 0.0
Von Hann -32 1.42 1.5 -6.02
Hamming -43 1.78 1.37 -5.35
Flat Top -44 0.01 343 -11.05
Blackman-Harris -67 1.13 1.71 -7.53
Gaussian

Interpolate Function

The Interpolate operator enables you to generate a trace that interpolates data points into the source trace
according to your selected method and upsampling factor.

Linear interpolation, which inserts a straight line between sample points, is best used to reconstruct straight-edged
signals such as square waves. This is the default interpolation method used by the oscilloscope.

(SinX)/X interpolation, on the other hand, is suitable for reconstructing curved or irregular waveshapes, especially
when the sampling rate is 3 to 5 times the system bandwidth.

Cubic interpolation can be used to create a smooth, continuous function by applying a third-degree polynomial.
For each method, you can select an upsample factor of 2 to 50 points to insert between samples.

1. Follow the usual steps to set up a math function, selecting Interpolate from the Filter submenu.

2. Select an interpolation method.

3. Enter the Upsample by number of points.

Tip: You can use the Up and Down buttons to set this value. To make single increment changes,
deselect the "Only by 2, 5..." checkbox.

4. In Half Width enter the width in taps of the filter.

5. Touse a weighting function rather than an upsample factor, select it from Weighting. See FFT for more
information about these functions. If using the Kaiser function, also enter the Beta value.
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Phistogram Function

The Phistogram Math function creates a histogram of the samples within a vertical or horizontal "slice" of a
persistence map to reveal the features that are only visible when several acquisitions have been superimposed on
one another. Vertically, each bin contains a class of similar amplitude levels; horizontally, each bin contains a class

of similar time values.

The source trace must have Persistence "on" to generate the persistence map. Eye diagrams, which are a type of
persistence map, are a an especially useful class of traces to which you can apply the Phistogram function.

1. Follow the usual steps to set up a math function, choosing a Single operator function using the Phistogram

operator.

2. Onthe Phistogram subdialog, choose the slice of the persistence map to histogram:

« Slice Direction determines whether the slice transverses an entire vertical level of the map across time
(horizontal), or a time on in the map across vertical values (vertical).

For a histogram of...

A crossover point in time or amplitude on an eye dia-
gram*

Use...

Vertical and horizontal slice persistence histogram

Cumulative jitter on an eye diagram *

Horizontal slice persistence histogram

Signal-to-noise ratio on an eye diagram *

Vertical slice persistence histogram

* Requires optional software package capable of creating eye diagrams, such as SDAIII or Serial Decoder TDME software.

« Slice Center represents the center level or time of the slice.

+ Slice Width represents the total amplitude or total time of the slice, half each side of the center. This
setting will deepen or widen the total area of the slice of values to be plotted on the histogram. If Help
Markers are on, you will see the change in the blue bar representing the slice.

Note: This selection does not affect Center and Width settings made on any existing

histograms.

3. Choose Center Cursor to place a measurement cursor at the center of the slice.
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Ptrace Functions

The Ptrace Mean, Ptrace Range, and Ptrace Sigma math functions (found in the Jitter Functions sub-menu of the
Math Operator selector) compute a vector trace based on a persistence map of underlying signal acquisitions
without destroying the underlying raw data. Signals sampled at or above 2 GS/s that have accumulated in the
persistence map can be traced at a resolution of 10 ps (100 GS/s equivalent sampling). Further measurements or
Pass/Fail testing can be performed on the resulting math traces.

The source trace must have Persistence "on" to generate the persistence map used by each of these functions.

Ptrace Mean
The Ptrace Mean trace helps to see edge detail in a fast signal, or to eliminate noise on a persistence map.

For each time slice of the persistence map, Ptrace Mean calculates and plots a trace corresponding to the mean
vertical value. The Ptrace Mean can be further analyzed using the instrument’s standard parameters, such as rise
time. Optionally, choose to limit the Num(ber of) Points plotted.

Ptrace Range
The Ptrace Range trace helps to assess typical noise on a persistence map.

For each time slice on the persistence map, Ptrace Range calculates and plots an envelope corresponding to the
range of vertical values.

Enter the % population range, the percentage of the population of the persistence map that forms the envelope,
enabling exclusion of infrequent events (artifacts). Optionally, choose to limit the Num(ber of) Points plotted.

Ptrace Sigma
The Ptrace Sigma trace helps to assess worst case noise on a persistence map. It can be used to create a tolerance
mask for Pass/Fail testing.

For each time slice on the persistence map, Ptrace Sigma calculates and plots an envelope corresponding to the
standard deviation of vertical values.

The envelope can be scaled to a specified sigma. Enter the Scale to standard deviations. This allows you to select a
sigma from 0.5 to 10.0 to define the envelope of values plotted. Optionally, choose to limit the Num(ber of) Points
plotted.
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Rescale Function

The Rescale function allows you to create a new function trace that rescales another trace by applying a
multiplication factor (a) and additive constant (b). You can also use it as a way to view the function source in a
different unit of measure.

0 Tip: Channel and sensor traces may be rescaled directly using the Cn and SEn dialogs.

Setting Up a Rescale Function

1. Follow the usual steps to set up a math function, selecting Rescale from the Functions submenu.

2. Touch the Rescale subdialog tab.
3. To modify the scale of output:
» Check the First multiply by: box and enter the number of units equal to 1V (a, the multiplication factor).
e Touch then add: and enter b, the additive constant.
4. To change the output unit of measure from that of the source waveform:
» Check Override units.
* In Output enter the code for the new unit of measure.
You can combine units following these rules:
 For the quotient of two units, use the character /"

» Forthe product of two units, use the character .

» Forexponents, append the digit to the unit without a space (e.g., "S2" for seconds squared)
Note: Some complex units are automatically converted to simple units. For example, V.A is W).

5. You can further override the output unit by selecting from the Units dialog. Only units in the equivalent
dimension as the unit of the Rescale function trace are available for selection.

Units of Measure

Units are automatically rescaled up or down within the list of standard, Sl prefixes based on the relative size of the
signal. For example a 1000 V reading is shown as 1 kV, while .1 V is shown as 100 mV. When the multiplication
factoris 1V =1 Pascal, a 10 millivolt (mV) reading is displayed as 10 mPa rather than .001 Pa or 100e-3 Pa.

Following are the supported Sl units of measure and the mnemonics used to represent them on the Rescale dialog.

Note: These same mnemonics can be used in remote control and customization scripts. Specify only the
base unit in code, do not add prefixes.

Note: Time and dimensionless units are available only for certain measurements and for use in code where
relevant.
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Category Unit Mnemonic
Mass gram G
slug SLUG
Volume liter L
cubic meter M3
cubic inch IN3
cubic foot FT3
cubic yard YARD3
Angle radian RAD
arcdegree DEG
arcminute MNT
arcsecond SEC
cycle CYCLE
revolution REV
turn TURN
Force/Weight Newton N
grain GR
ounce 0z
pound LB
Velocity meters/second M/S
inches/second IN/S
feet/second FT/S
yards/second YARD/S
miles/second MILE/S
Acceleration meters/second2 M/S2
inches/second2 IN/S2
feet/second? FT/S2
standard gravity GN
Pressure Pascal PAL
bar BAR
atmosphere, technical AT
atmosphere, standard ATM
Torr TORR
pounds/square inch PSI
Temperature degrees Kelvin K
degrees Celsius CEL
degrees Fahrenheit FAR
Energy Joule J
British Thermal Unit BTU
calorie CAL
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Category Unit Mnemonic
Rotating Machine radians/second RADPS
frequency (Hertz) HZ
revolutions/second RPS
revolutions/minute RPM
torque N*m NM
torque in+0z INOZ
torque in+lb INLB
torque ft-lb FTLB
power, mechanical (Watt) W
horsepower HP
Magnetic Weber WB
Tesla T
inductance (Henry) H
magnetic field strength A/M
permeability HENRYPM
Electrical Ampere A
Volt \%
Watt W
power, apparent VA
power, reactive VAR
power factor PF
capacitance (Farad) F
Coulomb C
Ohm OHM
Siemen SIE
electrical field strength V/M
electrical displacement field CPM2
permittivity FARADPM
conductivity SIEPM
Time second S
minute MIN
hour HOUR
day DAY
week WEEK
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Category

Dimensionless

Unit Mnemonic
percent PCT
percent min-max PCTMNMX
decibel DB
decibel milliwatt DBM
decibel Volt DBV
decibel millivolt DBMV
decibel microvolt DBUV
decibel microampere DBUA
decibel referred to carrier DBC
decade DECADE
unit interval Ul
Q-scale Q

bit BIT

byte BYTE
baud BAUD
least significant bit LSB
poise POISE
parts per million PPM
pixel PIXEL
division DIV
event EVENT
sample SAMPLE
segment SEG
sweep SWEEP

Sparse Function

The Sparse math function allows you to thin out an incoming waveform by skipping points at regular intervals, and
by starting acquisition at a particular offset (point). The Sparsing factor specifies the number of sample points to
reduce the input waveform by. A sparsing factor of 4, for example, says to retain only one out of every 4 samples. A
Sparsing offset of 3, on the other hand, says to begin on the third sample, then skip the number of samples specified

by the sparsing factor (4). In this way, the sample rate is effectively reduced.

For the sparsing factor (interval), you can set a value from 1 to 1,000,000 points. For the sparsing offset you can set
a value from 0 t0 999,999.

1. Follow the usual steps to set up a math function, selecting Sparse from the Misc submenu.

2. Touch the Sparsing factor control and provide a Bandwidth Limit value.

3. Touch the Sparsing offset control and provide a value.
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Memories

The instrument is equipped with internal memory slots (Mn) to which you can copy any waveform that is active on
the grid. This is a convenient way to store an acquisition for later viewing and analysis. Memories can be used as
source inputs for most oscilloscope math and measurements, allowing you to compare historical data to a live
acquisition or perform "what if" modeling on saved acquisitions.

Note: If there is a processing error (e.g., no data) when saving or recalling a memory, a small letter 'i" inside
a bubble will appear on the Mn descriptor box to indicate there is more information regarding the waveform
status. See Finding Waveform Status for instructions on finding the error.

Saving Memories

Store memories on the Memory dialogs (Mn). Memories are created at the same scale as the source trace, but they
can be adjusted independently by using the zoom factor controls that appear next to the Mn dialogs.

Save Waveform to Memory
0 Tip: Try to choose an empty slot, as anything currently stored in that location will be overwritten. All

memories will state if they are empty or an acquisition is stored there.

Horizontal

0.0 mV

Add / Edit Reset
Name Zoom

On oscilloscopes with OneTouch, touch the Add New box and choose Memory. Drag the descriptor box of the trace
you wish to store onto the Mn descriptor box.

Or

1. Press the front panel Mem button or choose Math > Memory Setup.
2. Touch the Mn tab corresponding to the memory slot you wish to use.
3. In Copy from Waveform, choose the source trace to copy to memory.
4. Touch Copy Now.

5. Optionally, check Trace On to immediately display the memory.

Import External Waveform Files into Memory

Trace (.trc) files saved on other Teledyne LeCroy instruments can also be imported into internal memory using the
waveform recall feature. Choose File > Recall Waveform and to recall the file to an internal memory. Then, you can
use the Memories dialog to place them on the display.
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Restoring Memories

The Memories dialog is a convenient panel for restoring saved memories to the display.

Access the Memories dialog by pressing the front panel Mem button or choosing Math > Memory Setup.

Check On next to the memory trace you wish to display. A description of the memory showing the source channel
and creation time appears next to each Mn on the dialog.

Touch Clear All Memories to empty the memory banks.

A Caution: Memories cannot be restored once they have been erased.

16 9:08:51 AM

16 13:27:44 PM

Clear All
Memaories
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Analysis Tools

Analysis tools complement the standard math/measurements to help you understand the behavior of waveforms.
WaveScan searches single or multiple acquisitions for events that meet specific criteria.
Pass/Fail Testing shows whether waveforms or measurements meet a set of defined criteria.

CustomDSO (XDEV) enabes you to insert custom VBScript (VBS) or 3rd-party programs such as Excel™, Mathcad™,
and MATLAB™ into the oscilloscope processing stream. It is standard on many high-bandwidth oscilloscopes,
optional on others.

Many optional software packages may be purchased for specialized uses, such as power analysis or serial message
trigger and decode. In most cases, these options are added to the Analysis menu. Complete documentation for
software options can be found at teledynelecroy.com/support/techlib under Manuals > Software Options. In
addition, context-sensitive Help for many options available on your platform can be found in the MAUI Support site
under the Analysis menu.

WaveScan

The WaveScan® Search and Find tool enables you to search for unusual events in a single capture, or to scan for a
particular event in many acquisitions over a long period of time. Each Scan Mode is optimized to find a different type
of event. Results are time stamped, tabulated, and can be viewed individually. You customize the presentation by
choosing different WaveScan displays, called Scan Views.

@ Note: The instrument reverts to Real-time sampling mode when WaveScan is enabled.

Bl File | T Vertical |+ Timebase = Trigger | & Display | # Cursors = E] Measure '@ Math | = Anal X Utilities | @ Support
Runt Ampl.

146 mV

800mvV
400mv
om

-400mV

-800mv

-101.625ms -100.625ms B S
Trigger 1l S
200 mV/div 2 | 50.0 ms/div Stop 0.0 mV
0.0 mV ofst S | 125MS 25 MS/s Edge Positive

WaveScan Runt Setup € cLose

thresholds

Action on Features Found

. MNone

WaveScan window with different scan "views" turned on.
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Scan Modes

The Scan Mode determines the type of search to be performed. Select the Mode along with the Source trace to be
searched on the main WaveScan dialog. For each mode, different controls appear on the WaveScan dialog, providing
additional inputs to the search criteria. Make the appropriate entries in these fields before starting the search.

Edge Mode

Edge Mode is used for detecting the occurrence of edges. Events that meet the threshold level are captured and
tabulated. When the acquisition is stopped, scan filters can be applied to the edges to find specific characteristics.
Edge Mode settings are:

» Slope. Choose Pos, Neg, or Both.
+ Levelis (setin...). Choose Percent or Absolute.

» Percent/Absolute Level. Enter a threshold value as a percentage of Top to Base or voltage level.

Non-monotonic Mode

Non-monotonic Mode looks for edges that cross a threshold more than once between high and low levels. All events
that meet the criteria of slope, hysteresis, and level are presented in a table and highlighted in the source trace. The
value displayed in the table is the difference of the max. and min. of the non-monotonicity. This can be confirmed
with cursors. The hysteresis value is used to eliminate noise. A non-monotonicity is detected only when its amplitude
is greater than the hysteresis. Therefore, when setting a hysteresis level, set a value that is greater than the
amplitude of the noise. Settings are:

» Slope. Choose Pos, Neg, or Both.

» Hysteresisis (setin...). Choose Division, Percent, Absolute.

Division/Percent/Absolute. Enter hysteresis level in the selected unit.

» Levels are (setin...). Choose Percent, Absolute, or Pk-Pk%.

High/Low Level. Enter top and bottom thresholds in the selected unit.

Runt Mode

Runt Mode looks for pulses that fail to cross a specified threshhold. You can search for positive-going or negative-
going runts, or both. An adjustable hysteresis band is provided to eliminate noise.

In the case of negative-going runt pulses, the value displayed in the table is the difference (delta) of the high level of
the signal and the runt amplitude (i.e., where the runt bottoms out). This can be confirmed by placing cursors on the
runt pulse and reading the delta Y value in the trace labels. In the case of positive-going runt pulses, the value
displayed in the table is the absolute value of the amplitude of the runt pulse. Runt Mode settings are:

» Runt Type. Choose Both, Pos, or Neg.
» Hysteresis. Enter the hysteresis level as a percentage or voltage.
» Low/High Threshold. Enter the levels as a percentage or voltage.

 Absolute Levels. Check this box to enter levels as absolute voltage instead of percentage.
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Measurement Mode

Measurement Mode is used for applying filters to measurements to find those that meet your defined criteria,
helping to isolate particular events within many samples. Markers appear over the source trace to indicate the
location of measurement, while the table displays values for the selected parameter that meet the criteria.
Measurement Mode settings are:

» Measurement. Choose the measurement parameter you wish to search.

« Filter Method. Choose the operator that indicates the desired relationship to the Filter Limit. Only
measurements that meet this criteria are returned.

« Filter Limit. Enter the value that completes the filter criteria.

Alternatively, you can use the Filter Wizard to create the filter criteria.

Serial Pattern Mode

Serial Pattern Mode is used for finding 2- to 64-bit patterns in serial data sequences or serial clocks. It is ideal for
bursted patterns where a PLL cannot lock. Serial Pattern Mode settings are:

Pattern Time
This is the bit pattern to find.

« Viewing. Choose to enter the pattern as Binary or Hex(adecimal).
 Binary/Hex. Enter the digital pattern to find in either binary or hexadecimal.

For binary patterns, enter the state the line should be in as 1=high, 0=low, X=don't care (not included in pattern),
starting from highest to lowest number line.

» Num. Patterns to detect. Enter a whole number of pattern locations to mark on the acquisition.

NRZ to Digital
These settings define the serial logic for the bus.

e Check Datais NRZ if the data is an NRZ signal.
 Enter the Base Frequency of the signal.

» In Level Type and Level, enter the threshold for logic determination as either a percent amplitude or an absolute
voltage.

» Choose the waveform Slope used for logic determination.

e Choose if the Signal Type being scanned is Data or Clock.

e |fthereisany PLL in use on the signal scanned, check Use PLL.
e Select the PLL Type in use.

 Enter the PLL Cutoff Divisor if you are using a Custom PLL. This field normally updates to the standard for the
PLL type selected.
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Bus Pattern Mode

Bus Pattern Mode (only on Mixed Signal models) is used for finding 2- to 16-bit patterns across the digital lines
where PLL is not a concern. Bus Pattern Mode settings are:

« Viewing. Choose to enter the pattern as Binary or Hex(adecimal).
 Binary/Hex. Enter the digital pattern to find in binary or hexadecimal code.

For binary patterns, enter the state the line should be in as 1=high, 0=low, X=not included in pattern, starting
from highest to lowest number line. An 8-line bus is assumed. For example, to set the pattern D2=1, D1=0 and
DO=1 for 8-line bus DO-D7, you can just enter 101" on the keypad, and the software will complete the full
pattern XXXXX101. If you wish to set the pattern on D7, D6 and D5, enter T0TXXXXX.

» Num. Patterns to detect. Enter a whole number of pattern locations to mark on the acquisition.

Scan Views

Scan Views are different ways to view your WaveScan results. Just check the boxes at the bottom of the WaveScan
dialog for those views you wish to display simultaneously.

Note: The number of grids varies depending on which views are enabled. WaveScan handles this function
automatically, and you cannot move traces among grids as in normal operation.

Additional controls for Scan Overlay and Zoom views are on their respective dialogs. If you turn on these traces from
those dialogs, you must turn them off from there, too.

Source Trace
By default, the source trace is displayed in the top grid, with markers indicating points that meet the search criteria.

Table

Table view displays a table of measurements relevant to your chosen Search Mode next to the source trace. Times
view adds columns to the table showing Start and Stop Times for each event.

Scan Overlay
Scan Overlay view uses colored overlays to show the location of events meeting the scan criteria.

Zoom

Zoom view works exactly as it does elsewhere in the oscilloscope software, creating a new trace that is a magnified
section of the source trace. A WScanZn tab appears by default when you launch WaveScan.

146



Analysis Tools

Setting Up WaveScan

Set up your source channel and triggers before setting up the scan.

Runt Setup

Both

1. Press the front panel Stop button to stop acquisition.
2. Choose Analysis > WaveScan and check Enable.
3. Choose the Source waveform.

4. Choose the Scan Mode and enter values for any additional settings that appear at the right of the dialog
based on your selection.

5. Select each Scan View in which you wish to display results by checking the box at the bottom of the dialog.
Each view selected is displayed simultaneously.

6. Optionally, choose a Trigger Action to take when an event is found that meets your scan criteria.
Tip: Despite the name, these actions occur only when the WaveScan criteria are met, not with every

acquisition trigger. Pulse AUX Output will send a pulse over the AUX Out connector. Print Screen will
execute whatever you have configured on the Print dialog.

7. Restart acquisition.

WaveScan Search

Search is used to find events in zoom (Zn) traces that match user-defined criteria. To search within WaveScan:
1. Select the Zoom view.
2. After stopping the acquisition, open the Z1 dialog that appears behind the WaveScan dialog.

3. Use the Prev and Next buttons to move back or forward within the trace to the events that matched your Scan
Modes criteria.
Or

If you know the WaveScan table index (row) number of the event you wish to find, enter it in ldx.
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Scan Overlay

To apply monochromatic persistence to a Scan Overlay:
1. Select Scan Overlay when setting up the wave scan, then open the Scan Overlay dialog.
2. Check Persistence On.

3. Enter a Saturation level as a percentage. All samples above the saturation level are assigned the highest color
intensity.

4. Choose a Persistence Time. The higher the time, the more static the persistence display.
To adjust the scan overlay to "zoom" in or out: touch the In/Out buttons, or touch Scale and enter new values. Check

Var. to adjust scale in finer steps than the default 1, 2, 5.

Scan Histogram

Scan Histogram is an additional WaveScan "view" that generates a histogram to give you a statistical view of edges
that meet your search criteria. Set it up as you would any histogram:

Zoom

Scaling

#Bins
200 13

Find Center
and Width

1. Enter the total #Values in the histogram buffer.
2. Enter the #Bins (bars) in the histogram.

3. Enter the Center value and Width of each bin from center, or check Enable Auto Find and let the sofware Find
Center and Width.

4. Choose a Vertical Scale method:

 Linear allows the histogram to build vertically as data accumulates. When the histogram reaches the top
of the display it rescales the vertical axis to keep it on screen.

» LinConstMax keeps the histogram at near full scale and rescales the vertical axis as data is
accumulated.
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PASS/FAIL Testing

PASS/FAIL testing allows you to define a set of qualifying conditions that an acquisition may "PASS" or "FAIL" when
tested against, then take actions depending on the result.

» Mask testing compares sampled values to a pre-defined area of the grid to see if they fall within or without.

» Parameter comparison compares a measurement result to a pre-defined value (Param compare) or to another
measurement (Dual param compare).

You can preconfigure multiple queries (Qn) using either method, which are then enabled by selecting them on the
Pass/Fail dialog and defining what results constitute a "PASS" on the Actions dialog.

Mask Testing

A mask defines an area of the grid against which a trace is compared. Test conditions define how the waveformis to
be compared to the masked area (e.g., some/all values fall within, some/all values fall outside), and a pass or fail
result is returned indicating the condition was found to be true or false.

Mask testing can be done using a pre-defined mask or a mask created from a waveform with user-defined vertical
and horizontal tolerances. Some industry standard masks used for compliance testing are included with the
oscilloscope software. The mask test can be confined to a region of the trace by the use of a measurement gate.

Access Mask Test Dialogs

Test Load Msk

Summary
Any point is outside Mask0003.msk

1. Choose Analysis > Pass/Fail Setup to display the Pass/Fail dialog.
2. Touch the Qn button where you want to set up the query.

3. Select Condition Mask test. Make mask settings on the right-hand dialogs.

Make Mask

Use this procedure to create a new mask based on a live waveform. The mask covers the area of the waveform plus
the boundaries you enter. It is best used for "all in" testing.

1. Open the Make Mask subdialog.

2. If desired, enter a new Destination File Name and path, or touch Browse and select a previous file to overwrite.
The file name should end with the .msk extension.

3. Touch the Ver Delta and Hor Delta fields and enter boundary values.

4. Touch Make from Trace.

Load Mask

Do this instead of Make Mask if you have a pre-defined mask file.
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1. Open the Load Mask subdialog.
2. Touse asaved .msk file, touch File and select the mask.

3. Check View Mask to display the mask over the trace.

Remove Masks from the Display
Touch the Delete All Masks button on the Pass/Fail dialog.

Set Gates
To limit the section of the waveform that is compared to the mask.

1. Open the Gate subdialog.

2. Enter the Start and Stop horizontal divisions that mark the section of the waveform to be tested. These can be
a whole division or a fraction of a division. Divisions are numbered 1-n left to right.

0 Tip: You can also drag the gate posts from the left and right edges of the grid to the desired position.

Define "True"
1. Open the Test subdialog.
2. Select one of the conditions that, when true (yes), results in a pass or fail.

3. Optionally, turn On markers to show where on the waveform mask violations have occurred.
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Param(eter) Compare

PASS/FAIL queries (Qn) can be configured to compare different parameter measurements (Pn) to each other, or to a
user-defined limit or statistical range. The Summary field shows the logic represented by the query. Check it to
ensure your selections are producing the test you want.

Comparing a Measurement to a Limit
This method compares the result of a selected parameter to a user-defined limit or statistical range.

Qs Q6 Q7 Qs ParamCompare

"o
K Param compare

All
Summary
All P2 = 0.147782 147
Set Limit and Delta using
Current T3 =} p b
[EE] Sigma Sigma Sigma

1. Choose Analysis > Pass/Fail to display the Pass/Fail dialog.
2. Touch the Qn button where you want to set up a query.

3. From the pop-up menu, choose Param compare.

4. Onthe Qn dialog, touch Source1 and choose the parameter.

5. On the ParamCompare subdialog, touch Compare Values and select All (every value must be within limit to be
"true") or Any (any value can be within limit to be "true").

6. Touch Condition and select a Boolean operator, then touch Limit and enter the value that completes the
condition. The value entered acquires properties corresponding to the parameters being tested. For example,
if you are testing a time parameter, the unit is seconds.

7. If you chose to set a Delta limit, also enter the Absolute or % Delta value. You may choose instead to set Limit
and Delta using one of the buttons at the bottom of the dialog.

Comparing Parameter Measurements
This method compares one parameter to another, rather than a limit.

1. Choose Analysis > Pass/Fail to display the Pass/Fail dialog.

2. Touch the Qn button where you want to set up a query.

3. From the Pass/Fail Condition menu, choose Dual Param Compare.

4. Onthe left-hand Qn dialog, select the parameters to compare in Source1 and Source?2.

5. On the ParamCompare subdialog, choose to Compare All (every value must meet condition to be "true") or
Any (any value can meet condition to be "true").

6. Touch Condition and select the Boolean operator that expresses the relationship between parameters (e.g.,
All P1 values must be less than P2).
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Defining PASS/FAIL Tests

The queries define the conditions that, if met, would result in "true” but don't in themselves determine the test result.
You must separately define what constitutes a "PASS" or a "FAIL" on the Actions dialog. Either result can be made to
produce various additional actions, such as sending a pulse to another device.

Q3

All True
Q1&0Q2)

Force Actions

Clear All e

1. After setting up the PASS/FAIL test qualifiers, open the Actions tab.
2. Optionally, check Summary View to see a running summary of results.
3. Select the test Pass criteria in Pass If.
Apply Actions
1. Check Enable Actions to turn on actions.
2. Under If, choose to apply actions if the result is a Pass or a Fail.
3. Under Then, choose all the actions to take:

* Save Waveform file

Stop the test

Sound an Alarm

Emit a Pulse from the AUX OUT connector. When taking this action, also go to Utilities > Utilities Setup >
Aux Output and choose to Use Auxilliary Output For Pass/Fail.

» User Action configured for the front panel User button.

Create a LabNotebook Entry

Use the Clear All button to clear all the action checkboxes, or Force Actions Once to take action once regardless of
the test results.

Delay Test
You can delay the start of a test by entering the number of sweeps to wait in Start Testing After.

Touch Clear Sweeps at any time to reset the test counter.

Stop Test
To stop the test following a specified number of sweeps, rather than a PASS or FAIL result, check the Stop Test box,
then enter the desired number of sweeps in After.

Stop After

1000 sweeps
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CustomDSO Setups/Controls

Custom setups, which can include proprietary math/measurements, are one of the most commonplace uses of
Advanced Customization. The CustomDSO Setup dialog, which is enabled with the XDEV option, provides a
convenient entry point for either:

* Linking Automation programs saved as .Iss or .vbs files to eight Basic Action buttons

* Installing a Plug-in that adds a custom dialog and processors to the oscilloscope's MAUI interface

Note: You can only enable either the Plug-in or the Basic Actions at once, which determines which user
interface is displayed.

From the oscilloscope menu bar, choose Analysis > CustomDSO.

If you do not need to link your custom script to a GUI control, but just want to create a custom processor to be
applied as a math function (Fn) or measurement parameter (Pn), you can go directly to that part of the oscilloscope
interface to upload or begin scripting it.

Basic Actions

The Basic setup utilizes eight Action buttons, each of which can launch a different setup file written in VBScript. This
"menu" of custom Action buttons can be set to appear at the bottom of the oscilloscope touch screen at all times,
regardless of whatever dialogs are open, or even if the oscilloscope application is closed and the Windows desktop
or other application is open.

Template LeCroy System Setup (Iss) files named custom 1.Iss through custom 8.Iss are the defaults for each
button, ready to be modified in situ, or copied, edited and saved to new files for future use. These default scripts,
syntactically identical to VBScripts with a different file extension, are Microsoft COM Automation programs used to
apply complex setup instructions to the oscilloscope.

The scripts can program an entire oscilloscope setup, or just a portion of a total setup—such as to recall a waveform
file or memory, enable a particular math function, set a trigger and acquire, modify a display setting, etc. Scripts can
be run synchronously or asynchronously.

Installing Scripts
To assign scripts to buttons:

CustomDSO Setup Test B:

de on Action Definition

D:\CustomDSO Browse

Plugln

1. Select Basic, then select the Action button to host the script.

2. Check Enable Action to make the button active. If deselected, the program will remain associated with the
button, but the button will not function.
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3. Toallow scripts to run in a separate process from the oscilloscope application, check Execute Scripts
Asynchronously. This allows the oscilloscope application to perform another function while the script is being
executed.

4. To keep the Action buttons visible on the oscilloscope at all times, check Present CustomDSO menu at
powerup and when menu closed.

5. Either touch Edit and modify the template script in the CustomDSO Editor (see below) , or touch Browse to
select a saved program you wish to launch with this button.

6. Optionally, open the Test Basic Mode dialog and test the new button.

Creating/Modifying Scripts
Since the setup files are VBScript (VBS) files, follow the programming rules and recommendations in Customization
Using VBScript when scripting.

1. Set up the oscilloscope exactly as you would wish it to be when the button is activated.

2. Onthe CustomDSO dialog, select the button and click Edit to open the CustomDSO Editor window.

CustomDSO Editor

On Error Resume Next
set dso = CreateObject ("LeCroy.XStreamD50.1"™)

Load From Load From
Example Current Setup

3. Tocopy all current oscilloscope settings into the setup file, select Load from Current Setup.
To revert to the original template file, select Load from Example.

While not required, starting your script by loading the current setups can help ensure the presence of all
settings required for your Action, especially if you have already scripted and activated custom math or
measurements you wish to make part of this setup. They will be already embedded in the setup script.

4. Make any further modifications or additions to the script.
5. Optionally, click Test to execute the script.

6. When done editing, Save As a new file, or just Save these changes to the custom n.Iss file associated with the
button. The original template remains unaffected.

Note: The file name is displayed on the button, as shown on the Test Basic Mode dialog, so choose a
name that is short and sufficiently descriptive of the action that users know what they are selecting.
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Plug-Ins

Any ActiveX (.ocx) or .NET (.dll) control can be inserted into the oscilloscope process by using the CustomDSO Plug-
In feature. This is especially useful for programs that are written in languages other than VBScript or designed to
interface with other applications, such as Excel or MATLAB.

Plug-ins are launched using whatever custom Windows controls you have included in your program; the plug-in
dialog replaces the Basic Action buttons. This is ideal for non-technical personnel using the oscilloscope for testing
and production: an entire workflow, including feedback controls, can be embedded in your custom dialog.

Programming Plug-Ins
Plug-ins are programmed as oscilloscope application subroutines that access the oscilloscope's COM Automation
interface through VBS processors. The basic structure is:

Private Sub control label action

Dim app as Object

Set app = CreateObject ("LeCroy.XStreamDSO.1")
custom code

End Sub

The control label is whatever you have named the Ul control that will invoke the program, for example, SingleButton.
The action is the user action associated with the control, for example, Click().

Custom code refers to the Automation commands and processors that are invoked when the control is activated, for
example: app.Acquisition.TriggerMode = "Stopped".

So, a very simple plug-in that presents a button to Stop acquisition on the CustomDSO dialog might be:

Private Sub SingleButton Click()

Dim app as Object

Set app = CreateObject ("LeCroy.XStreamDSO.1")
app.Acquisition.TriggerMode = "Stopped"

End Sub

Using ActiveDSO

If your ActiveX plug-in is created with Visual Studio, C Compiler or similar, you will have to register the plug-in. If you
use ActiveDSO as the interface for the CustomeDSO plug-in, you can call the already registered C:\Program Files
(x86)\LeCroy\ActiveDSO\ActiveDS0.ocx as the CustomDSO plug-in. While not required, ActiveDSO is helpful for
creating ActiveX controls for Teledyne LeCroy instruments.

ActiveDSO is available free from the teledynelecroy.com software download page under Oscilloscope > Software
Utilities. See the ActiveDSO Developer's Guide for more information.

Using VB.NET
If you are using Microsoft's VB.NET framework to program your plug-in, see the instructions in our application note,
Plug-ins Using VB.NET.

Installing Plug-Ins

To install plug-ins:
1. Onthe CustomDSO dialog, select Plug-In.

2. Select the COM ProgID of Plug-In field and enter the program ID on the pop-up keyboard.

155


http://teledynelecroy.com/support/softwaredownload
http://teledynelecroy.com/doc/docview.aspx?id=9224
https://teledynelecroy.com/doc/plugins-using-vbnet

HD06000B High Definition Oscilloscopes Operator's Manual

The default plug-in, LeCroy.CustomDSODemo.1, demonstrates plug-in functioning. Install it to see how the
custom dialog is inserted into the oscilloscope's GUI.

3. To keep the plug-in dialog visible on the oscilloscope at all times, check Present CustomDSO menu at
powerup and when menu closed.

4. Select Install.

5. Open the Plug-In n dialog to test your program. Whatever controls you have created for the GUI appear in the
Plugin1 dialog.

To uninstall the plug-in, simply select Remove.

MAUI Browser

The MAUI Browser utility (formerly XStreamBrowser™) enables you to view, copy and modify the COM object
hierarchy of a Windows-based MAUI oscilloscope. It is essential for writing Automation programs, as it always
shows all the Automation objects on the instrument at the exact current configuration—including those objects
belonging to software options.

MAUI Browser is installed on all MAUI oscilloscopes for local browsing. It may also be installed with MAUI Studio on

remote PCs to view a connected oscilloscope's Automation hierarchy.

Caution: The legacy XStreamBrowser available for download on our website is a 32-bit version. Do not
install this on any 64-bit oscilloscopes or PCs. Use only the latest 64-bit MAUI installer to update the
oscilloscope MAUI Browser, or use MAUI Studio to install it on your PC.

Connecting to a Local Oscilloscope
To launch MAUI Browser on the oscilloscope:

1. Choose File->Minimize to display the Windows desktop.

2. Double-click the MAUI Browser icon.

-
3. Selectthe ™ connection icon.

Connecting to a Remote Oscilloscope
1. Be sure the oscilloscope is configured to allow a DCOM connection from the PC.
2. Launch MAUI Browser on the PC.

W
3. Select the ®* connection icon.

4. Enter the network IP Addressof the oscilloscope, then click OK.
§=|| Note: If the oscilloscope application is not running, initiating the connection from the MAUI Browser will

start it; however, it will not power on a device that is powered off. Be sure the oscilloscope is turned on
before connecting.

When the connection to an instrument is established, the MAUI Browser window is populated with the oscilloscope
application object hierarchy.

156



Analysis Tools

Caution: While remote viewing is safe, it is not advisable to use MAUI Browser to change certain settings, in
particular remote control CVARs, over a remote connection. Make these changes locally on the
oscilloscope.

Refreshing the Display

If you change the state of the oscilloscope in any way while connected to MAUI Browser, select the 2l icon to
refresh the object hierarchy. Settings changed on the oscilloscope must be "pulled” into the MAUI Browser display.

Disconnecting
Only one connection may be made at one time. To disconnect, choose File > Close Session.

Use the window closebox or choose File > Exit to close the MAUI Browser application.

Viewing MAUI Objects

The number of different objects in a complete oscilloscope setup is obviously large and changes with the installation
of new firmware and software options. MAUI Browser helps you quickly find the object path and valid values
corresponding to any instrument control.

The object hierarchy exposed by MAUI instruments is rooted at the Application object. This object is always named
LeCroy.XStreamDSO.

All major instrument subsystems are available from this object, and many of these subsystems themselves may be
broken down further. As new software options are activated on the oscilloscope, these subsystems are added to the
Application object hierarchy.

Anything exposed by the object hierarchy can be controlled or read back via Automation.

Object Hierarchy

File Edit Help The left-hand pane of the MAUI Browser window contains an

w2 expandable navigation "tree." The object hierarchy is tiered; for example,
- = the Acquisition subsystem is comprised of a variety of objects, each

ENET L cCroy XStreamDSO] “ | with child objects.

E|[:| Acquisition
-0 Auwdn The right-hand pane shows the Control Variables or Properties related

-8 AuwxOutput to the object selected from the navigation tree.
..D -l

@3 C2

@ G

-3 4

5@ Channels

z@a

: {:l InputB
EI{:l Qut
: @ Result

Control Variables
The majority of the items you will find as you expand the navigation tree are Control Variables, or CVARs for short.
These are shown as yellow folders in the MAUI Browser window.

CVARs provide an interface for accessing scope configurations and for executing methods and actions. When
viewed from MAUI Browser, many CVARs appear to be properties, but are actually objects with properties such as
Name, Value, and Type, to name a few.
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File Edit Help

Sl
=+ LeCroy.XStreamDS0 [+] | Name Value Type Flags / Status  Range / Helpstring &
-3 Acquisition Activelnput Input3 Enum H Input2
a ﬁ”ﬂg AverageSweeps 1 sweep Integer From 1 to 1000000 step 1
g " utput AvisHRatation 45+ Integer From -90 to 90 step 1
B 503 Inpu® AvisYRotation 20° Integer From -90 to 90 step 1
{ E3 Inpu
Cl O\Ijt BandwidthLimit Full Enum Full, 200MHz, 20MHz
& Result CableCompensation false Bool H 0.-1 or false true
@ ClearSweeps Action n/a
aa Coupling DCIM Enum DCS0,Gnd,DCIM ACIM
; Deskew Ops Deuble From -4.5¢-007 to 4 5¢-007 step 1e-012
o
8 Channels EndSamples 1 Integer H From -5000 to 5000 step 1
(23 Horizontal EnhanceResType None Enum None,0.5bits,Lbits,1 Shits, 2bits, 2. Sbits, 3bits
Trigger FindScale Action s -
] 99 B
(23 Cursors || | HorscaleToggle Action n/a
r 99
-3 CustomDSO || | nterpolstion NONE Enum NONE,25INXX SSINXX
(3 DDRA Invert false Bool 0,-1 or false true
(13 Display LabelsPosition String Any number of characters
- ElectricalTelecom LabelsText String Any number of characters
(0 HardCopy OptimizeGroupDelay PulseResponse  Enum H PulseResponse, EyeDiagram,Flatness
-3 Help Overload false Bool R 0,-1 or false true
& History Persist3DQuali Solid Enum WireFrame, Solid, Shaded
03 itk "
itKit
PersistDotloined false Bool 0.-1 or false true
-2 Labhotebook
g N?athu shee Persisted false Bool 0.1 or false true
32 Messure Persistenceld false Bool 0,-1 or false true
& Memory PersistenceMonoChrome  true Bool 0,1 orfalse true L4
PersistenceSaturation 50 Integer From 0 to 100 step 1
-3 MIPIDPHY
L2 MIPIMPHY | || | PersistenceTime 055 Enum Infinite,0.55.15,25,55,105,205
ProbeAttenuation 1.000000 Double From 1e-006 to 10000 step 1e-006
(23 PassFail p
HE3 PowerAnalysis ProbeLabel String H Any number of characters
(1 Preferences RescaleLabel y=1x+0V String R Any number of characters
(22 ProbesCal SegmentMode Adjacent Enum Adjacent Overlay, Waterfall Perspective Mosaic
(23 SaveRecall ShowLastTrace false Bool 0,-1 or false true
3 spa2 StartSamples 1 Integer H From -5000 to 5000 step 1
-] SerialDecode [ =] | statSegment 1 Integer From 1 to 100000 step 1 -

app.Acquisition.C1

CVAR properties shown in the right-hand pane of MAUI Browser window.

The Range/Helpstring column provides short form information about the possible values the variable can take.

The Flags/Status column contains coded information about the object.

Flag/Status Indicates

R For CVARs: Read only.
For Properties: Readable.
W For CVARs: Wrapping, incrementing the value will "wrap around" from max. to min., or vice versa.
For Properties: Writable.
Hidden: not visible on any GUI dialog or menu.
Grey: appears "greyed out" on GUI indicating it is
disabled or not settable.
B Backwards: incrementing the CVAR value will decrease the value.
N Nonvolatile: value is saved in the application's "nonvolatile” settings file. These CVARSs are typically user pref-
erences and are not affected by Recall Default Setup.
A AutoRepeat: the CVAR action should be repeated if a button on the GUI is held down.
M MultiLine: the CVAR value may be rendered on
multiple lines of the GUI.
L LateUpdate: the CVAR value may be updated when it is read/refreshed.

Actions and Methods
Besides the configuration CVARs, Automation also provides for Actions that may be applied at the application or

subsystem level.

For example, to clear sweeps for all subsystems, the Automation command would be:

app.ClearSweeps

Methods are similar to Actions but may take parameters from the caller and may possibly return a value, whereas,
Actions do not support any parameters or return values. An example of a Method is app.Acquisition.Acquire, which
takes both "timeout" and "force trigger" arguments.
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Result Interfaces

The grey folders are Result Interfaces. Result Interfaces contain more than just the basic results of oscilloscope
operations, such as waveform data and measurement values; they include information about horizontal and vertical
resolution, event times, number of sweeps, histogram peaks, etc. The Type column of the MAUI Browser window
shows the result interface type.

Collections

Collections, which are shown as pink folders in MAUI Browser, contain sets of similar objects. For example, the
app.Acquisition.Channels collection contains input channel objects (C1, C2, etc.). Objects in Collections folders are
dynamically linked to those in the yellow folders; changing the value in either place changes it everywhere. Collection
subfolders are referenced by indexing the collection name with the subfolder name.

Copying from MAUI Browser
When a variable is selected from the right-hand pane, the message bar at the bottom of the screen shows the full
object path in correct notation for sending as an Automation command:

AxisYRotation 0° Integer From -90 to 90 step 1
BandwidthLimit Full Enum Full, 200MHz, 20MHz
CableCompensation false Bool H 0,-1 or false true
ClearSweeps Action n/a
Coupling DC1M Enum DC50,Gnd, DCIM, ACLM
Deskew 0ps Double From -4.5e-007 to 4.5e-007 step 1e-012
EndSamples 1 Integer H From -5000 te 5000 step 1
EnhanceResType Mone Enum Mone,0.5bits, 1bits 1.5bits, 2bits, 2. 5bits, 3bits
£|| | FindScale Action n/a
Hor5caleToggle Action n/a
Interpelation MNOME Enum MNOME, 25IMXK SSINK
Invert false Bool 0,-1 or false true
LabelsPosition String Any number of characters
LabelsText String Any number of characters
OptirnizeGroupDelay PulseResponse  Enum H PulseResponse EyeDiagram,Flatness
Overload false Bool R 0,-1 or false true
Persist3DQuality Solid Enum WireFrame, Solid,Shaded
PersistDotloined false Bool 0,-1 orfalse true
Persisted false Bool 0,-1 orfalse true
Persistencedd false Bool 0,-1 or false true
| | PersistenceMonoChrome  true Bool 0,-1 or false true
PersistenceSaturation 50 Integer From 0 to 100 step 1
PersistenceTime 0.5z Enum Infinite,0.55,15,25 55,105,205
ProbeAttenuation 1.000000 Double From 1e-006 to 10000 step 1e-006
Probelabel String H Any number of characters
Rescalelabel y=1x+ 0V String R Any number of characters
SegmentMode Adjacent Enum Adjacent, Overlay, Waterfall,Perspective Mosaic
ShowlastTrace false Bool 0,-1 orfalse true
StartSamples 1 Integer H From -5000 to 5000 step 1
~ | | StartSegment 1 Integer From 1 to 100000 step 1

app.Acquisition.C1 BandwidthLimit g

Right-click and choose Copy Path. The text is automatically placed in the clipboard, from where it can be easily
copied into Automation programs.
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File Edit Help

=1 XStream Browser - Online, browsing LeCroy.XStrea [E=8r=] ™

w0

=21 LeCroy.XStreamDSQ
| (-0 Acquisition

| 02 Awdn

A1 AuxOutput
oB3a

3 InputB
{3 Out
|

e

W23 cu

-8 Channels

1 Horizontal
(2 Trigger
3 Cursors

-1 CustomDSQ
{3 DDRA

{3 Display

- ElectricalTelecom
-2 HardCopy
{3 Help

2 History

- JitKit

{3 LsbNotebook
{23 Math

-3 Measure

-1 Memory

{3 MIPIDPHY
-2 MIPIMPHY
- PassFail

[ PowerAnalysis

Name
Activelnput
AverageSweeps
AxisXRotation
AxisVRotation
BandwidthLimit
CableCompensation
ClearSweeps
Coupling

Deskew
EndSamples
EnhanceResType
FindScale
HorScaleToggle
Interpolation

Invert
LabelsPosition
LabelsText
OptimizeGroupDelay
Overload
Persist3DQuality
PersistDotloined
Persisted
Persistence3d
PersistenceMonaChrome
PersistenceSaturation
PersistenceTime
ProbeAttenuation
Probelabel

RescaleLabel
SegmentMode
ShowlastTrace
StartSamples
StartSegment

Copy Path...
Refresh..

Set Value...

Enum::Full
Enum::200MHz
Enum::20MHz

NONE

false

PulscResponse
false

Solid

false

false

false

true

50

0355

1000000

y=lx+0V
Adjecent
false

1

1

Type
Enum

Integer
Integer

Integer

Enum
Bool
String
String
Enum
Bool
Enum
Bool
Bool
Bool
Baol
Integer
Enum
Double
String
String
Enum
Bool
Integer
Integer

Flags / Status
H

Range / Helpstring
Inputd

From 1 to 1000000 step 1

From -00 to 90 step 1

From -90 to 90 step 1

Full, 200MHz, 20MHz

0,1 or false true

nfa

DCS0,Gnd,DCIMACLM

From -4.5¢-007 to 4.56-007 step 1e-012
From -5000 te 5000 step 1
None,0.5bits 1 bits,1.5bits, 2bits,2.5bits, 3bits
n/a

nz

NOME, 25INXK, SSINXX

0,1 or false true

Any number of characters

Any number of characters
PulscRespense, EyeDiagram, Flatness
0,1 or false true

WireFrame Solid,Shaded

0,-1 or false true

0,1 or false true

0,1 or false true

0,-1 or false true

From 0 to100 step 1
Infinite,0.55,15,25,55,105,20s

From 1e-006 to 10000 step 1e-006

Any number of characters

Any number of characters

Adjacent, Overlay, Waterfall, Perspective, Mosaic
0,1 or false true

From -5000 to 5000 step 1

From 1 to 100000 step 1

m

Copy the contents of the current path buffer.
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Save/Recall Data (File Menu)

The File menu functions allow you to save and recall acquisition setups, waveform data and table data, or to
generate screen captures, LabNotebooks, and reports of acquisitions. You can use Print or E-mail to share these
files.

Save

Oscilloscope setups (configurations), waveform data, tabular data, and the display can all be saved in multiple
formats.To save them all as a composite LabNotebook file, see Save LabNotebook.

Note: We strongly recommend that you stop acquisition before saving waveforms or LabNotebooks,
especially when running in Auto trigger mode. If you do not first stop, there is no guarantee that what you
are capturing is what you want to save.

Save Waveform

The Save Waveform function saves trace data either to internal memory (M1-Mn) or to a file in text or binary format.
The source waveform can be any type of trace; a channel, math function, zoom, or even another memory. Waveform
files can be recalled into an internal memory, from where they can be restored to the display.

Note: Only traces saved in Teledyne LeCroy proprietary formats can be recalled to the display directly. Use
the Binary format (.trc) for analog waveforms, or WaveML (.xml) for digital waveforms. Other waveform
types must be recalled into memory before being displayed.

Save Waveform To Memory

Save Recall Report Generator File Sharing Print Auto Save Email & Report Settings

= nn

LabMotebook Waveform i g 57:19 PM

B - Memory: 7 15:00:35 PM
Setup

Screen Image

1. From the menu bar, choose File > Save Waveform.

2. Choose to Save To Memory.

3. Choose the Source trace you are saving.

4. Optionally, select Show On Save to display the memory trace with its source as soon as it is saved.

5. Touch the Save button directly to the left of the selected Destination memory slot. The date/time stamp of
the saved memory will appear at that location.
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Save Waveform To File

Save Recall Report Generator File Sharing Print Auto Save Email & Report Settings

San

Ca nn

LabNotebook Waveform i

Earar Save Now
B ] Memory S
Setup Table N

o [}
L] File S
Screen Image All Displayed

1. From the menu bar, choose File > Save Waveform.
2. Choose to Save To File.

3. Choose the Source waveform. To quickly save all displayed waveforms separate trace files, touch the All
Displayed button.

4. Select a file Format. Binary is Teledyne LeCroy's .trc file format. Binary results in the smallest possible file
size. Binary files can be converted to ASCII using Teledye LeCroy utilities such as WaveStudio. WaveML is a
proprietary .xml format used to save persistence maps, eye diagrams, histograms, and digital traces. This
option is only active if the source is compatible.

5. If your Format is ASCII, touch Delimiter and select a character from the pop-up menu.

6. Depending on your Format selection, you may also need to specify a SubFormat:
» Word (Binary) represents samples using 16 bits. Always use this unless Byte mode is "pre."
 Byte (Binary) represents samples using 8 bits. This option can result in a loss of resolution.
 Auto (Binary) looks at the data and automatically selects either Word or Byte subformat.
« Amplitude only (Text) includes amplitude data for each sample, but not time data.
» Time and Amplitude (Text) includes both types of data for each sample.
» With Header (Text) includes a file header with scaling information.

7. The system will auto name the file <Source>-Trace-<Counter>. To change the file name or Selected Folder,
enter the full path and name in File, or use the File Browser. By default, trace files are saved to D:\Waveforms
on the instrument hard drive.

8. If you do not want to use the Source prefix or Counter number, deselect them.

9. Touch Save Now.
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Save Setup

You can quickly save oscilloscope configurations to one of the internal setup panels or to a LeCroy System Setup
(Iss) file, a text-based Automation program. Setups can be easily recalled to restore the oscilloscope to the saved
state.

Save Setup to Memory

r File Sharing Print Auto Save Email

= nn

LabNotebook Waveform i

- - Memory| Sel -2 3 Setup5 - Empty
Setup 5 Save -
L Setupb - Empty

Save Panel6

Screen Image

1. From the menu bar, choose File > Save Setup.
2. Choose to Save To Memory.

3. If desired, touch one of the Setup slots and enter a name for the memory. The default name will be Paneln.
Try to select an empty slot, as anything currently in it will be overwritten.

4. Touch the Save button directly to the left of the selected Setup slot. The save date/time is displayed above
the Setup field.

Save Setup to File

Report Ge File Sharing Print Auto Save Email & Report Settings
™) n
LabNotebook Waveform - i
Ide

k- Y

Setup

Save Now

Screen Image

1. From the menu bar, choose File > Save Setup.
2. Choose to Save To File.

3. Tochange the file name or Selected Folder, enter the full path and name in File, or use the File Browser. By
default, setup files are saved to D:\Setups on the instrument hard drive.

4. If you do not want to use the Counter number, deselect it.

5. Touch Save Now.
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Save Table
The Save Table function saves tabular measurement data displayed on screen to an Excel or ASCI file.

Save Recall Report Generator File Sharing Print Aut Email & Report Settings

Ca nn : i ) 7 CAN Browse
LabNotebook Waveform uto N Save Now
o Fol / \

B - - ,_ C:\ ream\Tables\
Setup
P Last Saved Table File

Screehr}‘\‘mage All Displayed

1. From the menu bar, choose File > Save, then choose Table.
2. Tosave only one of the tables displayed, touch Source and navigate to the selection.

By default, data from all visible tables are saved to separate files. To quickly restore this selection, touch the
All Displayed button.

3. Choose a format of ASCII (.txt) or Excel (.csv). If you selected ASCII format, also touch Delimiter and choose a
character.

4. The system will auto name the file "<source>-Table-<counter>". To change the file name or Selected Folder,
enter the full path and name in File, or use the File Browser. By default, table files are saved to D:\Tables on

the instrument hard drive.

5. If you do not want to use the Source or Counter number, deselect them.

6. Touch Save Now.
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Save Screen Image

The full touch screen display or selected portions of it can be captured, saved to an image file, and marked with
custom annotations.

Save Recall Report Generator File Sharing Print Auto Save Email & Report Settings

Cim nn
LabNotebook Waveform
Save Now
i L DSO Window
Setup
oo Standard
Print colors use a white background

Screen Image

1. From the menu bar, choose File > Save, then choose Screen Image.
2. Choose a File Format of .JPEG, .PNG, .TIF, or .BMP.
3. To mark up the screen image using the drawing tools, select Annotate Screen Image Before Saving.
4. Select the Screen Area captured:
 Grid Area Only includes any visible waveform grids, tables, and descriptor boxes.
e DSO Window includes the above plus any open dialogs, menu bar, and message bar.
» Full Screen is the full Windows display, including other visible applications and desktop.
5. Choose the Colors used in the capture:
» Standard uses the screen colors on a black background as it appears on the instrument.

* Print (default) uses your print color palette (set in Preferences) on a white background to save ink.

e Black & White captures the image in grayscale.

6. To change the file name or Selected Folder, enter the full path and name in File, or use the File Browser. By
default, image files are saved to D:\Hardcopy on the instrument hard drive.

7. Touch Save Now.

8. If you've turned on annotations, use the Drawing toolbar to mark up the screen image. Click Done when
finished.
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Auto Save

Data that appears on the oscilloscope display, such as waveforms, measurement readouts and decoder data, can be
very dynamic and difficult to read from the oscilloscope unless you stop the acquisition.

Auto Save enables you to automatically store waveform and table data to file with each new trigger. The file can later
be recalled to the oscilloscope or saved permanently to external storage.

Report Generator File Sharing Print Auto Save Email & Report Settings

s\WWySavedTable—00000 txt

1. Choose File > Save and open the Auto Save dialog.
2. Select to save Waveforms and/or Tables.

3. Select the Source from which to save. The All Displayed selection will create a separate file for each trace or
table displayed.

4. By default, waveform files are stored in D:\Waveforms and tables are stored in D:\Tables on the instrument
hard drive. Optionally:

» Enter a different root path and name in File.
» Touch Browse to open the File Browser and add or remove the source prefix and counter suffix.

5. Choose one of the Auto Save options: Wrap (old files overwritten when buffer filled) or Fill (no files
overwritten, excess is truncated).

Tip: If you have frequent triggers, it is possible you will eventually run out of storage space. Choose
Wrap only if you're not concerned about files persisting on the instrument. If you choose Fill, plan to
periodically delete or move files off the instrument, or you will lose new data.

6. To confirm these selections, choose Configure Auto Save from the pop-up dialog that appears.

7. Assoon as there is a trigger, files will begin to be saved. Choose Disable Auto Save from the pop-up to stop
saving files while the acquisition is in process.

You can also choose Off on the Auto Save dialog to disable this feature in between acquisitions.
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Waveform File Format

By default, the oscilloscope saves waveform data as binary files (.trc). The properties of the trace file are shown by
the waveform descriptor block, which appears immediately after the file header. The waveform descriptor is the key
to understanding the data that follows.

There are two waveform file formats and waveform descriptors currently in use:

» WAVEDESC1 defines the waveform file format that has been used since the introduction of 64-bit LeCroy
DSOs. This describes all waveform files that are <2 GB in length.

» WAVEDESC?2 defines the extended trace file format that was introduced with the long memory HD
oscilloscopes. This descriptor appears only in >2 GB waveform files in a second section of the file following the
variables described by WAVEDESC1.

When an acquisition is >2 GB, the TRIGTIME_2, DATA_ARRAY_3 and DATA_ARRAY_4 blocks (all defined in
WAVEDESC?2) contain the balance of the waveform data that does not fit into the legacy format. To export the
complete waveform to other programs, the data in these blocks should be appended to the data in TRIGTIME,
DATA_ARRAY_1 and DATA_ARRAY_2, according to the properties that will appear in the WAVEDESC1 and
WAVEDESC?2.

Waveform File Format

Section Block ID Type Size Description
1: Legacy file format #Nnnnnnnnnnn Header 11-17 The special character '#'; then one Hexadecimal
digit N (0-9, A-F); then N decimal digits that denote
Only this section is used the positive integer size of this section. The number
when the waveform size of digits 'nnnnnnnnnn’ is equal to N, representing
is the block size of Section 1.
=2CB. WAVEDESC1 Block 344 Waveform descriptor of primary section. See table
If the waveform size is > below for a definition of its components.
2 GB, this section of the USERTEXT Block variable |User defined text.
file contains all data up TRIGTIME Trigger variable | Thetotal size is defined in
t02GB. Time Array WAVEDESC1 > TRIGTIME_ARRAY.
Each trigger time element is defined as:
The WAVEDESC1 block {double TRIGGER_TIME;
describes the properties double TRIGGER_OFFSET}
of this part of the - —— - -
waveform. RISTIME Double variable | The total size is defined in
Array WAVEDESC1T > RIS_TIME_ARRAY.
The type of each element is double.
DATA_ARRAY_1 Array variable | The total size is defined in

WAVEDESC1 > WAVE_ARRAY_1.
The data format is defined in

WAVEDESC1 > COMM_TYPE.

DATA_ARRAY_2 Array variable | The total size is defined in

WAVEDESC1 > WAVE_ARRAY_2.
The data format is defined in

WAVEDESC1 > COMM_TYPE.
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Section Block ID Type Size Description

2: Extended file format #Nnnnnnnnnnn Header 11-17 The special character '#'; then one Hexadecimal
o digit N (0-9, A-F); then N decimal digits that denote

If the waveform sizeis > the positive integer size of this section. The number

2 GB, this section of the of digits 'nnnnnnnnnn’ is equal to N, representing

file contains all data > 2 the block size of Section 2.

GB. WAVEDESC?2 Block 672 Waveform descriptor of extended section. Note:

The WAVEDESC? block Parts of this block replace equivalent parts of

describes the properties WAVEDESCT; see WAVEDESC2 below.

of this part of the USERTEXT Block variable |User defined text.
waveform. TRIGTIME_?2 Trigger variable | The total size is defined in
Time Array WAVEDESC?2 > TRIGTIME_ARRAY.

Each trigger time element is defined as:
{double TRIGGER_TIME;
double TRIGGER_OFFSET}

RISTIME Double variable | The total size is defined in
Array WAVEDESC?2 > RIS_TIME_ARRAY.
The type of each element is double.
DATA_ARRAY_3 Array variable | The data in this block follows DATA_ARRAY_1. To

get the full waveform, DATA_ARRAY_1 and DATA_
ARRAY_3 must be combined.
The total size is defined in

WAVEDESC1 > WAVE_ARRAY_3.
The data format is defined in

WAVEDESC1 > COMM_TYPE.

DATA_ARRAY_4 Array variable | The data in this block follows DATA_ARRAY_2. To
get the full waveform, DATA_ARRAY_2 and DATA_
ARRAY_4 must be combined.

The total size is defined in

WAVEDESC2 > WAVE_ARRAY_4.
The data format is defined in

WAVEDESC2 > COMM_TYPE.

WAVEDESC1
Size (Bytes) Variable Name Description

0 16 string DESCRIPTOR_NAME Will contain "WAVEDESC"

16 16 string TEMPLATE_NAME Name of the template

32 2 short COMM_TYPE Data format: O = byte; 1 = word

34 2 short COMM_ORDER Data order: 0 = Hi First; T = Lo First
The following variables specify the lengths of all blocks of which the entire waveform (as it is currently being read) is composed.
If a block length is zero, that block is (currently) not present. Blocks and arrays that are present will be found in the same order
as shown below.

36 4 long WAVE_DESC_LENGTH Length in bytes of WAVEDESCT block

40 4 long USER_TEXT_LENGTH Length in bytes of USERTEXT block

44 4 long RES_DESCT Reserved

48 4 long TRIG_TIME_ARRAY Length in bytes of TRIGTIME array

52 4 long RIS_TIME_ARRAY Length in bytes of RISTIME array

56 4 long RES_ARRAY_1 Reserved

60 4 long WAVE_ARRAY_1 Length in bytes of first simple data array

64 4 long WAVE_ARRAY_2 Length in bytes of second simple data array

68 4 long RES_ARRAY_2 Reserved

72 4 long RES_ARRAY_3 Reserved
The following variables identify the instrument.

76 16 string INSTRUMENT_NAME
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Size (Bytes)

Variable Name

Description

92 4 ULONG INSTRUMENT_NUMBER
96 16 string TRACE_LABEL Waveform identifier
112 4 long RESERVED_DATA_COUNT Reserved

The following variables describe the waveform type and the time at which

the waveform was generated.

116 4 long WAVE_ARRAY_COUNT Number of data points in a data array. If there are
two arrays (e.g., FFT or Extrema waveform), this num-
ber applies to each array separately.

120 4 long POINTS_PER_SCREEN Nominal number of data points on the screen

124 4 long FIRST_VALID Number of points to skip before first good point.
FIRST_VALID_POINT=0 for normal waveforms.

128 4 long LAST_VALID Index of last good data point in record before pad-
ding (blanking) was started. LAST_VALID_POINT =
WAVE_ARRAY_COUNT -1 except for aborted
Sequence and Roll Mode acquisitions.

132 4 long FIRST_POINT Indicates the data offset relative to the beginning of
the trace buffer

136 4 long SPARSING_FACTOR Indicates the sparsing into data block

140 4 long SEGMENT_NO For Sequence waveforms, index of the segment

144 4 long SUBARRAY_COUNT For Sequence waveforms, acquired segment count,
between 0 and NOM_SUBARRAY_COUNT

148 4 long SWEEPS _PER_ACQ For Average or Extrema waveforms, number of
sweeps accumulated, else 1

152 2 short POINTS_PER_PAIR For Peak Dectect waveforms (which always include
data points in DATA_ARRAY_1 and min/max pairs in
DATA_ARRAY_2), the number of data points for each
min/max pair

154 2 short PAIR_OFFSET For Peak Dectect waveforms, the number of data
points by which the first min/max pair in DATA_
ARRAY_2 is offset relative to the first data value in
DATA_ARRAY_T

156 4 float VERTICAL_GAIN Total gain of waveform, units per Isb

160 4 float VERTICAL_OFFSET Total vertical offset of waveform. To get floating val-
ues from raw data:

VERTICAL_GAIN * data - VERTICAL_OFFSET

164 4 float MAX_VALUE Maximum allowed value; corresponds to the upper
edge of the grid

168 4 float MIN_VALUE Minimum allowed value; corresponds to the lower
edge of the grid

172 2 short NOMINAL_BITS Intrinsic precision of the observation

174 2 short NOM_SUBARRAY_COUNT For Sequence waveforms, nominal segment count,
else 1

176 4 float HORIZONTAL_INTERVAL Sampling interval, the nominal time between suc-
cessive points in the data

180 8 double |HORIZONTAL_OFFSET Trigger offset in time domain for zero'th sweep of trig-
ger, measured as seconds from trigger to zero'th
data point (i.e., actual trigger delay)

188 8 double  |PIXEL_OFFSET Time from trigger to zero'th pixel of display segment
in time domain, measured in seconds (i.e., nominal
trigger delay)

196 48 string VERTUNIT Vertical axis unit

244 48 string HORUNIT Horizontal axis unit

292 4 float HORIZ_UNCERTAINTY Uncertainty from one acquisition to the next, of the

horizontal offset in seconds

169



HD06000B High Definition Oscilloscopes Operator's Manual

Size (Bytes) Variable Name Description

296 16 structure |TRIGGER_TIME Time of the trigger, listed in the structure: double
seconds; char minutes; char hours; char days; char
months; short year; short dummy

312 4 float ACQ_DURATION Duration of the acquisition (in sec) for multi-trigger
waveforms (e.g., Sequence, RIS and Average)

316 2 short CA_RECORD_TYPE Type of waveform

318 2 short PROCESSING_DONE Indication of any processing done. 0 = no processing;

1 = firfilter; 2 = interpolated; 3 = sparsed; 4 = auto-
scaled; 5 = noresult; 6 = rolling; 7 = cumulative.

320 2 short RESERVEDS

322 2 short RIS_SWEEPS For RIS acquisitions, number of sweeps from which
waveform is calculated, else 1

**The information below is based on the legacy enumeration list. It may not be valid for newer oscilloscope models.

324 2 short TIME_BASE Enumerated time/div **
326 2 short VERTICAL_COUPLING Enumerated channel coupling value
328 4 float PROBE_ATTENUATION Probe attenuation value
332 2 short FIXED_VERTICAL_GAIN Enumerated vertical gain **
334 2 short BAND_WIDTH_LIMIT
336 4 float VERTICAL_VERNIER
340 4 float ACQ_VERTICAL_OFFSET
344 2 short WAVE_SOURCE Waveform source input
WAVEDESC2
Size (Bytes) Variable Name Description

0 16 string DESCRIPTOR_NAME Will contain "BLOCK2"

16 16 string TEMPLATE_NAME Name of the template

32 16 string VERSION

The following variables specify the lengths of all blocks of which the entire waveform (as it is currently being read) is composed.
If a block length is zero, that block is (currently) not present. Blocks and arrays that are present will be found in the same order
as shown below.

48 8 int64 WAVE_DESC_LENGTH_2 Length in bytes of WAVEDESC?2 block

56 8 int64 TRIG_TIME_ARRAY Length in bytes of TRIGTIME_2 array

64 8 int64 WAVE_ARRAY_3 Length in bytes of data array 3

72 8 int64 WAVE_ARRAY_4 Length in bytes of data array 4

80 8 int64 WAVE_ARRAY_COUNT Number of data points in each data array. If there are
two data arrays (e.g., FFT or Extrema), this number
applies to each array separately.

96 8 int64 FIRST_VALID Number of points to skip before first good point.
FIRST_VALID_POINT = 0 for normal waveforms.

104 8 int64 LAST_VALID Index of last good data point in record before pad-

ding (blanking) was started. LAST_VALID_POINT =
WAVE_ARRAY_COUNT -1 except for aborted
Sequence and Roll Mode acquisitions.

The following variables describe waveform properties of all data in file sections 1 and 2. These values replace equivalents in
WAVEDESC1.

88 8 int64 POINTS_PER_SCREEN Nominal number of data points on the screen

112 8 int64 FIRST_POINT Indicates the data offset relative to the beginning of
the trace buffer

120 8 int64 SPARSING_FACTOR Indicates the sparsing into data block

128 8 inte4 SEGMENT_NO For Sequence waveforms, index of the segment
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Size (Bytes) Variable Name Description

136 4 int SUBARRAY_COUNT For Sequence waveforms, acquired segment count,
between 0 and NOM_SUBARRAY_COUNT

140 8 inte4 SWEEPS _PER_ACQ For Average or Extrema waveforms, number of
sweeps accumulated, else 1

148 4 int NOM_SUBARRAY_COUNT For Sequence waveforms, nominal segment count,
else 1

152 8 double |HORIZONTAL_OFFSET Trigger offset in time domain for zero'th sweep of trig-
ger, measured as seconds from trigger to zero'th
data point (i.e., actual trigger delay)

160 512 bytes[512] |RESERVED Reserved for future use

Recall

Setups saved to internal memory or to .LSS file can be recalled to restore the oscilloscope to the saved state.

Waveform data stored in Teledyne LeCroy binary (.trc) or WaveML (.xml) format can be recalled directly to the
display. Waveform data stored in other binary or ASCI! file formats can be recalled into a memory and from there
displayed.

To recall and modify saved LabNotebook files, see Recall LabNotebook.

Recall Waveform

Note: Only files saved in Teledyne LeCroy binary (.trc) or WaveML (.xml) format can be recalled directly to
the display.

Recall Report Generator File Sharing Print Auto Save Email & Report Settings

v Digital1-00000_XMLdig Browse
: i

LabMNotebook E—
&-nn

v A

nn = Recall Now

Waveform

&

Setup

1. Choose File > Recall Waveform from the menu bar to open the Recall dialog.
2. Touch Browse and navigate to the file.

If the file is in the Selected Folder, you can use the Up /Down Arrows to cycle through the available files until
the desired file is selected.

Optionally, touch Show Only Files to filter the list by file type.
3. Select a Destination memory slot into which to recall the file.
4. Mark Show on Recall to display the trace on the grid.

5. Touch Recall Now.
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Recall Setup

Choose File > Recall Setup... from the menu bar.

Recall Setup from Memory

Recall Report Generator File Sharing Print Auto Save Email & R

From

i

LabMNotebook i

Recall

nn Wemory Recall S 201813 = e W Recall Mow
Waveform N )

é y 5 - Empty

Recall Recall | p. .,
Setup Panel6

1. Onthe Recall dialog, select Setup.
2. Choose to Recall From Memory.

3. Select one of the six Recall buttons under Recall From Internal Setup....

Note: If a setup has been stored to a location, it is labeled with the save date/time. Otherwise, the slot is
labeled Empty.

Recall Setup from File

or File Sharing Print Auto Save Email & Report Settings Q CLOSE
Recall From Recall File Recall Default
J:l [y W S5 Browse
LabNotebook : Folde L]
v A

nn Memory' N Recall Now Recall Now
Waveform

A"
a

&

Setup

1. On the Recall dialog, select Setup.
2. Choose to Recall From File.
3. Enter the path to the File, or touch Browse and navigate to the desired file.

If the file is in the Selected Folder, you can use the Up /Down Arrows to cycle through the available files until
the desired file is selected.

4. Under Recall File, touch Recall Now.

Recall Default Setup
The front panel Default Setup button restores all the volatile setups to the factory default state.

You can also restore default settings via the touch screen. Choose File > Recall Setup from the menu bar and under
Recall Default select Recall Now.
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LabNotebook

LabNotebook is Teledyne LeCroy's proprietary tool for capturing a composite file containing waveform data,
oscilloscope setups and display, which can be output to a preformatted report.

The LabNotebook feature allows you to create and save composite files containing a screen capture of all displayed

waveforms, as well as all waveform and setup data at the time of capture. The Flashback feature instantly recalls the
setups and waveforms stored with LabNotebook Entries, enabling you to restore the exact state of the instrument at
a later date to perform additional analysis.

LabNotebooks saved on oscilloscopes running MAUI firmware v.9.5.x.x. and later will also support enhanced
LabNotebook features, recalling the source oscilloscope's model type and software options when recalled in MAUI
Studio Pro.

LabNotebooks can be output to a preformatted .PDF, .RTF, or . HTML report.

Save LabNotebook

All LabNotebook files (LNB) are composed of a screen image (.PNG), a setup file (LSS), and a waveform file ( TRC)
for each waveform displayed. When creating LabNotebooks, you choose how to handle the screen image
component, which is the basis for the Report Generator output, and to which you can add a description and other
hand-drawn annotations.

Note: We strongly recommend that you stop acquisition before saving LabNotebooks, especially when
running in Auto trigger mode. If you do not first stop, there is no guarantee that what you are capturing is
what you want to save.

Save Recall Report Generator File Shari Print Auto Save Email & Report S

tion ok
|:h ihih Browse

LabMotebook Waveform Digital Power Auto Namin

Be ™ \LabNotebook! Save Now
Setup Table

Last Saved LabNotebook Eniry
Area [ Color

e Preferences
Screen Image

1. Choose File > Save LabNotebook from the menu bar.
2. Optionally, enter a Description. This text appears whenever the file is recalled and on reports.
3. Tomark up the image using the drawing tools, select Annotate Screen Image Before Saving.

To skip this step, deselect the checkbox. You can recall the LabNotebook later to add a description and
annotations.

4. To change the area of the screen captured and the colors used, touch Area/Color Preferences and make your
selections on the pop-up. Touch Close to save your changes.

» Use Print Colors (default) uses your print color palette (set in Preferences) on a white background to
save ink. Deselect this to capture the display using a black background as it appears on the instrument.

» Grid Area Only includes any visible waveform grids, tables, and descriptor boxes.
e DSO Window includes the above plus any open dialogs, menu bar, and message bar.

» Full Screen is the full Windows display, including other visible applications and wallpaper.
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5. The system will auto name the file "MyLabNotebook" followed by a counter number. To change this to
something more descriptive, enter the name in LabNotebook Entry, or touch Browse and use the File Browser.

Note: Changing the file path, name or format resets the counter to the next number in that sequence.

6. If you do not want to use autonumbering to identify files, deselect Counter.
7. Touch Save Now.

8. If annotating, use the Drawing toolbar to mark up the screen image. Click Done when finished.

LabNotebook Drawing Toolbar

The basic LabNotebook is a screen capture of the display as it was at the time of entry, along with the setup and
waveform data. If you have selected to Annotate Screen Image Before Saving, the capture is immediately displayed
in the Drawing window. You can later add Annotations by recalling the LabNotebook into the Preview window and
choosing to Annotate Screen Image.

Markup tools are available from the toolbar along the top of the window.

Too \ O /‘ ( - More

[l File | ¥ Vertical |+ Timebase | I Trigger | & Display | # C rs | Bl Measure @ Math | =2 Analys s | @ Support

. H

Enter label text Drag the dotted
box to move the
callout.

To use any tool, touch the icon, then touch on the image where you wish to draw or add text. From left to right, the
tools are:

Tool Function

Pencil Draw in freehand. Maintain contact with the screen to make a continuous mark. Once you release, you
can touch-and-drag the object to any point on the image.

Circle Draw a circle around a waveform feature that you want to emphasize. Touch-and-drag across the dia-
meter of the circle. When you release, the circle is placed. You can drag the circle to any location on the
image.

Arrow Draw lines with arrowheads for placing callouts. You can rotate these lines through 360 degrees or
drag them to any location on the image.

Text Open a textbox for placing labels/annotations on the image. Touch the point on the image to place the

label, then enter the text in the pop-up dialog. Once placed, you can resize the textbox or drag it to any
location on the image.

RGB Selectors Quickly change the line color. Just touch the color icon, then choose the next drawing tool.

More Activates a Custom line color field. The default color is Yellow. To choose another, touch the color
swatch, then select from the Color dialog. You can enter RGB values, or choose from the spectrum.
After saving, the new color appears in the Custom field. This remains the markup color until you
choose another.

Erase / Erase All Remove selected drawing objects. Erase All will also undo any Custom color selection.
Undo Cancel the last action. Use it to restore any objects you inadvertently erased.
Move Undock the drawing toolbar so you can move it anywhere on the display. This helps to keep tools

handy when working on a particular area of a waveform. Touch the button again to restore the toolbar
to the top of the Drawing window.

Done Save the annotations with the image and close the Drawing window.
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Recall LabNotebook

Once a LabNotebook Entry is saved, you can either:

 Recall the screen image to view/modify the description, or manage attachments and component files.

» Flashback to restore the oscilloscope application to the state saved in the LabNotebook file. If you are using
MAUI Studio Pro, this will change the configuration to that of the oscilloscope on which the LabNotebook file
was saved, including all its installed software options.

Note: LabNotebooks saved in the legacy .ZIP format do not support MAUI Studio Pro enhanced
LabNotebook features. The file must have been created in the new .LNB format using either MAUI Studio
Pro, or MAUI firmware v.9.5.x.x or later.

Choose File > Recall LabNotebook from the menu bar. The last selected file will open in the Preview window.

Recall Report Generator File Sharing Print

- ent Management
(2 abM 00001 Inb e
LabMNotebook

‘ebook

nn v A ok
sk tes Flashback

Waveform Mask test

View

a On / Off

Setup

Edit Description
You can modify the description and annotations saved with the LabNotebook Entry. Setups and waveform data
originally saved with the LabNotebook cannot be changed.

1. Browse to and select the LabNotebook Entry.

2. Select View On/Off to preview the file.

3. From the top of the preview window, choose Edit Description.

4. Touch the pop-up description to open the virtual keyboard and edit the text.

5. Touch OK twice to save changes.

Annotate Screen Image
1. Browse to and select the LabNotebook Entry.
2. Select View On/Off to preview the file.
3. From the top of the preview window, choose Annotate Screen Image and use the drawing tools.

4. Click Done when finished to close the Drawing window and return to the preview.

Manage Attachments
To append external files to the LabNotebook composite (such as images of the DUT, mask files, test scripts, etc.):

1. Browse to and select the LabNotebook Entry.
2. Select View On/Off to preview the file.

3. From the top of the preview window, choose Manage Attachments and select the files to attach. The file list
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will build in the lower part of the File Attachments browser.
4. Click Update Attachments to finish.

To later remove appended files, click Manage Attachments and deselect the files from the list. Update Attachments
again to refresh the list.

Convert File Format
Individual entries in legacy .ZIP format Notebooks can be converted to the new LabNotebook file format.
1. Inthe LabNotebook Entry field, Browse to and select the legacy .zip file from the File Browser.
Note: Be sure to select the .zip file from the left side navigation pane so that its sub-entries appear in
the right pane, the Save buttons are active, and the file name appears in Current Path.
2. Tobatch convert all into separate LabNotebooks, on the file browser choose Save All As LNB Files.
To convert a single entry, select it from the Name list (right side), then choose Save As LNB File.

New LabNotebooks of the same name as the original entries are created in the D:\XPort folder. These can be
selected the same as any other .LNB files for Flashback, editing, reports, or extraction.

Extract Files

The component files that make up the LabNotebook composite (PNG, .LSS, and .TRC) and any appended files can
be extracted into separate files.

1. Enter the path to the LabNotebook Entry, or Browse to the file.
2. To extract all files, under Content Management, choose Extract Files.
To extract only the attachments, choose Extract Attachments.

3. Navigate to the folder where you want the files extracted, and choose Extract Now. A folder of the same name
as the original LabNotebook with the separate files will be created at that location.

Flashback

Flashback restores the waveforms and setups saved with the LabNotebook Entry to the screen. For MAUI Studio Pro
users, Flashback will also cause the oscilloscope application to simulate the oscilloscope on which the
LabNotebook was originally captured, including all its installed software options.

1. Choose File > Recall LabNotebook, then enter the path to the LabNotebook Entry, or touch Browse and
navigate to the file.

2. Select the Flashback button.
3. Toexit the Flashback, select the Undo button at the far right of the menu bar.

Some result data not included in the Flashback are:

 Persistence data, although it is saved with the .LNB file and appears on reports.
 Histogram data over 16 bits.

* Floating point waveforms resulting from certain math functions that have much higher resolution than
16 bits. This extra resolution is not preserved when traces are recalled using Flashback.

» Cumulative Measurements in process when Flashback is entered. When Flashback is used, they lose their
history and show only results from the stored waveforms, not including data taken from interim acquisitions.
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Report Generator

The Report Generator feature allows you to output a preformatted report consisting of an annotated screen image
and a summary of the setups in place when it was captured. The report can be sourced from an existing
LabNotebook, or it can be newly generated from the current state of the oscilloscope.

The logo and template used to create the report can be changed on the Email & Report Settings dialog.

Generate from LabNotebook

This procedure outputs an existing source as is. If you want to further annotate or change the description of a
LabNotebook file, first recall the LabNotebook.

Report Generator File Sharing Print Auto Save Email & ings € cLose

Open LabNotebook Entry - T -
prowse htm Browse
Save Now
uto Naming
LabNotebook

Share

Email

Current State Last Saved Report File

1. Choose File > Report Generator from the menu bar.

2. Browse to and select the LabNotebook Entry. If it is in the Selected Folder, just use the Up/Down Arrow keys
to select it.

3. Optionally, use View On/Off to preview the selected file.

4. Choose a Save Format of HTML, .RTF, or .PDF.

Note: Only HTML reports can later be saved to .RTF or .PDF format. The .RTF and .PDF reports can
only be combined into another report of the same format.

5. By default, the system will auto name the file "Report" followed by a counter number. To change the file name

Browser. By default, report files are saved to the D:\Xport folder on the instrument hard drive.
Note: Changing the file path, name or format will reset the counter to the next number in sequence.

6. If you do not want to use autonumbering, deselect Counter.

7. To save the report, choose Save Now.

Generate from Current State

If you are creating a report from the current state of the instrument, you will also be able to enter a new Description,
Annotate Screen Image, and select your capture Area/Color Preferences as when first creating a LabNotebook. See
Save LabNotebook.

However, when generating from Current State, you will not have saved a composite .LNB file that can later be
recalled or extracted into its component files. You will only have the preformatted report file.
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Print

Print dialog settings control how the oscilloscope's front panel Print button behaves.

Print captures an image of the touch screen display, but there are several options as to what it does next with the
image:

« Send it to a Printer as formatted here.

Copy it to the Windows Clipboard
» Save it to an image File using your current Screen Image Preferences

» Email an image file using your current Screen Image Preferences and Email Preferences

» Create a new LabNotebook file using your current LabNotebook Preferences

The Print Now button at the far right of the dialog can also be used to execute your current Print selection.

Recall Report Generator File Sharing Print Auto Save Email & Report Settings 8 CLOSE

! Print
. I Properties
Printer Clipboard Vel ps01inymkigptr1 roperties

DSO Window

B Orientation Print Now

[}
? : Standard Print Button
File Email n Action

Lahl‘- 0 e ouk a

Printer Settings
1. Touch Select Destination and choose a printer.
2. Touch Properties to change any of the printer properties.
3. Choose a paper orientation of Portrait or Landscape.
4. Select Annotate Before Saving to mark up captures before they print. Each time you press Print, the capture
will open in the Drawing Tools window. When you are Done drawing, the image prints.
Capture Settings

1. Select a Screen Area:
 Grid Area Only includes any visible waveform grids, tables, and descriptor boxes.
e DSO Window includes the above plus any open dialogs, menu bar, and message bar.
» Full Screen is the full Windows display, including other visible applications and wallpaper.

2. Choose the Colors used in the capture:
» Standard uses a black background as it appears on the instrument.
 Print uses your print color palette (set in Utilities > Preference Setup) on a white background

» Black & White captures the image in grayscale.
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File Sharing Dialog (send email)

Use the File Sharing dialog to email files from the instrument.

Report Generator File Sharing Print Auto Save Email & Report Settings

She
Browse

i MyReport—00000.htm i g
Email Share Now

These are the results

1. Choose File > File Sharing from the menu bar.

2. Use the File Browser to select all the files to be emailed. Use CTRL + Click to select multiple files.

3. Optionally, change the email Recipient(s). This field defaults to whatever is in your email settings.

4. Enter a Subject line and Message Body, then Share Now.

Email & Report Settings

Configure oscilloscope email settings and report output on the Email & Report Settings dialog.

Note: If using MAUI Studio Pro, these email settings can be pushed to a connected oscilloscope, but they
will not affect email on your PC. The report settings apply to reports created from LabNotebook files or the
current state of a connected oscilloscope.

Report Generator File Sharing Print Auto Save Email & Report Settings

Report

VyLog Browse [

Browse [l

ort\MyEngMot:

Send Test
Mail

Email Settings
1. Select to use MAPI or SMTP.
2. If you chose SMTP, touch SMTP Server and enter the network address of your mail server.
3. Touch Originator Address (From:) and enter the instrument's e-mail address.
4. Touch Default Recipient Address (To:) and enter the recipient's e-mail address.
5. Optionally, select to always Attach Setup & Waveforms associated with image files selected for email.

6. Use Send Test Mail to send a confirmation message to ensure proper e-mail configuration.
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Report Settings

The default report template uses our logo as a placeholder. You can replace this with your logo. Logo files should be
in bitmap (bmp) format and not exceed 100 pixels high by 180 pixels wide. Place the file in the oscilloscope's
D:\Xport folder.

You can also use your own report template. Templates must be saved as .xsl or .xslt files and placed in the D:\Xport
folder.

Deselect Use Defualt next to each item you want changed, then Browse to and select the new files.

Using the File Browser

Selecting Browse on any of the File menu dialogs opens a File Browser that enables you to perform basic disk utility
functions, as well as making file path/name and format selections.

Recall Waveform Brows:

i \ les DD 3 Open
MNew Folder | | Delete Folder| | Delete File Delete All Files = 5 Exploter Here

= [1 desktop Name Type Size  Modified

| |Ethemnet10GBRFrame1 trc TRC File 152 MB
" . Masks

B Ethernet10GBRFrame2 trc TRC File 391 KB 6/2/2011 9:
. Test LabNotebooks B Ethernet10GBRFrameSeqOrderSet.rc TRC File 390 KB 011 1

] n Wave Files
8b10b
64b66b
ARINC
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Dallas1Wire
DDR2
DDR3
DigRFV4
DisplayPort

Cumert Path  C

Flerame:  F t10GBRFram Waveform files (" tre;” XMLdig:" XMLy + Recall

Now

Close

Disk Utilities
New Folder, Delete Folder, Delete File, and Delete All Files can be used to change your file system prior to saving new
files. Be sure to first select the folder from the navigator (left) and file from the file list (right).

The buttons immediately above the file list let you change how items appear in the browser: icons only, details, etc.

File Path and Name

Use the navigator pane to the right to browse directories on the internal hard drive or USB drive. To select an existing
file to copy, move, change name, etc, use the file list to the right of the navigator. When an editable file is selected, the
Current Path and File Name are shown immediately below the navigator pane.

If you do not see the file you seek, try using the drop-down next to File name to change the file type to "All files (*.%)".
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Auto Naming Selections

The checkboxes to turn on/off the Source prefix and the Counter number suffix used to autogenerate file names will
appear on the File Browser when saving files. These selections are linked to those on the underlying dialog, and
changing the value in either place causes it to change everywhere.

Note: If you change any part of the file path/name or format on the File Browser or the dialog, the Counter
number will reset to the last number in the sequence associated with that value.

Example: Changing "Decode-Table-0002" to "Decode1-CANFDTable-..." will reset the counter to "Decode-
CANFDTable-0000" if there is no prior file named "Decode1-CANFDTable-..." .

Actions

The Close button accepts the selections you made on the File Browser and closes the browser window. If you do not
need to make further entries on the dialog to complete your task, you can choose to Save, Recall, Flashback, Email,
etc. right from the File Browser.
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Utilities & Preferences
The settings in this group allow you to customize the appearance and performance of the oscilloscope.
Utilities

Utilities settings primarily control the instrument's interaction with other devices and systems.

To access the Utilities dialogs, choose Utilities > Utilities Setup... from the menu bar.

Utilities Dialog

Utilities Status Remaote Aux Output Date/Time Options

T printer
HardCopy Setup ‘ WS nktgptr

Date/Time Setup m

System Status IR Senice b’
. Calibration

Hardcopy (Print) Setup, Date/Time Setup and System Status buttons open their corresponding setup dialogs.

Show Windows Desktop minimizes the oscilloscope application window. Maximize the application by touching the
display icon located at the lower-right of the desktop.

Touch-Screen Calibration launches a sequence of display calibration screens. You will be prompted through a series
of actions to improve the precision and accuracy of the touch screen.

The Service button to the far right of the dialog launches a section of the application reserved for qualified Teledyne
LeCroy service personnel. An access code is required to enter this section.

Status

The Utilities Status dialog displays information about your instrument including model number, serial number,
firmware version, and installed hardware and software options.

Choose Utilities > Utilities Setup from the menu bar, then touch the Status tab.

Or

Choose Support > About from the menu bar.
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Remote Control

The Remote dialog contains settings to configure remote control of the instrument and also network access.
Supported remote control protocols are:

TCPIP (Ethernet). Choose this if you wish to connect to the oscilloscope remotely from MAUI Studio Pro. The
instrument uses Dynamic Host Configuration Protocol (DHCP) as its default addressing protocol. You can
assign a static IP address using the standard Windows network setup menus.

 LXI (Ethernet). To use this option on Windows 10 oscilloscopes, you must supply the Admin. user password.
» USBTMC

» GPIB. This selection is active if you are using the USB2-GPIB adapter. Connect the adapter from any USB port
on the oscilloscope to the GPIB port on the controller.

Note: See the MAUI Oscilloscopes Remote Control and Automation Manual for full instructions on making
the remote connection and sending remote commands, particularly if you wish to do so using fully
automated remote control/automation programs, instead of MAUI Studio Pro. A commented copy of the
Waveform Template (.tpl) file is installed on the oscilloscope in C:\Program Files\LeCroy\XStream. Open
this ASCII file using any text editor to better understand the MAUI architecture for transferring waveform
data to and from the oscilloscope.

Status Remaote Aux Output Date/Time Options

TCPAP Remote
48
Show Remote
. 0.0.00 Control Log

Net
Connections

Set Up Remote Control

1. From the menu bar, choose Utilities > Utilities Setup, then touch the Remote tab.
2. Onthe Remote dialog, make a Control From selection.

3. Ifusing TCPIP and wish to restrict control to specific network clients, choose Yes under Security. Enter the IP
addresses or DNS names of the authorized controllers in a comma-delimited list.

Remote Control Assistant Event Log
The Remote Control Assistant monitors communication between the controller and instrument. You can log all
transfers or errors only, and the log can be output to an ASCII file.

1. From the menu bar, choose Utilities > Utilities Setup, then touch the Remote tab.
2. Under Remote Control Assistant, touch Log Mode and choose Off, Errors Only, or Full Dialog.

3. Toalways clear the log at startup, check Reset to Errors Only and clear at startup.

Export Contents of the Event Log

1. From the menu bar, choose Utilities > Utilities Setup, then touch the Remote tab.

2. Touch the Show Remote Control Log button. The Event Logs pop-up is shown.
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3. Enter alog file name in DestFilename, or touch Browse and navigate to an existing file.
Note: New contents will overwrite the existing content; it is not appended.
4. Touch Export to Text File.

Auxiliary Output
Use the Aux Output dialog to configure the output of the Aux Out port and Cal Out port.

Utilities Statu. Aux Output Date/Time

bration Output For

A

1.000 v

Set to 1KHz, 1V
Square Wave

Auxiliary Output
The Aux Out port outputs a configurable pulse of up to 1V into high impedance following the selected event:

 Trigger Enabled sends a pulse when the trigger is ready (Ready indicator lit), but not necessarily triggered. It can
be used as a gating function to trigger another instrument.

 Trigger Out sends a pulse upon a trigger (TRIG'D Indicator lit). If available, enter the desired Pulse Duration.

» Pass/Fail sends a pulse when Pass/Fail test conditions are met. Enter the desired Pulse Duration. Be sure to
also select Pulse Aux Out on the Pass/Fail Actions dialog.

Off disables output.

Calibration Output
On models equipped with a Cal Out hook on the front of the instrument, use these settings to configure the output
signal :

» For a Square wave signal, enter the Frequency and Amplitude into 1 MQ, or choose to Setto 1 kHz, 1V Square
Wave.

 For areference DC Level, enter an Amplitude into 1 MQ.

Off disables output.
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Date/Time

Date/Time settings control the instrument's timestamp. These numbers appear in the message bar and on
tables/records internal to the oscilloscope application, such as History Mode and WaveScan.

Note: On Windows 10 oscilloscopes, you must run MAUI with elevated privileges to change the Windows
Date/Time settings. Consult your IT department for the current Admin. password.

To run with elevated privileges:
1. Exit MAUI by choosing File > Exit from the menu bar.
2. Right-click on the Start DSO icon and choose Run as administrator.
3. Enter the Admin. user LCRYADMIN and current Admin. password.

4. After MAUI has restarted, access the Date/Time dialog by choosing Utilities > Utilities Setup from the menu
bar, then touch the Date/Time tab.

Utilities Status Remate Aux Output Date/Time Options

Monday, July 23, 2018 1:35:59 PM
Set from Internet

Validate
Changes

Manual Method
Enter the Hour, Minute, Second, Day, Month, and Year, then touch the Validate Changes button.

Internet Method
This method uses the Simple Network Time Protocol (SNTP) to read the time from time-a.nist.gov. The instrument
must be connected to an internet access device through a LAN (Ethernet) port.

If your oscilloscope has an active internet connection, simply touch the Set from Internet button.

Windows Method

To set date and time using the internal Windows system clock, touch the Windows Date/Time button. This displays
the standard Windows Date and Time Properties pop-up dialog, where you can further configure these settings.
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Options

Many optional software packages are available to extend the Analysis functions of the instrument. When you
purchase an option, you will receive a key code by email that activates the new functionality. Use the oscilloscope
Options dialog to activate options by installing the key code.

Note: This dialog also displays the ScopelD and Serial #, which may need to be supplied when purchasing
an option.

To install a key code:
1. From the menu bar, choose Utillities > Utilities Setup, then open the Options tab.

Utilites | Status Aux Output | DateTime  Options

Installe

Reset = =
Masked Options 3 D41-7EFE

PWR_ANALYSIS

2. Touch Add Key. The Virtual Keyboard appears onscreen.

3. Use the Virtual Keyboard to type the key code in the Enter Option Key field.

Note: For oscilloscopes using firmware version 8.1.x.x or earlier, the legacy 16-digit key code must be
used.

4. Touch OK or press Enter to enter the information. The key code is added to the list of Installed Option Keys.

Tip: You can use the Up/Down buttons to scroll the list of keys. The software option that each key
activates is displayed below the list.

5. Iffinished, choose Yes to restart the oscilloscope application, or click Cancel to enter additional option keys.
Restart the oscilloscope after entering the last key code.

6. Afterrestarting, check the list of installed software options by choosing Help > About from the menu bar. If
the installed options are not listed, then a firmware upgrade may be required.

The latest firmware is available on our website at: Resources > Software Downloads.

If you have any problems installing key codes on your Teledyne LeCroy oscilloscope, please call 1-800-5-LeCroy (1-
800-553-2769) or email support@teledynelecroy.com for further assistance.
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Preferences

Preference settings have mostly to do with the appearance and performance of the instrument itself, rather than its
interaction with other devices/systems. Most of these settings are called "non-volatile," because they are not lost
when the oscilloscope is restarted and do not change when a setup panel is recalled.

Access the Preferences dialogs by choosing Utilities > Preference Setup... from the menu bar.

Preferences Dialog

Preferences Calibration Acquisition Color Misc

Power on AC Audible Feedback Language Font Size

. ; anguage
W Enale Enable English Defaut

Power on the scope when Enables audible feedback
AC line is plugged of Touch-Screen Activity.

On the main Preferences dialog:

Power on AC will turn on the oscilloscope and launch the software as soon as you connect to AC power, without
having to first press the Power button.

Audible Feedback controls the instrument's audio output. Select this box to hear a beep each time you touch a
screen or front panel control.

Language sets the language used on the touch screen display.

Font Size changes the size of the text that appears on the touch screen display.

Tip: The best way to change font size and other screen settings on Windows 10 oscilloscopes is to swipe
from the right of the touch screen to display the Action Center, then choose All Settings > System Settings
and make your selections.

Performance settings let you optimize performance for either Analysis (speed of acquisition and calculation) or
Display (speed of update/refresh). For example, if you are concerned with persistence or averaging, you might
optimize for Analysis, giving higher priority to waveform acquisition at the expense of display update rate. Choices
are presented as a spectrum.

Calibration

Calibration ensures that the output from the analog-to-digital converters (ADCs) accurately represents the input. The
oscilloscope is calibrated at the factory prior to shipment at all possible horizontal and vertical settings at 23 °C (+ 2
°C). This calibration remains on the oscilloscope as a baseline and is never deleted. It is used in default of any more
current calibrations.

So that the oscilloscope maintains specified performance, both cached and dynamic calibration routines are used
during operation, depending on model.

Note: After power on, warm the oscilloscope for at least 20 min. to ensure it reaches a stable operating
temperature. A message on the Calibration dialog alerts you when the oscilloscope is still in the warm-up
phase. Specifications are not guaranteed during warm up.
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High Definition Oscilloscopes (HDO, HD and MDA models) utilize Temperature Dependent Calibration to maintain
gain accuracy. To avoid dynamic recalibration and minimize disruptions, the oscilloscope uses cached calibration
files that cover a particular combination of vertical and horizontal settings over a temperature range.

Whenever you acquire, the oscilloscope checks the current temperature. If the temperature has changed beyond the
calibration threshold (shown in the table below) since last acquisition, it loads the most recent calibration within
threshold of the current temperature. If there is no calibration within threshold of the current temperature, it loads
the calibration closest to the current temperature (regardless of age), and you will receive a message on the
Calibration dialog that manual calibration is recommended. Depending on the model, additional dynamic
calibrations may occur when outside threshold.

Calibration Threshold... Action at Acquisition...
HDO4000A +5 °C of last temperature at current o Checks temp and if outside threshold loads most
HDO6000B acquisition settings recent cached cal file within threshold of current
temp

¢ If no cal file within threshold of current temp, loads
closest temp and recommends manual calibration

MDA/WaveRunner 8000HD +5 °C of last temperature at current | Automatic Calibration checked on Preferences dialog:
acquisition settings

e Checks temp and if outside threshold loads most
recent cached cal file within threshold of current
temp

o If no cal file within threshold of current temp, loads
closest temp and recommends manual calibration

Automatic Calibration unchecked on Preferences dialog:*

e Stops temperature check

e Continues to use last cal file loaded for current
setup; cal file changes only when acquisition
settings change, using closest to last temperature
recorded when Automatic Calibration disabled

WavePro HD +5 °C of last temperature at current | For acquisitions <1 GHz:
acquisition settings

e Checks temp and if outside threshold loads most
recent cached cal file within threshold of current
temp

o If thereis no cal file within threshold of current
temp, dynamically recalibrates current setup

For acquisitions >1 GHz, checks temp and if outside
threshold dynamically recalibrates current settings.
WaveMaster 8000HD +3 °C of last temperature at current * Within range of ~20-35 °C, checks temp and if
acquisition settings outside threshold loads most recent cached cal file
within threshold of current temp

o QOutside range of ~20-35 °C, dynamically
recalibrates current setup whenever temperature
varies by +3 °C of the last calibration temperature

* This is also the behavior on oscilloscopes where Temperature Dependent Calibration was turned off using COM Automation.
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It is also possible to manually re-calibrate the oscilloscope prior to acquisition for maximum accuracy. We
recommend manually re-calibrating when:

» The ambient temperature is known to have ranged outside the calibration threshold since last acquisition
» Your last manual calibration was performed:

» QOver one month ago for HDO4000A and HDO6000B

» Qver six months ago for MDA/WaveRunner 8000HD, WavePro HD and WaveMaster 8000HD

From the menu bar, choose Utilities > Calibration. The Status section of the Calibration dialog will tell you if
"Calibration is recommended" for the current acquisition settings and environmental conditions.

There are two manual calibration routines available for selection:

 Calibrate All calibrates all possible combinations of vertical and horizontal settings. This calibration is valid for
the current temperature plus/minus the calibration threshold and may take over an hour.

Tip: To avoid deleting good calibration files, be sure your Windows clock is set correctly before
Calibrate All.

» Calibrate Current Setting calibrates the current vertical and horizontal settings. This calibration is valid for these
settings only at the current temperature plus/minus the calibration threshold and takes ~10 seconds.

A Caution: Remove all inputs prior to calibrating the oscilloscope.

The Calibration dialog will inform you when the calibration is complete and valid.

Calibration Acquisition Color Miscellaneous

Calibrate

Calibrate All Current State

Calibration is valid.

Calibration Status Messages
Following are Calibration messages you may see on oscilloscopes with Temperature-Dependent Calibration:

System is warming up... The oscilloscope has not reached a stable operating temperature. Spe-
cifications are not guaranteed.

Calibration is valid Calibration status is good; no action is required.

Calibration is recommended The temperature is outside threshold of any available cal file, Or it has been

more than six months since the last calibration (WaveRunner 8000HD,
WavePro HD and WaveMaster 8000HD). You should perform a manual cal-
ibration of at least the current setup.

The calibration database has encountered a The calibration data table is corrupted. Cease operation and contact Service.
problem. Please contact service department.
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Disabling Temperature Dependent Calibration
Temperature Dependent Calibration can be de-activated using COM Automation by setting the CVAR:

app.Acquisition.AutoCal = 0

This stops the temperature check and substitution of the calibration file in use at time of acquisition. The system will
continue to run with the last set of calibration files at the last temperature recorded.

If you need to ensure the use of a particular calibration temperature for testing, we recommend that you:
1. Bring the oscilloscope to temperature (and maintain it there).
2. Make a short acquisition to reset the temperature.
3. Disable Temperature Dependent Calibration.
4. Invoke Calibrate All.
This will ensure the correct temperature calibration remains in use at all settings.
Note: The Automatic Calibration setting cannot be saved to the oscilloscope's non-volatile setup panel and

will revert to "On" (1) with each start up. You must reset this anytime you power on the oscilloscope either
manually or through Automation command.
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Acquisition

The Acquisition preference settings determine how traces behave as Vertical Offset or Horizontal Delay changes.
Choose Utilities > Preference Setup to open the Acquisition dialog.

Preferences Calibration Acquisition Color Miscellaneous

Delay Setting (

Offset Setting constant in:

» Volts keeps the amount of Offset in the amount of Volts specified, regardless of the V/div setting. As the Offset
is adjusted, the trace will appear to move up or down relative to the zero level.

» Div(isions) keeps the Vertical Offset level indicator stationary. The waveform remains on the grid as you
change V/div, but your Offset value will change.

Delay Setting constant in:

» Time keep the Horizontal Delay at the amount of time specified, regardless of the Time/div setting. The
Horizontal Delay indicator moves relative to the 0 point at the center of the grid.

« Div(isions) keeps the Horizontal Delay indicator stationary. The trigger point remains on the grid as you
increase the timebase; whereas, if Time is selected, the trigger point could move off the grid.

Note: Whenever Div is selected, values are scaled proportional to the change in gain or timebase, thereby
keeping the division of the grid constant.

Trigger Counter Setting is selected by default. It clears the trigger counter each time a new acquisition command is
sent. It is only made active for deselection when trigger Holdoff is set.
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Color

Color dialog settings assign the colors used for channel, math, and memory traces. All dialogs, tables, and trace
descriptor boxes will match the color of the trace assigned here. You can choose different colors to be used on the
instrument and in print.

Note: Print colors are used only when the Colors control is set to Print on any of the File menu dialogs (Save
Screen Image, Print, etc.). Otherwise, the Screen colors are used for print output as well as on screen.

This alloy ear th when printed

Preview
default colors print colors

To make any setting, just touch the color swatch for either Screen or Print next to the trace number, and make a
selection from the Color pop-up menu.

For convenience, you can Preview print colors to see how the settings will appear in print output.

Touch Factory default colors to recall the original color settings for your instrument.

Miscellaneous

These other Preference settings are located on the Miscellaneous dialog.

Calibration Acquisition

Security

"\‘ TELEDYNE LECROY

Everywhereyoulook

To add the Teledyne LeCroy logo to print output, check Print Teledyne LeCroy Logo When Printing Grid Area Only.
This identifies the instrument as the source of the image.

Dimming darkens/shades those areas of the source waveform that are not part of the Zoom trace.

Control Sensitivity adjusts the sensitivity of the front panel knobs. Optimized applies an acceleration algorithm to the
knobs. Legacy detects rotation of the front panel knobs in a manner similar to our legacy oscilloscopes.

Serial Decode Annotation Position: If you have Serial Trigger or Decode options installed on your instrument, this
control determines the placement of annotation labels relative to the trace line. It does not appear if there are no
installed options.

» On Trace places the label close to the line.
« On Noisy Trace sets the label further away to accommodate potential noise spikes in the trace.

Check Enable HTTP Screen Capture to enable remote capture of the touch screen display over a netowrk. This
setting is required to use the instrument with the WaveStudio software.
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Disk Utilities

Use the Disk Utilities dialog to manage files and folders on your instrument's hard drive. Disk Space information is
shown at the far right of the dialog for convenience.

Note: These tasks can also be accomplished using the standard Microsoft Windows file management tools.

Choose File > Minimize to access the Windows desktop and task bar.

Access the Disk Utilities dialog by selecting Utilities > Disk Utilities from the menu bar.

Disk Utilities

Delete

Empty

Browse
Folder

Delete
File

Delete a Single File

1.

2.

3.

4,

Touch the Delete button.
Browse to the current folder containing the file.
Browse to the file to be deleted, or use the Up and Down arrow buttons to scroll through the files in the folder.

With the desired file selected, touch Delete File.

Delete All Files in a Folder

1.
2.

3.

Touch the Delete button.
Browse to the current folder containing the file.

With the desired folder selected, touch Empty Folder.

Create a New Folder

1.
2.

3.

Touch Create.
Touch Current folder and provide the full path to the new folder, including the folder name.

Touch Create Folder.
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Digital Voltmeter

The Digital Voltmeter option activates an integrated 4-digit digital voltmeter and 5-digit frequency counter that
operates through the same probes already attached to the oscilloscope channels.

Note: You do not need to display the source channel trace to see the voltage readout on the DVM descriptor
box and dialog.

DVM Readout

DVM Descriptor Box

[oc[c1]

3.51 mV

. AutoScale indicator; "A" when on, blank when off

A

B. Mode
C. Input channel measured
D

. Voltage readout, color coded to match input channel

DVM Dialog

DVM
Setup Measurement

Enable

3.51mV

-0.20V 0.00v

206 mV

A. Last measured voltage
B. Histogram of measured voltage
C. Vertical range (in -/+ divisions) of signal

D. Amplitude and Frequency readout
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Set Up DVM

1. From the menu bar, choose Utilities > DVM.

2. Mark Enable to turn on the DVM function.

3. Touch Source and select the input channel to be measured.

4. Touch Mode and choose the waveform parameter to display on the readout. Options are:
 DC
e« DCRMS
« ACRMS
e Frequency

5. Optionally, turn on AutoRange, which automatically adjusts the Vertical range and offset of the waveform as
the amplitude changes so that measurements are always taken at the optimal resolution. When this option is
selected, the letter A appears on the DVM descriptor readout.
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WaveSource Arbitrary Function Generator

The WaveSource Arbitrary Function Generator allows you to output custom sine, square, triangle, pulse, DC, noise,
and arbitrary waveforms from the oscilloscope.

Connect a BNC cable from the WaveSource output on the back of the oscilloscope to the external device. Output is
continuous once WaveSource is enabled.

Output Standard Waveform

WaveSource 0 cLose

WaveSource Waveform Utilities

Default Setup

1. Choose Utilities > WaveSource.
2. Select the Load level.
3. Choose a Waveform type.

4. Depending on the type, waveforms may be configured using different groups of Settings (e.g., Frequency or
Period, but not both). When you see buttons offering this choice, first select the group of settings to use.

5. Adjust settings (e.g., Frequency) by touching the field and turning the front panel Adjust knob, or touch twice
and use the soft keypad to enter new values.

Touch Default Setup to restore the default waveform settings.

6. Check Enable to begin output.

Import and Output Arbitrary Waveform

You may import files defining arbitrary waveforms to be output from the function generator. Waveform files must be
saved in .csv format to be loaded into WaveSource. Transfer the file to the oscilloscope from a USB drive or through
MAUI Studio.

1. Choose Utilities > WaveSource .
2. Select the Load level.
3. Choose Waveform type ARB.
4. Touch Browse next to the File Name field and select the arbitrary waveform file. Touch OK.
5. Touch Upload.
6. Check Enable to begin output.
Note: When outputting arbitrary waveforms, the Frequency shown on the WaveSource dialog is the

pattern repetition rate, not the actual frequency of any source waveform from which the waveform
file was created. See the parameter definitions below.
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Arbitrary Waveform File Syntax

A B
1 |datalength 16384
2 |frequency 1000
3 lamp 2
4 |offset 0
5 |phase 0
6
I
8
9
10
11
12
13 |xpos value
14 1 ol
15 2 -0.00012
16 3 -0.00024
17 4 -0.00037
18 5 -0.00045

Waveform files for use with WaveSource must be set up with header and data as shown
in the image at left.

Following the header, each line contains the sample point Xpos number and vertical
value.

Header Fields
Data Length - Total number of values that define the waveform. This total length will
continue to repeat as long as the waveform is output.

Frequency - Waveform frequency in Hz. The waveform sample point interval will be
1/<frequency>.

Amplitude - Waveform amplitude in Volts peak-peak (Vpp).
Offset - Waveform offset from 0 value, in Volts.

Phase - Waveform phase, in degrees.

Data Fields
Xpos - Index number of the sample point. Note Xpos defines a series; it does not define
the actual X-axis value of the sample point.

Value - Vertical value of sample point, in Volts.

This information may be set up in a spreadsheet, as shown, then output to a comma-delimited .csv file for import.

Note: You must use a comma, not any other delimiter character, when saving the .csv file.
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Maintenance

Topics in this section describe procedures for keeping the instrument in optimal working condition.

Cleaning

Clean only the exterior of the instrument using a soft cloth moistened with water or an isopropyl alcohol solution. Do
not use harsh chemicals or abrasive elements. Under no circumstances submerge the instrument or allow moisture
to penetrate it. Dry the instrument thoroughly before connecting a live voltage source.

A Caution: Unplug the power cord before cleaning. Do not attempt to clean internal parts.

Restart/Reboot Instrument

To restart the oscilloscope application, choose File > Exit from the menu bar, then touch the Start DSO icon.
To reboot the instrument, which includes restarting the Windows 0OS:
1. From within the oscilloscope application, choose File > Shutdown.

2. Wait 10 seconds after the oscilloscope has fully shut down, then press the Standby Power button on the front
of the instrument.

Restore Default Setup

The front panel Default Setup button restores all the volatile setups to the factory default state.
You can also restore default settings via the touch screen:

1. Choose File > Recall Setup from the menu bar.

2. Choose to Recall From File.

3. Under Recall Default touch Recall Now.

Changing Screen Settings

On Windows 10 instruments, MAUI software font size and other screen settings are now changed using the
standard Windows controls, rather than through the MAUI application. The text font is set to display at 125% by
default.

1. Swipe the touch screen from the right to display the Action Center.

2. Touch the All Settings icon .
3. Choose System settings.
4. Make your selections from the Settings dialog. If prompted, enter the current oscilloscope Admin. password.

5. Swipe from the right again to return to MAUI.

6. Choose File > Shutdown, then press the Power button to reboot.
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Touch Screen Calibration

Periodically calibrate the touch screen to maintain its accuracy and responsiveness. We recommend that you use a
stylus rather than your finger for this procedure.

1. From the menu bar, choose Utilities > Utilities Setup.
2. Onthe Utilities main dialog, touch Touch-Screen Calibration.

3. Following the prompts, touch as close as possible to the center of each cross that appears on the screen until
the calibration sequence is complete.

Switching Windows Users

To maintain the highest security profile, the oscilloscope is shipped to run as the Standard user, LeCroyUser. If you
need to run as an Administrator, do the following to switch to LCRYADMIN. This will put the oscilloscope into a
"legacy" mode where it will run most like it did on Windows 7.

1. Choose File > Exit to exit the oscilloscope application.

2. Open the Windows Start menu .
A,

3. Hover over the Teledyne LeCroy logo o and select user LCRYADMIN.
4. Enter the current LCRYADMIN password.

To return to the default LeCroyUser account, repeat this procedure selecting LeCroyUser and entering the current
user password.

You may create as many other new user accounts on the oscilloscope as you wish, provided you are logged in as
LCRYADMIN when doing so.

Note: The oscilloscope will always reboot into the last active Standard user. The only way to change this is
to make LeCroyUser (and all other users) an Administrator.

MAUI Firmware Update

Free MAUI® firmware updates are released periodically. You must register an account to download the software
from our website. Registered users will receive an email notification when a new version is released.

The MAUI Software Setup Wizard can be used to install MAUI Studio® desktop software, MAUI oscilloscope
firmware—including required DLLs, device drivers and low-level microcode for integrated circuits—or WavePulser
software. The update does not modify or delete any saved panel setups, waveforms, screen captures, calibration
constants, or other data stored on the oscilloscope D: drive.

Do not install MAUI Studio on an oscilloscope.

@ Note: To install software on Windows 10 oscilloscopes, you must supply the current oscilloscope
LCRYADMIN password. On oscilloscopes shipped with unique passwords, a sticker on the oscilloscope
body shows the password at time of shipment. Oscilloscopes without stickers were shipped with default
password SCOPEADMIN. Check with your IT department/lab manager if passwords have been changed
since receipt.
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Download Instructions

]
2
3.
4

. Visit the software download page.

Select your series and model number.
Enter your registration login information, or create a new account. You cannot proceed without an account.

Click the download link, and choose to Save the installer to the oscilloscope Desktop or to a USB storage
device for transfer to the instrument.

Installation Instructions

A Caution: The installation can take several minutes. Do not power down at any point during the process.

o g A~ w2

10.

From the oscilloscope menu bar, choose File > Exit to close MAUI.
Browse to mauiinstaller64_<version>.exe and double-click it to launch the setup wizard.
Enter the current LCRYADMIN Password.
Click Next to begin installation.
Review and accept the license agreement. Click Next.
For an oscilloscope update, select the checkboxes for:
» MAUI Oscilloscopes, including DSO Device Drivers and Upgrade DSO Microcode
» MAUI Browsers

» Optionally, select SPARQ or WavePulser if you wish to drive that instrument from the oscilloscope.

,;':" Choose Components
:.Al J Tetepyne  Choose which features of MAUT Software 9.3.0.0 you want to
— ﬁ LECROY install,
Select components to install:
= MALUI Oscilloscopes Description
H DSO Device drivers
Upgrade DSO Microcode
-] MaUI studio
-[] wavePulser
i-[]sParq
MALIL Automation Browsers
Space required: 2,1 GB
Teledyne LeCroy < Back Install Cancel
Click Install.

If you receive Windows security warnings, trust and Install the file.

If you see the Hardware Programmers screen, accept all code installations, then click the closebox after you
see that programming has completed.

When installation is complete, choose Reboot now and click Finish .

Release Notes

Release Notes are provided for each new version. They can be found on the web page from which you downloaded
the installer.
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Note to QualiPHY/QualiPHY 2 Users

MAUI/MAUI Studio Pro and QualiPHY/QualiPHY 2 software versions must match to the second decimal to function
properly. If you are upgrading your oscilloscope firmware or PC MAUI Studio Pro installation, upgrade your version of
QualiPHY as soon as possible.

Windows 10 External Display Setup

The Windows 10 default is to treat any external monitor connected to a Windows 10 PC as the primary touch screen.
On Windows 10 oscilloscopes with an external monitor attached, you will have to manually change the display
settings so that the oscilloscope is recognized as a touch screen.

If the external monitor is touch screen enabled and you wish to use it along with the oscilloscope to control the
oscilloscope application, you will need to repeat this procedure to also identify it as a touch screen.

1. Follow manufacturer's instructions to connect your monitor to the oscilloscope.

2. Choose File > Minimize to display the Windows Desktop.

3. Choose StartE and in Search enter "Tablet PC Setup." You should see the Tablet PC Settings dialog.

& Tablet PC Settings hd
Display Other

Configure

pla 7P s toueh

Display options

Display: 1|2, Multiple Monitors v

Details: Limited Touch Support

Ggah‘brate... E; Reset
Choose the order in which your screen rotates.Go
to Origntation
oK Cancel

If the monitor is not touch screen enabled, Display 1|2 Multiple Monitors is OK.
If the monitor is touch screen enabled, be sure Display 1 (the oscilloscope) is selected.
4. Touch the Setup button.

5. When prompted, enter the LCRYADMIN password and touch Yes.
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User Account Control e

Do you want to allow this app to make
changes to your device?

\i’ Digitizer to Monitor Mapping Tool

Verified publisher: Microsoft Windows

To continue, enter an admin user name and password.
"\‘ LCRYADMIN

LCRY5001N60008\LCRYADMIN

6. When you see the oscilloscope display turn white with the text "Touch this screen to identify it as the touch
screen. . .", touch the oscilloscope display.

7. When you see "Press Enter to proceed to the next step to complete your configuration,” press Enter.

8. If you wish to also configure the external display as a touch screen, repeat this procedure selecting the
external monitor name from the Display field on the Tablet PC Setup dialog.

Windows 10 File Management

Due to the increased security of Windows 10, many more operations require Administrator permissions than did
with previous versions of Windows. When doing any of the following from either the default LeCroyUser account, you
will be asked to supply the current LCRYADMIN password:

« Installing third-party software and MAUI updates

» Accessing third-party applications or running an application as an administrator

» Admitting third-party applications to make changes to the MAUI application

 Using Device Manager and making changes within it (such as installing new device drivers)
» Moving, deleting or copying certain files

» Changing global settings, such as Date/Time (this also requires running MAUI with elevated permissions)
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Oscilloscope System Recovery

Mid- and high-bandwidth Teledyne LeCroy oscilloscopes run on the 64-bit MAUI® software installed over a
Microsoft Windows® platform. While the instrument is designed to operate reliably for many years, the loading or
incomplete removal of additional Windows applications can cause problems with the stability of the operating
system. Severe cases may require you to reload the base operating system and firmware.

For this purpose, Teledyne LeCroy provides a recovery application and a backup image. Windows 10 oscilloscopes
utilize the Acronis True Image 2019 OEM recovery software with an F10 startup utility script that automates the
recovery process. The entire process takes about 17 minutes to complete and is easy to perform.

Caution: This procedure will destroy all data on the C: drive. If your drive is accessible, first back up any files
you may want to restore after recovering. Be prepared to reinstall third-party software.

Before Recovery...

Check if the oscilloscope was shipped with or without unique passwords shown on a label on the body of the
oscilloscope.

The recovery procedure for oscilloscopes with unique passwords requires you to reset the unique Windows
LeCroyUser and LCRYADMIN account passwords at the end of recovery.

Note: The passwords on the label can be reused at the end of recovery, or you can create new passwords.

Instruments shipped before unique passwords (~Q4 2024) were delivered with shared default passwords:
» User LeCroyUser password is lecroyservice (all lowercase)

» User LCRYADMIN password is SCOPEADMIN (all uppercase)

Note: For security reasons, we strongly recommend changing both accounts to unique passwords after
recovery is complete. Use the standard Windows 10 networking tools.

Connect a keyboard and mouse to the oscilloscope before recovery. You will need to enter key commands.

After Recovery...

The recovery process restores a disk image of the software at the time of manufacture. It does not automatically
update the Windows operating system, virus scan definition files, external device drivers, etc.

Note: On oscilloscopes shipped with unique passwords, MAUI firmware is restored to the last installed
version after recovery.

After completing system recovery, we recommend that you reinstall/upgrade software to current revision levels.
Download the latest oscilloscope firmware for your model. You will need to register an account to complete the
firmware download.

User and calibration data stored on the D: drive are not overwritten during recovery. You do not need to restore them.
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Recovering Oscilloscopes with Default Passwords

Note: On oscilloscopes with default passwords (no password label):
Local user LeCroyUser = lecroyservice
Administrator LCRYADMIN = SCOPEADMIN

Before You Start

» Find your Windows license key in case you need to re-activate Windows

e Connect a keyboard and mouse to the instrument.

Run Recovery Script

1.

2.

8.

If still in the oscilloscope application, choose File > Exit to close and show the Windows desktop.

From the Windows E Start menu, choose Restart.

Note: You must be able to restart and enter the boot sequence to run recovery. If you cannot do this,
return the oscilloscope to Teledyne LeCroy for recovery.

During the boot sequence, watch for the message "Starting Acronis Loader..." When you see the Acronis
message, press the F10 key.

Note: Do not press F10 before you see "Starting Acronis Loader..." If a boot menu dialog appears,
press Cancel or Esc.

When you see the Acronis window, select Recover and press Enter. It may take awhile for the license screen
to appear.

Accept the Acronis license agreement.
Allow the recovery process to run. This may take several minutes.

When the MAUI Setup Wizard appears, enter password SCOPEADMIN and follow the installer prompts. If you
see a message that Windows can't verify the publisher of the driver software, choose "Install this driver
software anyway" and click Install.

Choose Yes to reboot the instrument at the conclusion of installation.

Check Windows Activation

Your Windows license may or may not need to be reactivated following recovery. Reactivation sends a digital license
key stored with the recovery image to Microsoft via the Internet, so the instrument must be networked to do this.
Have your Windows license key ready; it is listed on a sticker on the oscilloscope body.

To check activation status:

1.

Choose File > Exit to close the oscilloscope application and show the Windows desktop.

From the Windows Start menu, choose . Settings > Update & Security > Activation.

The activation status appears at the top of the dialog. An Activate button appears if reactivation is required.
Click the button and follow the Microsoft reactivation procedure.
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Re-enable Windows Defender
1. From the Windows Start menu, hover over the Teledyne LeCroy logo and select User LCRYADMIN. Enter
the password SCOPEADMIN.
2. Once logged on as admin., search for the program gpedit.msc (Edit Group Policy).
3. Navigate to Administrative Templates > Windows Components > Windows Defender.
4. Select Windows Defender from the navigation pane so the settings appear at the right of the window.
5. From the settings pane, right-click on Turn Off Windows Defender and select Edit.

6. Select Disable. (By disabling "Turn Off," you turn on the software.)

Reset Serial Number

To apply option keys to the instrument in the future, you must restore the correct instrument serial number after
recovering the hard drive. The number is the found on the back panel product sticker or removable hard drive.

1. From the Windows Start Menu, choose Control Panel > System .

2. Scroll down to Computer name, domain, and workgroup settings, then click Change Settings.

3. Onthe System Properties dialog, click Change and enter the oscilloscope serial number in Computer name.
4. Click OK twice to return to the desktop.

5. Double-click the StartDSO desktop icon.
Recovering Oscilloscopes with Unique Passwords

Before You Start

» For optimal security, devise new unigue passwords for LCRYADMIN and LeCroyUser accounts. Unique
passwords at time of shipment are on a label on the body of the oscilloscope.

e Connect a keyboard and mouse to the instrument.

Run Recovery Script

1. If stillin the oscilloscope application, choose File > Exit to close and show the Windows desktop.

2. From the Windows Start menu E choose Restart.

Note; You must be able to restart and enter the boot sequence to run recovery. If you cannot do this,
return the oscilloscope to Teledyne LeCroy for recovery.

3. During the boot sequence, watch for the message "Starting Acronis Loader..." When you see the Acronis
message, press the F10 key.

Note: Do not press F10 before you see "Starting Acronis Loader..." If a boot menu dialog appears,
press Cancel or Esc.
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4.

5.

6.

When you see the Acronis window, select Recover and press Enter. It may take awhile for the license screen
to appear.

Accept the Acronis license agreement.

Allow the recovery process to run. This may take a few minutes to complete.

Reset Account Passwords

1.
2.

10.
11.
12.
13.

When you see the message "Password incorrect..." click OK.

From the bottom left of the screen, select the LCRYADMIN account, then enter password ADMIN (all
uppercase). This puts you into an Administrator account so you can make the other necessary account
changes.

When you see the message "User's password must be changed...", click OK.
At the next change password prompt, enter a unique LCRYADMIN password twice, then click OK. Click OK
againtologin.

0 Tip: You can reuse the original unique passwords on the label or create new passwords.

On the desktop, right-click the This PC icon and select Manage.

Double-click on Local Users and Groups, then double-click the Users folder. You should see LCRYADMIN and
LeCroyUser accounts.

Right-click on LCRYADMIN and select Properties.

Check Password Never Expires, then click Apply and OK.

Right-click on the LeCroyUser account and select Set Password. Proceed when prompted.
Enter the unique LeCroyUser password twice, click OK.

Right-click on LeCroyUser and select Properties.

Check Password Never Expires, then click Apply and OK.

Close the Computer Management dialog.

This concludes the password reset.

Set Up Auto Login

The oscilloscope normally runs from the local user account, LeCroyUser. Auto Login will enable you to boot into that
account without having to enter a password. You will still need to enter the Administrator password to install
firmware or change Windows settings.

—_

N

Press the Windows key E + R on the keyboard.
Enter netplwiz and click OK.
While still in the LCRYADMIN account, check "Users must enter user name and password...". Click Apply

Select the LeCroyUser account and uncheck "Users must enter user name and password...". Click Apply.
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5. When prompted, enter the unique LeCroyUser password twice, then click Apply.

6. Click OK to accept all changes.

Reset Serial Number

To apply option keys to the instrument in the future, you must restore the correct instrument serial number after
recovering the hard drive. The number is the found on the back panel product sticker or removable hard drive.

1.

2.

From the Windows Start Menu, choose Control Panel > System + Security > System .
Scroll down to Computer name, domain, and workgroup settings, then click Change Settings.
On the System Properties dialog, click Change and enter the oscilloscope serial number in Computer name.

Click OK once, then click OK again when prompted to reboot.
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Returning a Product for Service

Contact your local Teledyne LeCroy service center for calibration or other service. If the product cannot be serviced
on location, the service center will give you a Return Material Authorization (RMA) code and instruct you where to
ship the product. All products returned to the factory must have an RMA.

Return shipments must be prepaid. Teledyne LeCroy cannot accept COD or Collect shipments. We recommend air-
freighting. Insure the item you're returning for at least the replacement cost.

1. Remove all accessories from the instrument.

2. Label the instrument with:
* The RMA
» Name and address of the owner
» Description of failure or requisite service

3. Pack the instrument in its original shipping box, or an equivalent carton with adequate padding to avoid
damage in transit. Do not include the manual.

4. Mark the outside of the box with the shipping address given to you by Teledyne LeCroy. Be sure to add the
following:

» ATTN: <RMA code assigned by Teledyne LeCroy>
» FRAGILE

5. If returning a product to a different country: contact Teledyne LeCroy Service for instructions on completing
your import/export documents.

Extended warranty, calibration, and upgrade plans are available for purchase. Contact your Teledyne LeCroy sales
representative to purchase a service plan.

For a complete list of Teledyne LeCroy offices by country, including our sales and distribution partners, visit:
teledynelecroy.com/support/contact
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Technical Support

Live Support
Registered users can contact their local Teledyne LeCroy service center at the number listed on our website.

You can also submit Technical Support requests via the website at:

teledynelecroy.com/support/techhelp

Resources
Teledyne LeCroy publishes a free Technical Library on its website. Manuals, tutorials, application notes, white
papers, and videos are available to help you get the most out of your Teledyne LeCroy products. Visit:

teledynelecroy.com/support/techlib

The Datasheet published on the product page contains the detailed product specifications.

Service Centers
For a complete list of offices by country, including our sales & distribution partners, visit:

teledynelecroy.com/support/contact

Teledyne LeCroy

700 Chestnut Ridge Road
Chestnut Ridge, NY, 10977, USA
teledynelecroy.com

Sales and Service:

Ph: 800-553-2769 / 845-425-2000
FAX: 845-578-5985
contact.corp@teledynelecroy.com

Support:
Ph: 800-553-2769

customersupport@teledynelecroy.com
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Certifications

Teledyne LeCroy certifies compliance to the following standards as of the time of publication.

European Council

The instrument bears this mark to indicate it conforms to all applicable European Council standards.
Please see the EC Declaration of Conformity document shipped with your product for current
certifications.

EMC Directive

The instrument meets the intent of EC Directive 2014/30/EU for Electromagnetic Compatibility. Compliance was
demonstrated to the following specifications as listed in the Official Journal of the European Communities:

ENIEC 61326-1:2021 EMC requirements for electrical equipment for measurement, control and laboratory use

EN IEC 61326-2-1:2021 Particular requirements for sensitive test and measurement equipment for EMC unprotected
applications 1.2.3
1 To ensure compliance with all applicable EMC standards, use high-quality shielded interface cables.

2 Emissions which exceed the levels required by this standard may occur when the instrument is connected to a test object.

3 This product is intended for use in nonresidential areas only. Use in residential areas may cause electromagnetic interference.

Low Voltage Directive
The instrument meets intent of EC Directive 2014/35/EU for Product Safety. Compliance was demonstrated to the
following specifications as listed in the Official Journal of the European Communities:

EN 61070-1:2010+A1:2019 Safety requirements for electrical equipment for measurement, control and laboratory
use—Part 1: General requirements

EN 61010-2:030:2021 Safety requirements for electrical equipment for measurement, control, and laboratory use—
Part 2-030: Particular requirements for testing and measuring circuits

The design of the instrument has been verified to conform to the following limits:

Mains Supply Connector: Overvoltage Category Il, instrument intended to be supplied from the building wiring at
utilization points (socket outlets and similar)

Measuring Circuit Terminals: No rated measurement category. Terminals not intended to be connected directly to
the mains supply.

Unit: Pollution Degree 2, operating environment where normally only dry, non-conductive pollution occurs.
Temporary conductivity caused by condensation should be expected.

End-of-Life Handling/ WEEE

= The instrument bears this mark to indicate that it complies with the applicable European Union
requirements to Directives 2012/19/EU and 2013/56/EU on Waste Electrical and Electronic Equipment
(WEEE) and Batteries.

The instrument is subject to disposal and recycling regulations that vary by country and region. Many
countries prohibit the disposal of waste electronic equipment in standard waste receptacles. For more
information about proper disposal of your Teledyne LeCroy product, visit teledynelecroy.com/recycle.
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Restriction of Hazardout Substances (RoHS)
Unless otherwise specified, all materials and processes are compliant with RoHS Directive 2011/65/EU in its
entirety, inclusive of any further amendments or modifications of said Directive.

European Contact:*

Teledyne GmbH, European Division
Im Breitspiel 11c

D-69126 Heidelberg, Germany

Tel: +49 6221 8270

United Kingdom

U K The instrument bears this mark to indicate conformity with health, safety, and environmental protection
standards for products sold within Great Britain (England, Wales and Scotland).The design of the product

C n has been verified to conform to the applicable harmonized standards and technical specifications, and
with the relevant Union harmonization legislation.

Australia and New Zealand

The instrument bears this mark to indicate it complies with the EMC provision of the Australian
Communication and Media Authority (ACMA) Radio Communications Act:

AS/NZS CISPR 11:2015, Radiated and Conducted Emissions, Group 1, Class A.

AUSTRALIA / NEW ZEALAND CONTACTS:*

RS Components Pty Ltd. RS Components Ltd.
Suite 326 The Parade West Unit 30 & 31 Warehouse World
Kent Town, South Australia 5067 761 Great South Road

Penrose, Auckland, New Zealand

* Visit teledynelecroy.com/support/contact for the latest contact information.

United States and Canada

The oscilloscope has been certified by Underwriters Laboratories (UL) to conform to the following safety

¢ standards and bears the UL/cUL Listing Mark:

LISTED
UL 61010-1 Third Edition — Safety standard for electrical measuring and test equipment.

UL 61010-2-030 Ed. 2-2018 — Particular requirements for equipment having testing or measuring circuits.

CAN/CSA-C22.2 No. 61010-1-12 — Safety requirements for electrical equipment for measurement, control and
laboratory use.

CAN/CSA-C22.2 No. 61010-2-030:18 — Particular requirements for equipment having testing or measuring circuits

China
h Unless otherwise specified, all materials and processes are compliant with the latest requirements of
30 China RoHS 2.
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ISO Certification
Manufactured under an ISO 9000 Registered Quality Management System.

Intellectual Property
All patents pertaining to the HDO6000B can be found on our website at:

teledynelecroy.com/patents/
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Index

A
acquisition

optimiztion 187
pre-processing 15, 32
sampling mode 39
settings 191
action toolbar 17
activating traces 20
altitude 2
analog
inputs 9
persistence 73
arbitrary function generator 196
at level measurements 87
attenuation 8
auto naming 181
auto save 166
auto zero 34
AUX connectors 11,184
averaging 15,32,119-120

B
bandwidth

limiting 15, 31
BNC connectors 8

C
cable de-embedding 33

calibration 10,184, 187,208
channel 30
descriptor box 15
frequency 9

setup 31

cleaning 198
clock
external 43
reference 43
sample 43
color 192
persistence 73
compliance 210
cooling 2
copy function 120
coupling 8,15, 31
cursor 79
controls 82
readout 16
custom measurements 87

D
date and time 185

DBI 39

de-embedding 9, 33

default setup 172,198

degauss 34

delay 40, 191
post-trigger 41
pre-trigger 40

derated voltage 2

descriptor box 13, 15,20

deskew 15,32

dialogs 17

display 11, 69, 198
controls 69, 192

extended 11,72
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grid 14,69
optimization 187
persistence 73

E
EC compliance 210

email 178-179

enhanced resolution 16, 32,120
enhanced sample rate 15,32
Ethernet 11

extended display 11

external monitor 11, 201
external trigger 9

F
FFT 132

file browser 180
file structure 180, 193, 202
filtering 16
bandwidth 31
LabNotebook entries 180
measurements 93
noise 32,120
firmware 12,199, 202
update 199
version 182
Flashback Recall 173,175
foreground trace 20
frequency 120
response 9,132
front panel 192

G
gain 31,191

gating measurements 84

GPIB 183

grid 14, 46
auto grid 69
indicators 14
intensity 15,70
style 69

H
hard drive 193

histograms 108, 135
WaveScan 148
holdoff 56
horizontal
controls 39
humidity 2

I
impedance 8

import

trcfiles 171

setup panels 172
input impedance 8
inputs

analog 9
intensity

grid 70
interfaces 9

ProBus 8
interleaving 39
interpolation 32,134
inversion 16, 32
IP address 10, 183

L
labelling traces 22,174
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LabNotebook 13,173-174
recall 175
save 173,178
language selection 18
logs
remote control event 183
LXI 183

M
markers 86

mask testing 149
math 114,116
descriptor box 16
function setup 114
graphing 115
on parameters 103
operators 114
measurements 83, 100-101
cursors 79
custom 87
filtering 93
gating 84
graphing 108, 111-112
level 87
markers 86
pass/fail testing 149, 151
processing web 105
readout 102
statistics 84
measurements; status 102

measuring terminals 2

memory 141-142,161, 163
descriptor box 16
memory length 41
multi-grid display 14
multi-stage triggers 54
multi-zoom 75,78

N
noise 16

0]
offset 191

operating environment 2
optimization 187
options 12,186

P
parameter compare 149, 151

parameter math 103
pass/fail testing 149, 151-152
passwords 199,202
pattern trigger 52
persistence 73

histogram 135

trace styles 73

WaveScan 148
position

cursors 7

trace 77
post-trigger delay 41
power

ratings 2

standby 10
preferences 187

pre-processing 15
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pre-trigger delay 40
printing 11,178,192
probes 9

settings 34

tip selection 34
ProBus interface 8
processing web editor 105

Q
Q-Scape display 14, 69

qualified measurements 93
qualified trigger 54

R
real-time sampling mode 39

recall

LabNotebooks 175
reference clock 11,43
remote control 11,183, 192
reports 173,177
rescaling 32,94, 137
restart/reboot 198
restore

waveforms 142
returns 208
RH 2
RIS sampling mode 39
rise and fall time 101
RoHS 211
roll sampling mode 40

S
sample clock 11,43

sample points 41, 140

sample rate 39, 41

sampling mode 39
real-time 39
RIS 39
roll 40
sequence 40
save
data 173
setup panels 173
waveforms 141
screen capture 165,178
search 143
sequence sampling mode 40, 70
serial triggers 192
service 208-209
setup panels 163,172-173
sinx 15,32
software assisted trigger 66
software options 12,186
sound 187
sparse function 140
support 208-209
system
hibernate 10
on/off 10
status 182
timestamp 185

T
tables 164

auto save 166
TCP/IP 11

technical support 208-209
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temperature 2
third-party software 202
timebase 39, 197
clock 43
controls 39
descriptor box 16
top and base 100
touch screen 11,13
calibration 199
language 18
traces
3D 73
activating 19
color 192
context menu 16
copy 120, 141
descriptor boxes 15
label 22,86,173-174
line style 70
persistence 73
recall 171,173
save 161,173
turn on/off 19
track 112-113
TRC files 141
trend 111,113
trigger 46
automating 67
controls 46, 48, 56
counter 56, 191

delay 40

descriptor box 16

holdoff 56

software assisted 66

time 56
TriggerScan 67

u
UL compliance 211

undo 13

units 32,94,137
USBTMC 11,183

user passwords 199, 202
utilities 182

Vv
vertical 30

controls 31
offset 31
resolution 120
sensitivity 30-31

W
waveform files 141, 162

auto save 166
recall 177
WaveScan 143
WaveSource 196
WaveStudio 192
Windows
networking 10
power settings 10
recovery 203
Windows 10 198-199, 201-202

X
XY plots 70
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Z
zoom 28,75

controls 77,192
descriptor box 16
multi-zoom 75

undo 13
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